FAQ
i am at a lost, i setup the db schema , database.yml and etc.... passwords
are correct.

im getting the below error, im trying to get my dashboard to work .....help
any? i also chmod the database.yml file to 660

# mysql -u dashboard -p dashboard_production
Enter password:
ERROR 1045 (28000): Access denied for user 'dashboard'@'localhost' (using
password: YES)

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jeffrey Watts at Jun 21, 2013 at 6:04 pm
    If you followed the instructions on the website it calls for you to create
    a database named "dashboard". However, the example database.yml that comes
    with the software calls for the database to be called
    "dashboard_production". This bit me in the ass, and I suspect that it
    might have bitten you as well. Just create dashboard_production and you
    should be okay.

    J.

    On Fri, Jun 21, 2013 at 12:54 PM, DJames wrote:

    i am at a lost, i setup the db schema , database.yml and etc.... passwords
    are correct.

    im getting the below error, im trying to get my dashboard to work
    .....help any? i also chmod the database.yml file to 660

    # mysql -u dashboard -p dashboard_production
    Enter password:
    ERROR 1045 (28000): Access denied for user 'dashboard'@'localhost' (using
    password: YES)

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • DJames at Jun 21, 2013 at 7:22 pm
    still no luck, i changed the database to database_production, also even
    went into mysql to try to reset please see below......

    # mysqld_safe --skip-grant-tables &

    [1] 27589

    [1]+ Exit 1 mysqld_safe --skip-grant-tables

    # mysql -u root -p
    Enter password:

    mysql> SELECT * FROM mysql.user;

    localhost | dashboard | **********************************
    N | N | N |

    -------+-----------------------+
    7 rows in set (0.00 sec)

    mysql> UPDATE mysql.user SET Password=PASSWORD('[ItPas83LogUSun]') WHERE
    User='[dashboard]';
    Query OK, 0 rows affected (0.00 sec)
    Rows matched: 0 Changed: 0 Warnings: 0


    ]# service mysql stop

    SUCCESS!
    [1]+ Done mysqld_safe --skip-grant-tables

    # service mysql start
    Starting MySQL.. SUCCESS!


      mysql -u dashboard -p
    Enter password:
    ERROR 1045 (28000): Access denied for user 'dashboard'@'localhost' (using
    password: YES)





    On Friday, June 21, 2013 2:04:49 PM UTC-4, Jeffrey Watts wrote:

    If you followed the instructions on the website it calls for you to create
    a database named "dashboard". However, the example database.yml that comes
    with the software calls for the database to be called
    "dashboard_production". This bit me in the ass, and I suspect that it
    might have bitten you as well. Just create dashboard_production and you
    should be okay.

    J.


    On Fri, Jun 21, 2013 at 12:54 PM, DJames <domini...@gmail.com<javascript:>
    wrote:
    i am at a lost, i setup the db schema , database.yml and etc....
    passwords are correct.

    im getting the below error, im trying to get my dashboard to work
    .....help any? i also chmod the database.yml file to 660

    # mysql -u dashboard -p dashboard_production
    Enter password:
    ERROR 1045 (28000): Access denied for user 'dashboard'@'localhost' (using
    password: YES)

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 21, '13 at 5:54p
activeJun 21, '13 at 7:22p
posts3
users2
websitepuppetlabs.com

2 users in discussion

DJames: 2 posts Jeffrey Watts: 1 post

People

Translate

site design / logo © 2021 Grokbase