FAQ
I upgraded our puppetmaster from 2.7.20 to 2.7.22 and puppet dashboard quit
importing reports. I'm getting a failed task with this error message.


undefined method `>=' for nil:NilClass
Backtrace <http://puppetconsoletest.prod.utah.gov:3000/delayed_job_failures>
  /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in `apply'
/usr/share/puppet-dashboard/lib/report_transformer.rb:8:in
`apply' /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in
`inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
`each' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
`inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
`apply' /usr/share/puppet-dashboard/app/models/report.rb:112:in
`create_from_yaml' /usr/share/puppet-dashboard/app/models/report.rb:90:in
`create_from_yaml_file'

Installed RPMS from yum.puppetlabs.com

rpm -qa |grep puppet

puppet-server-2.7.22-1.el5
puppet-2.7.22-1.el5
puppet-dashboard-1.2.23-1.el5

If I back-rev puppet and puppet-server to 2.7.20 it works.

Any Ideas?

Thanks,

Joe

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Bas at Jun 26, 2013 at 1:10 pm
    Hi,

    We do have this same issue when upgrading from 3.1.1 to 3.2.2, any ideas?

    - Bas

    On Thursday, June 20, 2013 11:29:58 PM UTC+2, Joe Benson wrote:

    I upgraded our puppetmaster from 2.7.20 to 2.7.22 and puppet dashboard
    quit importing reports. I'm getting a failed task with this error message.


    undefined method `>=' for nil:NilClass
    Backtrace<http://puppetconsoletest.prod.utah.gov:3000/delayed_job_failures>
    /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in `apply' /usr/share/puppet-dashboard/lib/report_transformer.rb:8:in
    `apply' /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in
    `inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `each' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `apply' /usr/share/puppet-dashboard/app/models/report.rb:112:in
    `create_from_yaml' /usr/share/puppet-dashboard/app/models/report.rb:90:in
    `create_from_yaml_file'

    Installed RPMS from yum.puppetlabs.com

    rpm -qa |grep puppet

    puppet-server-2.7.22-1.el5
    puppet-2.7.22-1.el5
    puppet-dashboard-1.2.23-1.el5

    If I back-rev puppet and puppet-server to 2.7.20 it works.

    Any Ideas?

    Thanks,

    Joe
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Bas Toonk at Jun 26, 2013 at 1:10 pm
    Hi,

    We do have this same issue while upgrading from 3.1.1 to 3.2.2, any ideas?
    It looks like only reports from 2.6 agents are failing.

    - Bas


    On Jun 20, 2013, at 11:29 PM, Joe Benson wrote:

    I upgraded our puppetmaster from 2.7.20 to 2.7.22 and puppet dashboard quit importing reports. I'm getting a failed task with this error message.


    undefined method `>=' for nil:NilClass
    Backtrace<http://puppetconsoletest.prod.utah.gov:3000/delayed_job_failures>
    /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in `apply'
    /usr/share/puppet-dashboard/lib/report_transformer.rb:8:in `apply'
    /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in `inject'
    /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in `each'
    /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in `inject'
    /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in `apply'
    /usr/share/puppet-dashboard/app/models/report.rb:112:in `create_from_yaml'
    /usr/share/puppet-dashboard/app/models/report.rb:90:in `create_from_yaml_file'

    Installed RPMS from yum.puppetlabs.com<http://yum.puppetlabs.com/>

    rpm -qa |grep puppet

    puppet-server-2.7.22-1.el5
    puppet-2.7.22-1.el5
    puppet-dashboard-1.2.23-1.el5

    If I back-rev puppet and puppet-server to 2.7.20 it works.

    Any Ideas?

    Thanks,

    Joe


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com .
    To post to this group, send email to puppet-users@googlegroups.com .
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Kurt Nuke at Aug 5, 2013 at 2:10 pm
    Having the same issue but not from an upgrade -- have not been able to get
    the dashboard to get reports from puppet clients.... yarr
    On Thursday, 20 June 2013 14:29:58 UTC-7, Joe Benson wrote:

    I upgraded our puppetmaster from 2.7.20 to 2.7.22 and puppet dashboard
    quit importing reports. I'm getting a failed task with this error message.


    undefined method `>=' for nil:NilClass
    Backtrace<http://puppetconsoletest.prod.utah.gov:3000/delayed_job_failures>
    /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in `apply' /usr/share/puppet-dashboard/lib/report_transformer.rb:8:in
    `apply' /usr/share/puppet-dashboard/lib/report_transformer.rb:18:in
    `inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `each' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `inject' /usr/share/puppet-dashboard/lib/report_transformer.rb:7:in
    `apply' /usr/share/puppet-dashboard/app/models/report.rb:112:in
    `create_from_yaml' /usr/share/puppet-dashboard/app/models/report.rb:90:in
    `create_from_yaml_file'

    Installed RPMS from yum.puppetlabs.com

    rpm -qa |grep puppet

    puppet-server-2.7.22-1.el5
    puppet-2.7.22-1.el5
    puppet-dashboard-1.2.23-1.el5

    If I back-rev puppet and puppet-server to 2.7.20 it works.

    Any Ideas?

    Thanks,

    Joe
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 20, '13 at 9:31p
activeAug 5, '13 at 2:10p
posts4
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase