FAQ
Hi

fully expecting to have done something silly here but am struggling to debug why I am getting the error:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: No such file or directory - getcwd at /etc/puppet/manifests/nodes.pp:2 on node my.domain.net

the line in question is getting a custom module which has not changed recently.

I was installing http://www.practicalclouds.com/content/guide/pclouds-vcsdeploy-deploy-stuff and having some permissions issues, so I think this may well be to do with permissions. However I am at a loss as to what as everything looks to be ok.

Puppet Master and two client nodes on Debian Wheezy, the clients both return this error. Puppet version 3.2.1 on all 3.

Any suggestions as to where to start debugging this?

Rachel

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jon Jaroker at Dec 10, 2013 at 6:40 pm
    I debugged this same 400 error with 'getcwd' in my 2.7.18 version of
    puppet. I did not find useful information through web searches, so posted
    my debugging steps here: http://jaroker.com/?p=2036

    In my case, the puppet master had been operating normally for over a year.
    I had recently updated my Eclipse IDE and created new manifests. The IDE
    used non UTF-8 encoding on these new files. Subsequent puppet runs on
    various nodes produced this 400-getcwd error: "puppet: Could not retrieve
    catalog from remote server Error 400 on SERVER “Could not parse for
    environment...” getcwd"

    In my case, the solution was to identify DOS-encoded files on the master
    and convert them to unix.

    Jon
    On Wednesday, June 19, 2013 12:28:28 PM UTC-4, Rachel Andrew wrote:

    Hi

    fully expecting to have done something silly here but am struggling to
    debug why I am getting the error:

    Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
    No such file or directory - getcwd at /etc/puppet/manifests/nodes.pp:2 on
    node my.domain.net

    the line in question is getting a custom module which has not changed
    recently.

    I was installing
    http://www.practicalclouds.com/content/guide/pclouds-vcsdeploy-deploy-stuffand having some permissions issues, so I think this may well be to do with
    permissions. However I am at a loss as to what as everything looks to be
    ok.

    Puppet Master and two client nodes on Debian Wheezy, the clients both
    return this error. Puppet version 3.2.1 on all 3.

    Any suggestions as to where to start debugging this?

    Rachel
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/3340e221-be23-405d-baa0-5d08001aedc8%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 19, '13 at 4:28p
activeDec 10, '13 at 6:40p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Rachel Andrew: 1 post Jon Jaroker: 1 post

People

Translate

site design / logo © 2021 Grokbase