FAQ
I'm having some trouble getting a silent install of Firefox to run with the
windows package provider. My manifest looks like this:

package { "Firefox Setup 21.0":
  ensure => installed,
  source => 'C:\\Files\\Firefox Setup 21.0.exe',
  install_options => ['/S']
}
When this is executed by 'puppet apply', the following windows command line
is executed:

cmd.exe /c start /w "C:\\Files\\Firefox Setup 21.0.exe" /S

If this didn't have the '/S' parameter, it would work, but with the '/S'
parameter, it returns an "Incorrect function" error. According to some blog
posts I have found (e.g.
http://www.catonrug.net/2013/04/start-wait-quotes-invalid-switch.html ),
this is a result of the "START" command believing that the '/S' switch is
intended for the "START" command, rather than passing it to the Firefox
setup exe.

One way of resolving this is to add a "title" parameter to the START
command, which makes it interpret the rest of the line as parameters.

First, am I missing something? Is anybody else using the EXE package
provider and seeing this problem?

If this is a real problem, should I submit a bug and patch, or would
someone else like to verify my assumptions?

Thanks!
Josh

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 18, '13 at 10:56p
activeJun 18, '13 at 10:56p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Josh Rivers: 1 post

People

Translate

site design / logo © 2021 Grokbase