FAQ
I'm trying to set up gitlab on the RHEL 6 server
using https://github.com/sbadia/puppet-gitlab with modifications to use RVM.

The problem I'm having is gitlab service wouldn't start even it says so.
Here is the service code:
service {
'gitlab':
ensure => running,
pattern => 'puma',
hasrestart => true,
enable => true,
hasstatus => false,
subscribe => File['/etc/init.d/gitlab'],
}

Here is the message from agent with debug on:
Debug: Service[gitlab](provider=redhat): Executing 'ps -ef'
Debug: Executing '/sbin/chkconfig gitlab'
Debug: Executing '/sbin/service gitlab start'
Debug: Executing '/sbin/chkconfig gitlab'
Notice: /Stage[main]/Gitlab::Server/Service[gitlab]/ensure: ensure changed
'stopped' to 'running'
Debug: /Stage[main]/Gitlab::Server/Service[gitlab]: The container
Class[Gitlab::Server] will propagate my refresh event
Info: /Stage[main]/Gitlab::Server/Service[gitlab]: Unscheduling refresh on
Service[gitlab]
Debug: Class[Gitlab::Server]: The container Stage[main] will propagate my
refresh event
Debug: Finishing transaction 69986165764840


It did run /sbin/service gitlab start, but nothing happend. The gitlab
service is still stopped and nothing appears in the server log. I noticed
one line saying "Unscheduling refresh on Service[gitlab]" and wondering if
it has something to do with it. But why unscheduling my refresh? Any
advice? Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Rilindo Foster at Jun 15, 2013 at 6:12 pm
    I guess this piece of code is what you created , because puppet-gitlab has that already defined service.pp already has that defined:

    file {
         '/etc/init.d/gitlab':
           ensure => file,
           content => template('gitlab/gitlab.init.erb'),
           owner => root,
           group => root,
           mode => '0755',
           notify => Service['gitlab'],
           require => Exec['Setup gitlab DB'];
       }

       service {
         'gitlab':
           ensure => running,
           require => File['/etc/init.d/gitlab'],
           pattern => 'puma',
           hasrestart => true,
           enable => true;
       }


    If that is the case, the service code you created is probably not necessary. In fact, it is probably getting the way of the puppet module trying to start up gitlab.

      - Rilindo
    On Jun 14, 2013, at 2:54 AM, Pan Luo wrote:

    I'm trying to set up gitlab on the RHEL 6 server using https://github.com/sbadia/puppet-gitlab with modifications to use RVM.

    The problem I'm having is gitlab service wouldn't start even it says so. Here is the service code:
    service {
    'gitlab':
    ensure => running,
    pattern => 'puma',
    hasrestart => true,
    enable => true,
    hasstatus => false,
    subscribe => File['/etc/init.d/gitlab'],
    }

    Here is the message from agent with debug on:
    Debug: Service[gitlab](provider=redhat): Executing 'ps -ef'
    Debug: Executing '/sbin/chkconfig gitlab'
    Debug: Executing '/sbin/service gitlab start'
    Debug: Executing '/sbin/chkconfig gitlab'
    Notice: /Stage[main]/Gitlab::Server/Service[gitlab]/ensure: ensure changed 'stopped' to 'running'
    Debug: /Stage[main]/Gitlab::Server/Service[gitlab]: The container Class[Gitlab::Server] will propagate my refresh event
    Info: /Stage[main]/Gitlab::Server/Service[gitlab]: Unscheduling refresh on Service[gitlab]
    Debug: Class[Gitlab::Server]: The container Stage[main] will propagate my refresh event
    Debug: Finishing transaction 69986165764840


    It did run /sbin/service gitlab start, but nothing happend. The gitlab service is still stopped and nothing appears in the server log. I noticed one line saying "Unscheduling refresh on Service[gitlab]" and wondering if it has something to do with it. But why unscheduling my refresh? Any advice? Thanks.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 15, '13 at 2:05p
activeJun 15, '13 at 6:12p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Rilindo Foster: 1 post Pan Luo: 1 post

People

Translate

site design / logo © 2022 Grokbase