FAQ
Hello,

My newb question is how can I debug what is going wrong with more detail.
I installed module wavesoftware/puppet-glassfish and I'm trying to use it
in a master-agent configuration on my proxmox openvz containers.
I run:

    - puppet agent -t -d -v

Which gives me the error:

    - Error: Could not find a suitable provider for domain

I fail to find any information in the debug trail to identify the problem.

With Regards,
Kobe.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ken Barber at Jun 12, 2013 at 4:15 pm
    Looks to me like there is only 1 provider for that module, and its
    confined to osfamily 'RedHat':

    https://github.com/wavesoftware/puppet-glassfish/blob/master/lib/puppet/provider/domain/el.rb#L6-L7

    ken.
    On Wed, Jun 12, 2013 at 12:29 PM, Kobe Nys wrote:
    Hello,

    My newb question is how can I debug what is going wrong with more detail.
    I installed module wavesoftware/puppet-glassfish and I'm trying to use it in
    a master-agent configuration on my proxmox openvz containers.
    I run:

    puppet agent -t -d -v

    Which gives me the error:

    Error: Could not find a suitable provider for domain

    I fail to find any information in the debug trail to identify the problem.

    With Regards,
    Kobe.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Kobe Nys at Jun 12, 2013 at 7:10 pm
    Thanks, apparently there is newer version which shouldn't have this problem
    it's just not available in the forge.
    https://github.com/fatmcgav/puppet-glassfish

    With Regards,
    Kobe.
    On Wednesday, 12 June 2013 18:15:02 UTC+2, Ken Barber wrote:

    Looks to me like there is only 1 provider for that module, and its
    confined to osfamily 'RedHat':


    https://github.com/wavesoftware/puppet-glassfish/blob/master/lib/puppet/provider/domain/el.rb#L6-L7

    ken.

    On Wed, Jun 12, 2013 at 12:29 PM, Kobe Nys <ko...@allnice.be <javascript:>>
    wrote:
    Hello,

    My newb question is how can I debug what is going wrong with more detail.
    I installed module wavesoftware/puppet-glassfish and I'm trying to use it in
    a master-agent configuration on my proxmox openvz containers.
    I run:

    puppet agent -t -d -v

    Which gives me the error:

    Error: Could not find a suitable provider for domain

    I fail to find any information in the debug trail to identify the problem.
    With Regards,
    Kobe.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 12, '13 at 3:23p
activeJun 12, '13 at 7:10p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Kobe Nys: 2 posts Ken Barber: 1 post

People

Translate

site design / logo © 2021 Grokbase