FAQ

On Thursday, December 1, 2011 7:55:42 PM UTC+11, Chris Phillips wrote:
Howdy,

I've been getting this issue for about a month in dashboard. All our
nodes poll on a cronjob between 00:00 and 01:00 daily, but one node
has been getting this as a failed task for a while, with the yaml
files building up on the server. Outside of this one cronjob, other
puppet runs on the same node are running just fine. The backtrace on
dashboard is:

Importing report report-1009-84.yaml at 2011-11-22 00:33 GMTValidation
failed: Host already has a report for time and kind
Backtrace

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/validations.rb:1102:in
`save_without_dirty!'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/dirty.rb:87:in
`save_without_transactions!'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
`save!'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:136:in
`transaction'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:182:in
`transaction'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
`save!'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:208:in
`rollback_active_record_state!'

/usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
`save!'
/usr/share/puppet-dashboard/app/models/report.rb:113:in `create_from_yaml'
/usr/share/puppet-dashboard/app/models/report.rb:86:in
`create_from_yaml_file'


Any pointers appreciated.

Thanks

Chris
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Luke Vidler at Jun 11, 2013 at 4:06 am
    Me Three, same versions and errors - Did you guys work out how to fix it
    yet?
    On Thursday, December 1, 2011 7:55:42 PM UTC+11, Chris Phillips wrote:

    Howdy,

    I've been getting this issue for about a month in dashboard. All our
    nodes poll on a cronjob between 00:00 and 01:00 daily, but one node
    has been getting this as a failed task for a while, with the yaml
    files building up on the server. Outside of this one cronjob, other
    puppet runs on the same node are running just fine. The backtrace on
    dashboard is:

    Importing report report-1009-84.yaml at 2011-11-22 00:33 GMTValidation
    failed: Host already has a report for time and kind
    Backtrace

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/validations.rb:1102:in
    `save_without_dirty!'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/dirty.rb:87:in
    `save_without_transactions!'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
    `save!'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:136:in
    `transaction'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:182:in
    `transaction'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
    `save!'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:208:in
    `rollback_active_record_state!'

    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
    `save!'
    /usr/share/puppet-dashboard/app/models/report.rb:113:in `create_from_yaml'
    /usr/share/puppet-dashboard/app/models/report.rb:86:in
    `create_from_yaml_file'


    Any pointers appreciated.

    Thanks

    Chris
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Keith Burdis at Jun 11, 2013 at 7:17 am
    This could be an issue with time on the host being inconsistent. Is it
    configured to use NTP to sync against a time server?

       - Keith
    On 11 Jun 2013 05:06, "Luke Vidler" wrote:

    Me Three, same versions and errors - Did you guys work out how to fix it
    yet?
    On Thursday, December 1, 2011 7:55:42 PM UTC+11, Chris Phillips wrote:

    Howdy,

    I've been getting this issue for about a month in dashboard. All our
    nodes poll on a cronjob between 00:00 and 01:00 daily, but one node
    has been getting this as a failed task for a while, with the yaml
    files building up on the server. Outside of this one cronjob, other
    puppet runs on the same node are running just fine. The backtrace on
    dashboard is:

    Importing report report-1009-84.yaml at 2011-**11-22 00:33 GMTValidation
    failed: Host already has a report for time and kind
    Backtrace
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/validations.rb:**1102:in
    `save_without_dirty!'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/dirty.rb:87:in
    `save_without_transactions!'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/transactions.rb:**200:in
    `save!'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/connection_**adapters/abstract/database_**
    statements.rb:136:in
    `transaction'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/transactions.rb:**182:in
    `transaction'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/transactions.rb:**200:in
    `save!'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/transactions.rb:**208:in
    `rollback_active_record_state!**'
    /usr/share/puppet-dashboard/**vendor/rails/activerecord/lib/**
    active_record/transactions.rb:**200:in
    `save!'
    /usr/share/puppet-dashboard/**app/models/report.rb:113:in
    `create_from_yaml'
    /usr/share/puppet-dashboard/**app/models/report.rb:86:in
    `create_from_yaml_file'


    Any pointers appreciated.

    Thanks

    Chris

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Steven Nemetz at Jun 11, 2013 at 12:09 pm
    Every time that I've received this error, it was because 2 different hosts had the same cert name.
    In my case a problem caused by system cloning or a system template that contained a cert name.

    Hope that helps,

    Steven

    Date: Tue, 11 Jun 2013 08:17:42 +0100
    Subject: Re: [Puppet Users] Re: Validation failed: Host already has a report for time and kind
    From: keith@burdis.org
    To: puppet-users@googlegroups.com

    This could be an issue with time on the host being inconsistent. Is it configured to use NTP to sync against a time server?
       - Keith
    On 11 Jun 2013 05:06, "Luke Vidler" wrote:

    Me Three, same versions and errors - Did you guys work out how to fix it yet?

    On Thursday, December 1, 2011 7:55:42 PM UTC+11, Chris Phillips wrote:
    Howdy,I've been getting this issue for about a month in dashboard. All our
    nodes poll on a cronjob between 00:00 and 01:00 daily, but one node
    has been getting this as a failed task for a while, with the yaml

    files building up on the server. Outside of this one cronjob, other
    puppet runs on the same node are running just fine. The backtrace on
    dashboard is:
    Importing report report-1009-84.yaml at 2011-11-22 00:33 GMTValidation

    failed: Host already has a report for time and kind
    Backtrace
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/validations.rb:1102:in
    `save_without_dirty!'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/dirty.rb:87:in

    `save_without_transactions!'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in
    `save!'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:136:in

    `transaction'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:182:in
    `transaction'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in

    `save!'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:208:in
    `rollback_active_record_state!'
    /usr/share/puppet-dashboard/vendor/rails/activerecord/lib/active_record/transactions.rb:200:in

    `save!'
    /usr/share/puppet-dashboard/app/models/report.rb:113:in `create_from_yaml'
    /usr/share/puppet-dashboard/app/models/report.rb:86:in `create_from_yaml_file'

    Any pointers appreciated.

    Thanks
    Chris










    --

    You received this message because you are subscribed to the Google Groups "Puppet Users" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.

    To post to this group, send email to puppet-users@googlegroups.com.

    Visit this group at http://groups.google.com/group/puppet-users?hl=en.

    For more options, visit https://groups.google.com/groups/opt_out.










    --

    You received this message because you are subscribed to the Google Groups "Puppet Users" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.

    To post to this group, send email to puppet-users@googlegroups.com.

    Visit this group at http://groups.google.com/group/puppet-users?hl=en.

    For more options, visit https://groups.google.com/groups/opt_out.






    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 11, '13 at 4:06a
activeJun 11, '13 at 12:09p
posts4
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase