FAQ
Hello,

I am having a problem with reports from a puppet node. After report is sent
the following error occurs on my puppet master:

*localhost puppet-master[31237]: Report processor failed: Connection timed
out - connect(2)*

i really don't know what is a problem.

I have the following configuration on puppetmaster (Puppet v3.2.1):

[master]
reports = store, http
reporturl = http://XXXXX:3000/reports/upload

on agent (Puppet v2.7.11)

[agent]
report=true

Dashboard GUI is running.

On agent --debug does not show anything:

notice: Finished catalog run in 93.11 seconds
debug: Executing '/etc/puppet/etckeeper-commit-post'
debug: Value of 'preferred_serialization_format' (pson) is invalid for
report, using default (b64_zlib_yaml)
debug: report supports formats: b64_zlib_yaml raw yaml; using b64_zlib_yaml

Master started with debug and verbose also:

Debug: Processing report from ucsadm.ucstech.eu with processor
Puppet::Reports::Store
Debug: Processing report from ucsadm.ucstech.eu with processor
Puppet::Reports::Http
Error: Report processor failed: Connection timed out - connect(2)

How can I turn more debug info?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Zgrega at Jun 6, 2013 at 5:41 am
    I will answer to myself.
    There is an option in /usr/share/puppet-dashboard/config/settings.yml which
    in my case has to b e set to true

    disable_legacy_report_upload_url: true


    On Wednesday, June 5, 2013 8:23:00 AM UTC+2, zgrega wrote:

    Hello,

    I am having a problem with reports from a puppet node. After report is
    sent the following error occurs on my puppet master:

    *localhost puppet-master[31237]: Report processor failed: Connection
    timed out - connect(2)*

    i really don't know what is a problem.

    I have the following configuration on puppetmaster (Puppet v3.2.1):

    [master]
    reports = store, http
    reporturl = http://XXXXX:3000/reports/upload

    on agent (Puppet v2.7.11)

    [agent]
    report=true

    Dashboard GUI is running.

    On agent --debug does not show anything:

    notice: Finished catalog run in 93.11 seconds
    debug: Executing '/etc/puppet/etckeeper-commit-post'
    debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (b64_zlib_yaml)
    debug: report supports formats: b64_zlib_yaml raw yaml; using b64_zlib_yaml

    Master started with debug and verbose also:

    Debug: Processing report from ucsadm.ucstech.eu with processor
    Puppet::Reports::Store
    Debug: Processing report from ucsadm.ucstech.eu with processor
    Puppet::Reports::Http
    Error: Report processor failed: Connection timed out - connect(2)

    How can I turn more debug info?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Zgrega at Jun 6, 2013 at 5:42 am
    I will answer to myself.
    There is an option in /usr/share/puppet-dashboard/config/settings.yml which
    in my case has to b e set to true

    disable_legacy_report_upload_url: true

    On Wednesday, June 5, 2013 8:23:00 AM UTC+2, zgrega wrote:

    Hello,

    I am having a problem with reports from a puppet node. After report is
    sent the following error occurs on my puppet master:

    *localhost puppet-master[31237]: Report processor failed: Connection
    timed out - connect(2)*

    i really don't know what is a problem.

    I have the following configuration on puppetmaster (Puppet v3.2.1):

    [master]
    reports = store, http
    reporturl = http://XXXXX:3000/reports/upload

    on agent (Puppet v2.7.11)

    [agent]
    report=true

    Dashboard GUI is running.

    On agent --debug does not show anything:

    notice: Finished catalog run in 93.11 seconds
    debug: Executing '/etc/puppet/etckeeper-commit-post'
    debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (b64_zlib_yaml)
    debug: report supports formats: b64_zlib_yaml raw yaml; using b64_zlib_yaml

    Master started with debug and verbose also:

    Debug: Processing report from ucsadm.ucstech.eu with processor
    Puppet::Reports::Store
    Debug: Processing report from ucsadm.ucstech.eu with processor
    Puppet::Reports::Http
    Error: Report processor failed: Connection timed out - connect(2)

    How can I turn more debug info?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 5, '13 at 1:22p
activeJun 6, '13 at 5:42a
posts3
users1
websitepuppetlabs.com

1 user in discussion

Zgrega: 3 posts

People

Translate

site design / logo © 2021 Grokbase