FAQ
Hi all:
good day!
when i want to start puppet-dashboard,i got this message below

[root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
start
Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
vendor/gems h
                               as no specification file. Run 'rake
gems:refresh_specs' to fix this.
config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
file. Ru
                           n 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
specificatio
                               n file. Run 'rake gems:refresh_specs' to fix
this.
config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
file. Ru
                           n 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
file. R
                         un 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
specification f
                                 ile. Run 'rake gems:refresh_specs' to fix
this.
config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
specifi
                         cation file. Run 'rake gems:refresh_specs' to fix
this.
config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
file. Ru
                           n 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
specification fil
                                   e. Run 'rake gems:refresh_specs' to fix
this.
config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
file. Ru
                           n 'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
specification
                                file. Run 'rake gems:refresh_specs' to fix
this.
config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no specification
file
                       . Run 'rake gems:refresh_specs' to fix this.
=> Booting WEBrick
=> Rails 2.3.17 application starting on http://0.0.0.0:3000
                                                            [FAILED]
[root@ers-devesx06-vm235 puppet-dashboard]# service mysqld start
Starting mysqld: [ OK ]
[root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
start
Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
vendor/gems has no specificati
                                on file. Run 'rake gems:refresh_specs' to
fix this.
config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
specification file. Run 'rake
                               gems:refresh_specs' to fix this.
config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
file. Run 'rake gems:ref
                          resh_specs' to fix this.
config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
specification file. Run 'rake ge
                                  ms:refresh_specs' to fix this.
config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
specification file. Run
                         'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
specification file. Run 'rake gems
                                    :refresh_specs' to fix this.
config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
specification file. Run 'rake g
                                ems:refresh_specs' to fix this.
config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no specification
file. Run 'rake gems:
                      refresh_specs' to fix this.
=> Booting WEBrick
=> Rails 2.3.17 application starting on http://0.0.0.0:3000
                                                            [FAILED]

*then i run this command*
[root@ers-devesx06-vm235 puppet-dashboard]# rake gems:refresh_specs
(in /usr/share/puppet-dashboard)
config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
file. Run 'rake gems:ref
                          resh_specs' to fix this.
config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
specification file. Run 'rake
                               gems:refresh_specs' to fix this.
config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
file. Run 'rake gems:ref
                          resh_specs' to fix this.
config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
specification file. Run 'rake ge
                                  ms:refresh_specs' to fix this.
config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
specification file. Run
                         'rake gems:refresh_specs' to fix this.
config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
specification file. Run 'rake gems
                                    :refresh_specs' to fix this.
config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
file. Run 'rake gems:refr
                          esh_specs' to fix this.
config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
specification file. Run 'rake g
                                ems:refresh_specs' to fix this.
config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no specification
file. Run 'rake gems:
                      refresh_specs' to fix this.
DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
deprecated. Use lib/tasks
                           instead. (called from
/usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)
Gem rspec not loaded locally - writing out current spec.
Gem rdoc not loaded locally - writing out current spec.
Gem will_paginate not loaded locally - writing out current spec.
Gem rack not loaded locally - writing out current spec.
Gem mocha not loaded locally - writing out current spec.
Gem rspec-rails not loaded locally - writing out current spec.
Gem thoughtbot-shoulda not loaded locally - writing out current spec.
Gem sass not loaded locally - writing out current spec.
Gem json_pure not loaded locally - writing out current spec.
Gem haml not loaded locally - writing out current spec.
Gem factory_girl not loaded locally - writing out current spec.
Gem daemons not loaded locally - writing out current spec.
but still fail and no error message
[root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
start
Starting Puppet Dashboard: => Booting WEBrick
=> Rails 2.3.17 application starting on http://0.0.0.0:3000
                                                            [FAILED]
[root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
start
Starting Puppet Dashboard: => Booting WEBrick
=> Rails 2.3.17 application starting on http://0.0.0.0:3000
                                                            [FAILED]



Can someone give me some adivice,thanks a lot.

BR,
Spencer

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Spencer hong at Jun 3, 2013 at 5:44 am
    when i try to start service,but i can't see any error log =(

    [root@ers-devesx06-vm235 share]# cd puppet-dashboard/
    [root@ers-devesx06-vm235 puppet-dashboard]# ls
    app certs db ext log Rakefile spec tmp VERSION
    bin config examples lib public script spool vendor
    [root@ers-devesx06-vm235 puppet-dashboard]# cd log
    [root@ers-devesx06-vm235 log]# ls
    development.log development.log-20130601 production.log
      production.log-20130531
    [root@ers-devesx06-vm235 log]# cat production.log
    [root@ers-devesx06-vm235 log]# /etc/init.d/puppet-dashboard start
    Starting Puppet Dashboard: => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
                                                                [FAILED]

    spencer hong於 2013年5月30日星期四UTC+8上午10時50分01秒寫道:
    Hi all:
    good day!
    when i want to start puppet-dashboard,i got this message below

    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
    vendor/gems h
    as no specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specificatio
    n file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. R
    un 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification f
    ile. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specifi
    cation file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification fil
    e. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification
    file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file
    . Run 'rake gems:refresh_specs' to fix
    this.
    => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]
    [root@ers-devesx06-vm235 puppet-dashboard]# service mysqld start
    Starting mysqld: [ OK ]
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
    vendor/gems has no specificati
    on file. Run 'rake gems:refresh_specs' to
    fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake ge
    ms:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification file. Run 'rake gems
    :refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake g
    ems:refresh_specs' to fix this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:
    refresh_specs' to fix this.
    => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]

    *then i run this command*
    [root@ers-devesx06-vm235 puppet-dashboard]# rake gems:refresh_specs
    (in /usr/share/puppet-dashboard)
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake ge
    ms:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification file. Run 'rake gems
    :refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake g
    ems:refresh_specs' to fix this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:
    refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks
    instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)
    Gem rspec not loaded locally - writing out current spec.
    Gem rdoc not loaded locally - writing out current spec.
    Gem will_paginate not loaded locally - writing out current spec.
    Gem rack not loaded locally - writing out current spec.
    Gem mocha not loaded locally - writing out current spec.
    Gem rspec-rails not loaded locally - writing out current spec.
    Gem thoughtbot-shoulda not loaded locally - writing out current spec.
    Gem sass not loaded locally - writing out current spec.
    Gem json_pure not loaded locally - writing out current spec.
    Gem haml not loaded locally - writing out current spec.
    Gem factory_girl not loaded locally - writing out current spec.
    Gem daemons not loaded locally - writing out current spec.
    but still fail and no error message
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]



    Can someone give me some adivice,thanks a lot.

    BR,
    Spencer
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Spencer hong at Jun 3, 2013 at 5:47 am
    Here is the log~
    [root@ers-devesx06-vm235 puppet-dashboard]# ./script/server -e production
    => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    Database isn't the current migration version: expected , got 0
    You must either run 'rake db:migrate' or set environmental variable
    NO_MIGRATION_CHECK


    spencer hong於 2013年5月30日星期四UTC+8上午10時50分01秒寫道:
    Hi all:
    good day!
    when i want to start puppet-dashboard,i got this message below

    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
    vendor/gems h
    as no specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specificatio
    n file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. R
    un 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification f
    ile. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specifi
    cation file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification fil
    e. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Ru
    n 'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification
    file. Run 'rake gems:refresh_specs' to fix
    this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file
    . Run 'rake gems:refresh_specs' to fix
    this.
    => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]
    [root@ers-devesx06-vm235 puppet-dashboard]# service mysqld start
    Starting mysqld: [ OK ]
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: config.gem: Unpacked gem rspec-1.3.2 in
    vendor/gems has no specificati
    on file. Run 'rake gems:refresh_specs' to
    fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake ge
    ms:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification file. Run 'rake gems
    :refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake g
    ems:refresh_specs' to fix this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:
    refresh_specs' to fix this.
    => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]

    *then i run this command*
    [root@ers-devesx06-vm235 puppet-dashboard]# rake gems:refresh_specs
    (in /usr/share/puppet-dashboard)
    config.gem: Unpacked gem rspec-1.3.2 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rdoc-3.6.1 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem will_paginate-2.3.15 in vendor/gems has no
    specification file. Run 'rake
    gems:refresh_specs' to fix this.
    config.gem: Unpacked gem rack-1.1.6 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem mocha-0.9.7 in vendor/gems has no specification
    file. Run 'rake gems:ref
    resh_specs' to fix this.
    config.gem: Unpacked gem rspec-rails-1.3.4 in vendor/gems has no
    specification file. Run 'rake ge
    ms:refresh_specs' to fix this.
    config.gem: Unpacked gem thoughtbot-shoulda-2.10.2 in vendor/gems has no
    specification file. Run
    'rake gems:refresh_specs' to fix this.
    config.gem: Unpacked gem sass-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem json_pure-1.7.7 in vendor/gems has no
    specification file. Run 'rake gems
    :refresh_specs' to fix this.
    config.gem: Unpacked gem haml-3.1.2 in vendor/gems has no specification
    file. Run 'rake gems:refr
    esh_specs' to fix this.
    config.gem: Unpacked gem factory_girl-1.3.3 in vendor/gems has no
    specification file. Run 'rake g
    ems:refresh_specs' to fix this.
    config.gem: Unpacked gem daemons-1.0.10 in vendor/gems has no
    specification file. Run 'rake gems:
    refresh_specs' to fix this.
    DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks are
    deprecated. Use lib/tasks
    instead. (called from
    /usr/share/puppet-dashboard/vendor/rails/railties/lib/tasks/rails.rb:10)
    Gem rspec not loaded locally - writing out current spec.
    Gem rdoc not loaded locally - writing out current spec.
    Gem will_paginate not loaded locally - writing out current spec.
    Gem rack not loaded locally - writing out current spec.
    Gem mocha not loaded locally - writing out current spec.
    Gem rspec-rails not loaded locally - writing out current spec.
    Gem thoughtbot-shoulda not loaded locally - writing out current spec.
    Gem sass not loaded locally - writing out current spec.
    Gem json_pure not loaded locally - writing out current spec.
    Gem haml not loaded locally - writing out current spec.
    Gem factory_girl not loaded locally - writing out current spec.
    Gem daemons not loaded locally - writing out current spec.
    but still fail and no error message
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]
    [root@ers-devesx06-vm235 puppet-dashboard]# /etc/init.d/puppet-dashboard
    start
    Starting Puppet Dashboard: => Booting WEBrick
    => Rails 2.3.17 application starting on http://0.0.0.0:3000
    [FAILED]



    Can someone give me some adivice,thanks a lot.

    BR,
    Spencer
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 30, '13 at 6:38a
activeJun 3, '13 at 5:47a
posts3
users1
websitepuppetlabs.com

1 user in discussion

Spencer hong: 3 posts

People

Translate

site design / logo © 2022 Grokbase