FAQ
Greetings.
Puppet 3.1.1, Debian 7.0

I am trying to sync resource(file) from master to agent host.
When "schedule" metaparameter is not defined - sync is successfull.
if not - schedule is skipped and sync does not start

clock is synchronized, timezone is ok.

part of master config:

*schedule { "test":*
* range => "18-19", *
* period => daily,*
* }*
*class sl_movie_main*
*{*
* file {"/tmp/rolik.mpg":*
* ensure => file,*
* owner => root,*
* mode => 777,*
* schedule => "test",*
* source => "puppet:///media/company/sl.movie.main.mpg",*
*}*

Debug from agent:
*Debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson*
*Debug: Finishing transaction 70219949229800*
*Debug: catalog supports formats: b64_zlib_yaml dot pson raw yaml; using
pson*
*Info: Caching catalog for somename*
*Debug: Creating default schedules*
*Debug: Loaded state in 0.00 seconds*
*Info: Applying configuration version '1369234836'*
*Debug: /Schedule[daily]: Skipping device resources because running on a
host*
*Debug: /Schedule[monthly]: Skipping device resources because running on a
host*
*Debug: /Schedule[hourly]: Skipping device resources because running on a
host*
*Debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson*
*Debug: /Stage[main]/Sl_movie_main/File[/tmp/rolik.mpg]: Not scheduled*
*Debug: /Stage[main]/Sl_movie_kiev/File[/tmp/rolik.kiev.mpg]: Not scheduled*
*Debug: /Schedule[never]: Skipping device resources because running on a
host*
*Debug: /Stage[main]//Schedule[test]: Skipping device resources because
running on a host*
*Debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson*
*Debug: /Schedule[weekly]: Skipping device resources because running on a
host*
*Debug: /Schedule[puppet]: Skipping device resources because running on a
host*
*Debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson*
*Debug: Finishing transaction 70219948774900*
*Debug: Storing state*
*Debug: Stored state in 0.02 seconds*
*Notice: Finished catalog run in 1.51 seconds*
*Debug: Value of 'preferred_serialization_format' (pson) is invalid for
report, using default (b64_zlib_yaml)*
*Debug: report supports formats: b64_zlib_yaml raw yaml; using b64_zlib_yaml
*
*ls: cannot access /tmp/rol*: No such file or directory*
*Debug: Finishing transaction 70219949503360*

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 22, '13 at 4:14p
activeMay 22, '13 at 4:14p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Михаил Павленко: 1 post

People

Translate

site design / logo © 2022 Grokbase