FAQ
So I am having issue with a manifest that contains the class below. I was
in hopes somebody could point me in the correct direction;

Original class, works on many others systems I have this deployed to,

class base::yum_plugins{
         require base::yum_repos
         package {yum-versionlock: ensure => latest}
         package {yum-security: ensure => latest}
}
However on a machine we are building a template out of it fails.


Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest --qf
%{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
'
Error: Could not update: Could not find package yum-versionlock
Error: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
change from absent to latest failed: Could not update: Could not find
package yum-versionlock
Notice: /File[/etc/yum/pluginconf.d/versionlock.list]: Dependency
Package[yum-versionlock] has failures: true
Warning: /File[/etc/yum/pluginconf.d/versionlock.list]: Skipping because of
failed dependencies
Debug: Finishing transaction 70184260275260
Debug: Storing state
Debug: Stored state in 0.02 seconds
Notice: Finished catalog run in 6.66 seconds
Debug: Value of 'preferred_serialization_format' (pson) is invalid for
report, using default (yaml)
Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
[root@rhel6Template ~]# ^C
[root@rhel6Template ~]# /bin/rpm -q yum-versionlock
package yum-versionlock is not installed
[root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
yum-plugin-versionlock-1.1.30-14.el6.noarch

Change class to represent yum-plugin-versionlock and it fails slightly
different,

class base::yum_plugins{
         require base::yum_repos
         package {yum-plugin-versionlock: ensure => latest}
         package {yum-security: ensure => latest}

Error: Failed to apply catalog: Could not find dependency
Package[yum-versionlock] for File[/etc/yum/pluginconf.d/versionlock.list

Yet
Setting up Install Process
Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
latest version
Nothing to do

and

[root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
[root@rhel6Template pluginconf.d]# ls
product-id.conf rhnplugin.conf security.conf subscription-manager.conf
versionlock.conf versionlock.list
Any help woudld be greatly appreciated;
Mike




--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Keith Burdis at May 16, 2013 at 2:13 pm
    This is often an issue with the underlying yum command being executed.

    Try running:

    # puppet apply --verbose --debug --execute 'package
    {yum-plugin-versionlock: ensure => latest}'

    to see what is happening.

    On my host this shows that '/usr/bin/yum -d 0 -e 0 -y install
    yum-plugin-versionlock' is being executed so I'd try this command manually
    without the -y to see if I get any errors.

       - Keith

    On 16 May 2013 13:35, wrote:

    So I am having issue with a manifest that contains the class below. I was
    in hopes somebody could point me in the correct direction;

    Original class, works on many others systems I have this deployed to,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.


    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/versionlock.list]: Skipping because
    of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-14.el6.noarch

    Change class to represent yum-plugin-versionlock and it fails slightly
    different,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}

    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/versionlock.list

    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do

    and

    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf subscription-manager.conf
    versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike




    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Michael R Bowden at May 16, 2013 at 3:26 pm
    So this seems to be different between RHEL5 and RHEL6 the command you
    suggested ran fine.
    Here it is on another RHEL6 box

    [root@crypt mbowden]# puppet agent --verbose --onetime --no-daemonize
    info: Caching catalog for crypt.bowdoin.edu
    info: Applying configuration version '1368708690'
    err: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure: change
    from absent to latest failed: Could not update: Could not find package
    yum-versionlock at
    /etc/puppet/modules/base/manifests/yum_plugins.pp:3
    notice:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Dependency Package[yum-versionlock] has failures: true
    warning:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Skipping because of failed dependencies
    err: /Stage[main]/Base::Yum_plugins/Package[yum-security]/ensure: change
    from absent to latest failed: Could not update: Could not find package
    yum-security at /etc/
    puppet/modules/base/manifests/yum_plugins.pp:4
    notice: Finished catalog run in 9.92 seconds
    [root@crypt mbowden]# yum install yum-versionlock
    Loaded plugins: product-id, rhnplugin, security, subscription-manager,
    versionlock
    This system is not registered to Red Hat Subscription Management. You can
    use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do
    [root@crypt mbowden]# puppet apply --verbose --execute 'package
    {yum-plugin-versionlock: ensure => latest}'
    info: Applying configuration version '1368718137'
    notice: Finished catalog run in 3.42 seconds

    On Thursday, May 16, 2013 10:12:33 AM UTC-4, Keith Burdis wrote:

    This is often an issue with the underlying yum command being executed.

    Try running:

    # puppet apply --verbose --debug --execute 'package
    {yum-plugin-versionlock: ensure => latest}'

    to see what is happening.

    On my host this shows that '/usr/bin/yum -d 0 -e 0 -y install
    yum-plugin-versionlock' is being executed so I'd try this command manually
    without the -y to see if I get any errors.

    - Keith

    On 16 May 2013 13:35, <michael....@gmail.com <javascript:>> wrote:

    So I am having issue with a manifest that contains the class below. I
    was in hopes somebody could point me in the correct direction;

    Original class, works on many others systems I have this deployed to,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.


    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/versionlock.list]: Skipping because
    of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-14.el6.noarch

    Change class to represent yum-plugin-versionlock and it fails slightly
    different,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}

    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/versionlock.list

    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do

    and

    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf
    subscription-manager.conf versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike




    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Keith Burdis at May 16, 2013 at 3:39 pm
    This package doesn't appear to exist in the default repositories for
    RHEL/CentOS 5:

    # cat /etc/redhat-release
    CentOS release 5.9 (Final)
    # yum install yum-plugin-versionlock
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
      * base: ftp.heanet.ie
      * extras: ftp.heanet.ie
      * updates: ftp.heanet.ie
    Setting up Install Process
    No package yum-plugin-versionlock available.
    Nothing to do

    Since you do seem to have the yum-plugin-versionlock package installed, try
    running:

    # rpm -qi yum-plugin-versionlock

    to see who the packager was. It may be that this repository is no longer
    enabled on the host that is having problems.

       - Keith

    On 16 May 2013 16:26, wrote:



    So this seems to be different between RHEL5 and RHEL6 the command you
    suggested ran fine.
    Here it is on another RHEL6 box

    [root@crypt mbowden]# puppet agent --verbose --onetime --no-daemonize
    info: Caching catalog for crypt.bowdoin.edu
    info: Applying configuration version '1368708690'
    err: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock at
    /etc/puppet/modules/base/manifests/yum_plugins.pp:3
    notice:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Dependency Package[yum-versionlock] has failures: true
    warning:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Skipping because of failed dependencies
    err: /Stage[main]/Base::Yum_plugins/Package[yum-security]/ensure: change
    from absent to latest failed: Could not update: Could not find package
    yum-security at /etc/
    puppet/modules/base/manifests/yum_plugins.pp:4
    notice: Finished catalog run in 9.92 seconds
    [root@crypt mbowden]# yum install yum-versionlock
    Loaded plugins: product-id, rhnplugin, security, subscription-manager,
    versionlock
    This system is not registered to Red Hat Subscription Management. You can
    use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.

    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do
    [root@crypt mbowden]# puppet apply --verbose --execute 'package
    {yum-plugin-versionlock: ensure => latest}'
    info: Applying configuration version '1368718137'
    notice: Finished catalog run in 3.42 seconds

    On Thursday, May 16, 2013 10:12:33 AM UTC-4, Keith Burdis wrote:

    This is often an issue with the underlying yum command being executed.

    Try running:

    # puppet apply --verbose --debug --execute 'package
    {yum-plugin-versionlock: ensure => latest}'

    to see what is happening.

    On my host this shows that '/usr/bin/yum -d 0 -e 0 -y install
    yum-plugin-versionlock' is being executed so I'd try this command manually
    without the -y to see if I get any errors.

    - Keith

    On 16 May 2013 13:35, wrote:

    So I am having issue with a manifest that contains the class below. I
    was in hopes somebody could point me in the correct direction;

    Original class, works on many others systems I have this deployed to,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.


    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_**plugins/Package[yum-**versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/**versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/**versionlock.list]: Skipping
    because of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_**format' (pson) is invalid
    for report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-**14.el6.noarch

    Change class to represent yum-plugin-versionlock and it fails slightly
    different,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}

    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/**
    versionlock.list

    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-**14.el6.noarch already installed
    and latest version
    Nothing to do

    and

    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf
    subscription-manager.conf versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike




    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@**googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.

    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Michael R Bowden at May 16, 2013 at 4:06 pm
    Seems to be there

    ed Hat Enterprise Linux Server release 6.4 (Santiago)
    [root@rhel6Template pluginconf.d]#
    [root@rhel6Template pluginconf.d]# yum install yum-plugin-versionlock
    Loaded plugins: product-id, rhnplugin, security, subscription-manager,
    versionlock
    This system is not registered to Red Hat Subscription Management. You can
    use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    puppetlabs-deps
    1.9 kB 00:00
    puppetlabs-enterprise-extras
    1.9 kB 00:00
    puppetlabs-products
    1.9 kB 00:00
    rhel-x86_64-server-6
    1.5 kB 00:00
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do
    [root@rhel6Template pluginconf.d]# yum install yum-versionlock
    Loaded plugins: product-id, rhnplugin, security, subscription-manager,
    versionlock
    This system is not registered to Red Hat Subscription Management. You can
    use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do


    On Thursday, May 16, 2013 11:38:29 AM UTC-4, Keith Burdis wrote:

    This package doesn't appear to exist in the default repositories for
    RHEL/CentOS 5:

    # cat /etc/redhat-release
    CentOS release 5.9 (Final)
    # yum install yum-plugin-versionlock
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: ftp.heanet.ie
    * extras: ftp.heanet.ie
    * updates: ftp.heanet.ie
    Setting up Install Process
    No package yum-plugin-versionlock available.
    Nothing to do

    Since you do seem to have the yum-plugin-versionlock package installed,
    try running:

    # rpm -qi yum-plugin-versionlock

    to see who the packager was. It may be that this repository is no longer
    enabled on the host that is having problems.

    - Keith

    On 16 May 2013 16:26, <michael....@gmail.com <javascript:>> wrote:



    So this seems to be different between RHEL5 and RHEL6 the command you
    suggested ran fine.
    Here it is on another RHEL6 box

    [root@crypt mbowden]# puppet agent --verbose --onetime --no-daemonize
    info: Caching catalog for crypt.bowdoin.edu
    info: Applying configuration version '1368708690'
    err: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock at
    /etc/puppet/modules/base/manifests/yum_plugins.pp:3
    notice:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Dependency Package[yum-versionlock] has failures: true
    warning:
    /Stage[main]/Patches::Nokernel/File[/etc/yum/pluginconf.d/versionlock.list]:
    Skipping because of failed dependencies
    err: /Stage[main]/Base::Yum_plugins/Package[yum-security]/ensure: change
    from absent to latest failed: Could not update: Could not find package
    yum-security at /etc/
    puppet/modules/base/manifests/yum_plugins.pp:4
    notice: Finished catalog run in 9.92 seconds
    [root@crypt mbowden]# yum install yum-versionlock
    Loaded plugins: product-id, rhnplugin, security, subscription-manager,
    versionlock
    This system is not registered to Red Hat Subscription Management. You can
    use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.

    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed and
    latest version
    Nothing to do
    [root@crypt mbowden]# puppet apply --verbose --execute 'package
    {yum-plugin-versionlock: ensure => latest}'
    info: Applying configuration version '1368718137'
    notice: Finished catalog run in 3.42 seconds

    On Thursday, May 16, 2013 10:12:33 AM UTC-4, Keith Burdis wrote:

    This is often an issue with the underlying yum command being executed.

    Try running:

    # puppet apply --verbose --debug --execute 'package
    {yum-plugin-versionlock: ensure => latest}'

    to see what is happening.

    On my host this shows that '/usr/bin/yum -d 0 -e 0 -y install
    yum-plugin-versionlock' is being executed so I'd try this command manually
    without the -y to see if I get any errors.

    - Keith

    On 16 May 2013 13:35, wrote:

    So I am having issue with a manifest that contains the class below. I
    was in hopes somebody could point me in the correct direction;

    Original class, works on many others systems I have this deployed to,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.


    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_**plugins/Package[yum-**versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/**versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/**versionlock.list]: Skipping
    because of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_**format' (pson) is invalid
    for report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-**14.el6.noarch

    Change class to represent yum-plugin-versionlock and it fails slightly
    different,

    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}

    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/**
    versionlock.list

    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-**14.el6.noarch already
    installed and latest version
    Nothing to do

    and

    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf
    subscription-manager.conf versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike




    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@**googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.

    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ramin K at May 16, 2013 at 5:47 pm

    On 5/16/2013 5:35 AM, michael.r.bowden@gmail.com wrote:
    So I am having issue with a manifest that contains the class below. I
    was in hopes somebody could point me in the correct direction;
    Original class, works on many others systems I have this deployed to,
    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.
    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/versionlock.list]: Skipping because
    of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-14.el6.noarch
    Change class to represent yum-plugin-versionlock and it fails slightly
    different,
    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/versionlock.list
    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed
    and latest version
    Nothing to do
    and
    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf
    subscription-manager.conf versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike
    You are mixing package names.

    RHEL 5.x
        yum-security
        yum-versionlock

    RHEL 6.x
        yum-plugin-security
        yum-plugin-versionlock

    Under RHEL 6.x yum install yum-versionlock helpfully installs
    yum-plugin-versionlock however Puppet is running a much more explicit
    yum command so the alias is not found. Setting the proper name per
    distro version should fix the problem.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Michael R Bowden at May 16, 2013 at 6:31 pm
    Thank You
    On Thursday, May 16, 2013 1:47:30 PM UTC-4, Ramin K wrote:
    On 5/16/2013 5:35 AM, michael....@gmail.com <javascript:> wrote:
    So I am having issue with a manifest that contains the class below. I
    was in hopes somebody could point me in the correct direction;
    Original class, works on many others systems I have this deployed to,
    class base::yum_plugins{
    require base::yum_repos
    package {yum-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    }
    However on a machine we are building a template out of it fails.
    Debug: Executing '/bin/rpm -q yum-versionlock --nosignature --nodigest
    --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
    '
    Error: Could not update: Could not find package yum-versionlock
    Error: /Stage[main]/Base::Yum_plugins/Package[yum-versionlock]/ensure:
    change from absent to latest failed: Could not update: Could not find
    package yum-versionlock
    Notice: /File[/etc/yum/pluginconf.d/versionlock.list]: Dependency
    Package[yum-versionlock] has failures: true
    Warning: /File[/etc/yum/pluginconf.d/versionlock.list]: Skipping because
    of failed dependencies
    Debug: Finishing transaction 70184260275260
    Debug: Storing state
    Debug: Stored state in 0.02 seconds
    Notice: Finished catalog run in 6.66 seconds
    Debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (yaml)
    Debug: report supports formats: b64_zlib_yaml raw yaml; using yaml
    [root@rhel6Template ~]# ^C
    [root@rhel6Template ~]# /bin/rpm -q yum-versionlock
    package yum-versionlock is not installed
    [root@rhel6Template ~]# /bin/rpm -q yum-plugin-versionlock
    yum-plugin-versionlock-1.1.30-14.el6.noarch
    Change class to represent yum-plugin-versionlock and it fails slightly
    different,
    class base::yum_plugins{
    require base::yum_repos
    package {yum-plugin-versionlock: ensure => latest}
    package {yum-security: ensure => latest}
    Error: Failed to apply catalog: Could not find dependency
    Package[yum-versionlock] for File[/etc/yum/pluginconf.d/versionlock.list
    Yet
    Setting up Install Process
    Package yum-plugin-versionlock-1.1.30-14.el6.noarch already installed
    and latest version
    Nothing to do
    and
    [root@rhel6Template pluginconf.d]# cd /etc/yum/pluginconf.d/
    [root@rhel6Template pluginconf.d]# ls
    product-id.conf rhnplugin.conf security.conf
    subscription-manager.conf versionlock.conf versionlock.list
    Any help woudld be greatly appreciated;
    Mike
    You are mixing package names.

    RHEL 5.x
    yum-security
    yum-versionlock

    RHEL 6.x
    yum-plugin-security
    yum-plugin-versionlock

    Under RHEL 6.x yum install yum-versionlock helpfully installs
    yum-plugin-versionlock however Puppet is running a much more explicit
    yum command so the alias is not found. Setting the proper name per
    distro version should fix the problem.

    Ramin
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 16, '13 at 1:55p
activeMay 16, '13 at 6:31p
posts7
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase