FAQ
When I discovered that I could use the PuppetLabs RPM's to install Puppet Dashboard on my RHEL 5 Puppet Master, I decided to take the plunge.

The "newest" Red Hat supplied rpm is mysql-server-5.0.95-5.el5_9

We have been using a customized 5.5.x, built from source.
I wanted to see if I could use RPM's to do this.

I got the latest 5.5.x RPM's from http://dev.mysql.com/downloads/mysql/5.5.html

Long story short: installed the MySQL-server and MySQL-shared-compat RPM's and then "yum install puppet-dashboard" did not complain.

Thought I'd share this little How-To with the community.

“Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
Bill Waterson (Calvin & Hobbes)

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Dan White at May 15, 2013 at 8:24 pm
    One more thing:

    Silly me :P

    MySQL-client also to be able to work with the database locally

    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    ----- Original Message -----
    From: "Dan White" <ygor@comcast.net>
    To: "Puppet Users Mailing List" <puppet-users@googlegroups.com>
    Sent: Wednesday, May 15, 2013 4:20:48 PM
    Subject: [Puppet Users] Preparing to install Puppet Dashboard on RHEL 5 with newer MySQL

    When I discovered that I could use the PuppetLabs RPM's to install Puppet Dashboard on my RHEL 5 Puppet Master, I decided to take the plunge.

    The "newest" Red Hat supplied rpm is mysql-server-5.0.95-5.el5_9

    We have been using a customized 5.5.x, built from source.
    I wanted to see if I could use RPM's to do this.

    I got the latest 5.5.x RPM's from http://dev.mysql.com/downloads/mysql/5.5.html

    Long story short: installed the MySQL-server and MySQL-shared-compat RPM's and then "yum install puppet-dashboard" did not complain.

    Thought I'd share this little How-To with the community.

    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Wolf Noble at May 20, 2013 at 3:07 pm
    Hi Dan,

    I've a script here that grabs the mysql 5.5 / 5.6 packages and turns them
    into a yumrepo for easier consumption:
    https://github.com/wolfspyre/MySQL_Createrepo

    it's not perfect, but imho better than grabbing the RPMs manually form
    Oracle.


    On Wed, May 15, 2013 at 3:24 PM, Dan White wrote:

    One more thing:

    Silly me :P

    MySQL-client also to be able to work with the database locally

    “Sometimes I think the surest sign that intelligent life exists elsewhere
    in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    ----- Original Message -----
    From: "Dan White" <ygor@comcast.net>
    To: "Puppet Users Mailing List" <puppet-users@googlegroups.com>
    Sent: Wednesday, May 15, 2013 4:20:48 PM
    Subject: [Puppet Users] Preparing to install Puppet Dashboard on RHEL 5
    with newer MySQL

    When I discovered that I could use the PuppetLabs RPM's to install Puppet
    Dashboard on my RHEL 5 Puppet Master, I decided to take the plunge.

    The "newest" Red Hat supplied rpm is mysql-server-5.0.95-5.el5_9

    We have been using a customized 5.5.x, built from source.
    I wanted to see if I could use RPM's to do this.

    I got the latest 5.5.x RPM's from
    http://dev.mysql.com/downloads/mysql/5.5.html

    Long story short: installed the MySQL-server and MySQL-shared-compat
    RPM's and then "yum install puppet-dashboard" did not complain.

    Thought I'd share this little How-To with the community.

    “Sometimes I think the surest sign that intelligent life exists elsewhere
    in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Dan White at May 20, 2013 at 4:51 pm
    Thanks.

    We already use a locally maintained repo for third party packages.
    I will adapt the script to pull the appropriate files and place them in that repo.

    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    ----- Original Message -----
    From: "Wolf Noble" <wolf@wolfspyre.com>
    To: puppet-users@googlegroups.com
    Sent: Monday, May 20, 2013 11:07:11 AM
    Subject: Re: [Puppet Users] Preparing to install Puppet Dashboard on RHEL 5 with newer MySQL


    Hi Dan,


    I've a script here that grabs the mysql 5.5 / 5.6 packages and turns them into a yumrepo for easier consumption:
    https://github.com/wolfspyre/MySQL_Createrepo



    it's not perfect, but imho better than grabbing the RPMs manually form Oracle.





    On Wed, May 15, 2013 at 3:24 PM, Dan White wrote:


    One more thing:

    Silly me :P

    MySQL-client also to be able to work with the database locally


    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)



    ----- Original Message -----
    From: "Dan White" < ygor@comcast.net >
    To: "Puppet Users Mailing List" < puppet-users@googlegroups.com >
    Sent: Wednesday, May 15, 2013 4:20:48 PM
    Subject: [Puppet Users] Preparing to install Puppet Dashboard on RHEL 5 with newer MySQL

    When I discovered that I could use the PuppetLabs RPM's to install Puppet Dashboard on my RHEL 5 Puppet Master, I decided to take the plunge.

    The "newest" Red Hat supplied rpm is mysql-server-5.0.95-5.el5_9

    We have been using a customized 5.5.x, built from source.
    I wanted to see if I could use RPM's to do this.

    I got the latest 5.5.x RPM's from http://dev.mysql.com/downloads/mysql/5.5.html

    Long story short: installed the MySQL-server and MySQL-shared-compat RPM's and then "yum install puppet-dashboard" did not complain.

    Thought I'd share this little How-To with the community.

    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com .
    To post to this group, send email to puppet-users@googlegroups.com .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en .
    For more options, visit https://groups.google.com/groups/opt_out .


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com .
    To post to this group, send email to puppet-users@googlegroups.com .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en .
    For more options, visit https://groups.google.com/groups/opt_out .





    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en .
    For more options, visit https://groups.google.com/groups/opt_out .


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 15, '13 at 8:20p
activeMay 20, '13 at 4:51p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Dan White: 3 posts Wolf Noble: 1 post

People

Translate

site design / logo © 2021 Grokbase