FAQ
Hy I m new to puppet.
I 'd like to install epel.repo on a my node and this is the module that I
ve created

class epel {

   package { 'epel':
      provider => 'rpm',
      ensure => installed,
      source =>
'http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
  }
}

Now my connection on node when I try to apply configuration is the following
info: Applying configuration version '1367962540'
err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to present
failed: Execution of '/bin/rpm -i --oldpackage
http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
returned 1: curl: (7) couldn't connect to host
error: skipping
http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm -
transfer failed

If I set a proxy on my linux server it give me error 407 (require
authentication)
How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
I read of a params.pp , but I cannot understand how to configure it


this is my site.pp
node rllbck02{
include epel


thank you very much and good night

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Eugene Vilensky at May 8, 2013 at 2:16 am

    On Tue, May 7, 2013 at 5:39 PM, Francesco wrote:
    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => 'http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    }
    }

    Hi,

    There exists a Puppet module which does much the same as the
    epel-release rpm. Using it with great success so far.

    http://forge.puppetlabs.com/stahnma/epel

    And others building on the same concept (Search Forge for 'epel').

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Francesco at May 8, 2013 at 9:46 am
    Excuse for my question
    I ve installed module and incuded it in file site pp.
    But nothin happen
    Where can i check llog files in puppet?
    Tahnk you very much again
    Here you are site .pp
    node 'rlltas05a
    #include screen
    #include run
    include epel


    On Wednesday, May 8, 2013 12:39:53 AM UTC+2, Francesco wrote:

    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I
    ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to present
    failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Francesco at May 9, 2013 at 9:47 am
    Excuse again
    This is the output of my node
    puppet agent --server=puppet.x.x.x. --no-daemonize --verbose --onetime
    info: Caching catalog for rlltas05a.x.x.x.x.
    info: Applying configuration version '1368021386'
    notice: Finished catalog run in 0.01 seconds


    this is my site.pp
    node 'rlltas05a' {
    #include screen
    #include run
    include epel
    }

    and this is my path for epel module
    /etc/puppet/modules/epel/manifests

    I ve installed **
    stahnma/epel with puppet module install procedure<https://forge.puppetlabs.com/stahnma/epel>
    What is my fault?? Nothing happen on my node .....an error a fault an
    exception nothing.......
    Thank you in advance for all your precious support

    <https://forge.puppetlabs.com/stahnma/epel>


    Il giorno mercoledì 8 maggio 2013 11:46:45 UTC+2, Francesco ha scritto:
    Excuse for my question
    I ve installed module and incuded it in file site pp.
    But nothin happen
    Where can i check llog files in puppet?
    Tahnk you very much again
    Here you are site .pp
    node 'rlltas05a
    #include screen
    #include run
    include epel


    On Wednesday, May 8, 2013 12:39:53 AM UTC+2, Francesco wrote:

    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I
    ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    '
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to
    present failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Francesco at May 10, 2013 at 9:18 am
    Excuse me, can anyone help me please . I m going mad...
    thank you , thank you, thank you



    Il giorno giovedì 9 maggio 2013 11:46:58 UTC+2, Francesco ha scritto:
    Excuse again
    This is the output of my node
    puppet agent --server=puppet.x.x.x. --no-daemonize --verbose --onetime
    info: Caching catalog for rlltas05a.x.x.x.x.
    info: Applying configuration version '1368021386'
    notice: Finished catalog run in 0.01 seconds


    this is my site.pp
    node 'rlltas05a' {
    #include screen
    #include run
    include epel
    }

    and this is my path for epel module
    /etc/puppet/modules/epel/manifests

    I ve installed **
    stahnma/epel with puppet module install procedure<https://forge.puppetlabs.com/stahnma/epel>
    What is my fault?? Nothing happen on my node .....an error a fault an
    exception nothing.......
    Thank you in advance for all your precious support

    <https://forge.puppetlabs.com/stahnma/epel>


    Il giorno mercoledì 8 maggio 2013 11:46:45 UTC+2, Francesco ha scritto:
    Excuse for my question
    I ve installed module and incuded it in file site pp.
    But nothin happen
    Where can i check llog files in puppet?
    Tahnk you very much again
    Here you are site .pp
    node 'rlltas05a
    #include screen
    #include run
    include epel


    On Wednesday, May 8, 2013 12:39:53 AM UTC+2, Francesco wrote:

    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that
    I ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    '
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to
    present failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Fco CM at May 10, 2013 at 12:34 pm
    El miércoles, 8 de mayo de 2013 00:39:53 UTC+2, Francesco escribió:
    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I
    ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to present
    failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Fco CM at May 10, 2013 at 12:35 pm
    Hi,

    did you try:

    node default {

    include epel

    }

    El miércoles, 8 de mayo de 2013 00:39:53 UTC+2, Francesco escribió:
    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I
    ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to present
    failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at May 10, 2013 at 1:56 pm

    On Friday, May 10, 2013 7:35:48 AM UTC-5, Fco CM wrote:
    Hi,

    did you try:

    node default {

    include epel

    }
    That is not the issue. The error message he reported shows that his class
    is assigned to the target node, for the error occurs when the Package
    resource declared in it is being applied.

    Francesco: it is unlikely to be possible to configure Puppet to issue HTTP
    requests through a proxy only during the application of one non-Exec
    resource. System commands issued by Puppet (such as 'rpm') will typically
    run each in a separate and very sparse environment, so one cannot set up
    the environment of another. You could conceivably set up and run a
    special-purpose http service on the local host that proxies requests via
    your main organizational proxy server; the important point here would be
    that you would rewrite the URL in your Package resource to refer to that
    service; maybe something like this:

       source => 'http://localhost/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm<http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm>
    '

    (where that special-purpose service knows that the ultimate server to which
    requests need to be directed is dl.fedoraproject.org, via your proxy).

    But that's an awful lot of work for a such a specialized need. You should
    consider simply installing epel-release as part of initial system
    provisioning. If that won't work for you, then you can instead either

        1. Use a Yumrepo resource to set up the repository. Relative to the
        package, this has the shortcoming that it will not install the repo's
        public key, but you can do that separately via a File resource.
        2. Serve the RPM from an internal source instead. If you are running
        Puppet via apache/passenger, then that source could be the same apache
        instance that hosts Puppet. It could also be a network filesystem
        accessible to your nodes, or even a local file (that you can ensure present
        via a File resource).


    Good luck,

    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Francesco at May 15, 2013 at 2:57 pm
    Hy I' ve used a Yumrepo resource to set up the repository. I have passed
    the public key with a file resource.
    It seems to work now
    Thank you thank you again


    Il giorno mercoledì 8 maggio 2013 00:39:53 UTC+2, Francesco ha scritto:
    Hy I m new to puppet.
    I 'd like to install epel.repo on a my node and this is the module that I
    ve created

    class epel {

    package { 'epel':
    provider => 'rpm',
    ensure => installed,
    source => '
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    }
    }

    Now my connection on node when I try to apply configuration is the
    following
    info: Applying configuration version '1367962540'
    err: /Stage[main]/Epel/Package[epel]/ensure: change from absent to present
    failed: Execution of '/bin/rpm -i --oldpackage
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm'
    returned 1: curl: (7) couldn't connect to host
    error: skipping
    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm- transfer failed

    If I set a proxy on my linux server it give me error 407 (require
    authentication)
    How can i setup a proxy in my /etc/puppet/modules/epel/init,pp
    I read of a params.pp , but I cannot understand how to configure it


    this is my site.pp
    node rllbck02{
    include epel


    thank you very much and good night
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 7, '13 at 10:39p
activeMay 15, '13 at 2:57p
posts9
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase