FAQ
I have run into the same error installing puppet 2.7 and 3.1.0 on centos
box. In the end it tries to install 1.8.7 for the 3.1.0 even though I have
1.9.3 already installed I have dumped all sorts of things like rebuiding
the yum repo but nothing seems to help I am using the puppetlabs yum repo

Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)
            Requires: libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-7.el6_2.x86_64 (base)
                libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-10.el6_4.x86_64 (updates)
                libruby.so.1.8()(64bit)
Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (epel)
            Requires: libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-7.el6_2.x86_64 (base)
                libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-10.el6_4.x86_64 (updates)
                libruby.so.1.8()(64bit)
Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (epel)
            Requires: ruby(abi) = 1.8
            Installed: ruby-1.9.3p194-1.el6.x86_64 (@chartboost)
                ruby(abi) = 1.9
            Available: ruby-libs-1.8.7.352-7.el6_2.i686 (base)
                ruby(abi) = 1.8
            Available: ruby-libs-1.8.7.352-10.el6_4.i686 (updates)
                ruby(abi) = 1.8
Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (epel)
            Requires: ruby(abi) = 1.8
            Installed: ruby-1.9.3p194-1.el6.x86_64 (@chartboost)
                ruby(abi) = 1.9
            Available: ruby-libs-1.8.7.352-7.el6_2.i686 (base)
                ruby(abi) = 1.8
            Available: ruby-libs-1.8.7.352-10.el6_4.i686 (updates)
                ruby(abi) = 1.8
Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)
            Requires: ruby(abi) = 1.8
            Installed: ruby-1.9.3p194-1.el6.x86_64 (@chartboost)
                ruby(abi) = 1.9
            Available: ruby-libs-1.8.7.352-7.el6_2.i686 (base)
                ruby(abi) = 1.8
            Available: ruby-libs-1.8.7.352-10.el6_4.i686 (updates)
                ruby(abi) = 1.8
Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (epel)
            Requires: libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-7.el6_2.x86_64 (base)
                libruby.so.1.8()(64bit)
            Available: ruby-libs-1.8.7.352-10.el6_4.x'


gem list

*** LOCAL GEMS ***

activemodel (3.2.13)
activerecord (3.2.13)
activesupport (3.2.13)
arel (3.0.2)
aureus (1.3.0)
bigdecimal (1.1.0)
bson (1.8.4)
bson_ext (1.8.4)
builder (3.0.4)
bundler (1.3.4)
cgi_multipart_eof_fix (2.5.0)
daemons (1.1.9)
elif (0.1.0)
fastercsv (1.5.5)
fastthread (1.0.7)
gem_plugin (0.2.3)
i18n (0.6.1)
io-console (0.3)
json (1.7.7, 1.5.5, 1.5.4)
memcache-client (1.8.5)
minitest (2.5.1)
mongo (1.8.4)
mongo_ext (0.19.3)
multi_json (1.7.3)
rake (0.9.2.2)
rdoc (3.9.4)
scout (5.6.2)
tzinfo (0.3.37)


ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ramin K at May 7, 2013 at 5:01 pm

    On 5/6/2013 5:34 PM, WojonsTech wrote:
    I have run into the same error installing puppet 2.7 and 3.1.0 on centos
    box. In the end it tries to install 1.8.7 for the 3.1.0 even though I
    have 1.9.3 already installed I have dumped all sorts of things like
    rebuiding the yum repo but nothing seems to help I am using the
    puppetlabs yum repo
      The Puppet rpms require Ruby 1.8.7. Ruby 1.9.3 is a completely
    different ABI which is reflected in the errors you're getting.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jerald Sheets at May 7, 2013 at 5:08 pm
    Yeah... god forbid you actually need to stay up to date with Ruby...



    On May 7, 2013, at 1:01 PM, Ramin K wrote:
    On 5/6/2013 5:34 PM, WojonsTech wrote:
    I have run into the same error installing puppet 2.7 and 3.1.0 on centos
    box. In the end it tries to install 1.8.7 for the 3.1.0 even though I
    have 1.9.3 already installed I have dumped all sorts of things like
    rebuiding the yum repo but nothing seems to help I am using the
    puppetlabs yum repo
    The Puppet rpms require Ruby 1.8.7. Ruby 1.9.3 is a completely different ABI which is reflected in the errors you're getting.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ramin K at May 7, 2013 at 5:56 pm
    meh, it's all the same problems and solutions of upgrading your Python
    version and breaking yum.

    Ramin
    On 5/7/2013 10:08 AM, Jerald Sheets wrote:
    Yeah... god forbid you actually need to stay up to date with Ruby...



    On May 7, 2013, at 1:01 PM, Ramin K wrote:
    On 5/6/2013 5:34 PM, WojonsTech wrote:
    I have run into the same error installing puppet 2.7 and 3.1.0 on centos
    box. In the end it tries to install 1.8.7 for the 3.1.0 even though I
    have 1.9.3 already installed I have dumped all sorts of things like
    rebuiding the yum repo but nothing seems to help I am using the
    puppetlabs yum repo
    The Puppet rpms require Ruby 1.8.7. Ruby 1.9.3 is a completely different ABI which is reflected in the errors you're getting.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at May 7, 2013 at 7:20 pm

    On Tuesday, May 7, 2013 12:08:13 PM UTC-5, Jerald Sheets wrote:
    Yeah... god forbid you actually need to stay up to date with Ruby...
    Puppet 3 runs fine on Ruby 1.9. The OP's problem is a matter of how the
    particular RPMs in question were prepared.

    On the other hand, not everything that runs on Ruby 1.8 does work correctly
    on Ruby 1.9. Puppet itself did not always do so. Packaging tools are not
    unreasonable to be conservative in their assumptions about dependencies.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David Schmitt at May 7, 2013 at 7:56 pm

    On 2013-05-07 19:08, Jerald Sheets wrote:
    Yeah... god forbid you actually need to stay up to date with Ruby...
    Use the system ruby only for system applications. Use system
    applications only with the system ruby. For everything else, use rbenv
    or rvm. On Debian you might get away with co-installing 1.8 and 1.9 as
    the package maintainers valiantly fought against ruby's inherent
    disregard for anything approaching sane packaging, api or abi management
    or compatibility. Yes, I'm bitter.


    Regards, David



    On May 7, 2013, at 1:01 PM, Ramin Kwrote:
    On 5/6/2013 5:34 PM, WojonsTech wrote:
    I have run into the same error installing puppet 2.7 and 3.1.0 on centos
    box. In the end it tries to install 1.8.7 for the 3.1.0 even though I
    have 1.9.3 already installed I have dumped all sorts of things like
    rebuiding the yum repo but nothing seems to help I am using the
    puppetlabs yum repo
    The Puppet rpms require Ruby 1.8.7. Ruby 1.9.3 is a completely different ABI which is reflected in the errors you're getting.

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ramin K at May 7, 2013 at 8:23 pm

    On 5/7/2013 12:55 PM, David Schmitt wrote:
    On 2013-05-07 19:08, Jerald Sheets wrote:
    Yeah... god forbid you actually need to stay up to date with Ruby...
    Use the system ruby only for system applications. Use system
    applications only with the system ruby. For everything else, use rbenv
    or rvm. On Debian you might get away with co-installing 1.8 and 1.9 as
    the package maintainers valiantly fought against ruby's inherent
    disregard for anything approaching sane packaging, api or abi management
    or compatibility. Yes, I'm bitter.

    Regards, David
      I have a few Ubuntu 12.04 servers running Puppet against the Ruby 1.8
    libs while Ruby 1.9.3 installed for apps and commandline. I sure there
    are some corner cases I haven't managed to trigger, but I've had little
    problem with the setup.

    For people on RHEL 6, you might want to look at software collections.

    http://developerblog.redhat.com/2013/01/31/ruby-on-rails-3-2-on-red-hat-enterprise-linux-6-with-software-collections/

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Brian Lalor at May 7, 2013 at 9:49 pm
    I'd love to be proven wrong, but in my experience neither rvm nor rbenv are packaging-friendly. You'll end up compiling code and downloading dependencies from your prod machines. That's a really Bad Idea.

    --
    Brian Lalor
    blalor@bravo5.org
    On May 7, 2013, at 3:55 PM, David Schmitt wrote:

    For everything else, use rbenv or rvm.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David Schmitt at May 8, 2013 at 6:52 am
    To be clear, I do not think that rbenv or rvm are Good Ideas(tm). I'm
    only claiming that there are enough mismanaged ruby code dumps on github
    that provide useful functionality that cannot be installed on top of
    system rubies without destroying the rest of the system to make rbenv
    the lesser evil.

    Don't get me started on rvm's
    I'll-replace-some-of-your-shell-builtins-with-dynamically-loaded-code-from-the-internets
    philosophy.


    The ruby community has--obviously with good results--chosen development
    velocity over more conservative systems values.

    D.
    On 07.05.2013 23:35, Brian Lalor wrote:
    I'd love to be proven wrong, but in my experience neither rvm nor rbenv are packaging-friendly. You'll end up compiling code and downloading dependencies from your prod machines. That's a really Bad Idea.

    --
    Brian Lalor
    blalor@bravo5.org
    On May 7, 2013, at 3:55 PM, David Schmitt wrote:

    For everything else, use rbenv or rvm.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 7, '13 at 4:35p
activeMay 8, '13 at 6:52a
posts9
users6
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase