FAQ
I'm trying to install python (via msi) onto a windows 2008R2 box. I'm using
puppet 3.1 on the client, 3.0.2 on the puppet server. Here is my install.pp:

class python::install {
     package { 'python':
         ensure => installed,
         provider => 'msi',
         source =>
'\\\\example.com\\software\\python\\python-2.7.3.amd64.msi',
         install_options => [ { 'INSTALLDIR' => 'C:\python27' }, {
'ALLUSERS' => '1' } ],
     }
}

I can see the "msiexec" process running on the client, but it seems to run
forever without installing anything.

Any help would be greatly appreciated!

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Matt F at May 7, 2013 at 5:26 pm
    Bump. Any help on this would be GREATLY appreciated! I also notice in the
    windows event log that I get the error "Failed to install: Fail on INT
    24." and "/Stage[main]/Python::Install/Package[python]/ensure: change from
    absent to present failed: Failed to install: Fail on INT 24."

    I've tried running "puppet apply --debug --trace" from a "command prompt
    with puppet", but this just hangs.

    On Friday, May 3, 2013 1:53:12 PM UTC-4, Matt F wrote:

    I'm trying to install python (via msi) onto a windows 2008R2 box. I'm
    using puppet 3.1 on the client, 3.0.2 on the puppet server. Here is my
    install.pp:

    class python::install {
    package { 'python':
    ensure => installed,
    provider => 'msi',
    source => '\\\\example.com
    \\software\\python\\python-2.7.3.amd64.msi',
    install_options => [ { 'INSTALLDIR' => 'C:\python27' }, {
    'ALLUSERS' => '1' } ],
    }
    }

    I can see the "msiexec" process running on the client, but it seems to run
    forever without installing anything.

    Any help would be greatly appreciated!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at May 21, 2013 at 4:49 am
    Hi Matt,

    On Tue, May 7, 2013 at 10:26 AM, Matt F wrote:

    Bump. Any help on this would be GREATLY appreciated! I also notice in the
    windows event log that I get the error "Failed to install: Fail on INT
    24." and "/Stage[main]/Python::Install/Package[python]/ensure: change from
    absent to present failed: Failed to install: Fail on INT 24."
    You may be running into http://projects.puppetlabs.com/issues/20534. May
    sure to use backslashes, but don't escape them, e.g.
    '\\server\share\python.msi'

    I've tried running "puppet apply --debug --trace" from a "command prompt
    with puppet", but this just hangs.

    Are you running as an administrator? Do you have any custom facts (if so,
    check that they aren't executing a command that is hanging waiting for
    input, e.g. date.exe). I recommend installing process explorer and see what
    puppet's ruby.exe process is executing.

    Also verify that the MSI can be installed silently from the command line
    directly (msiexec.exe /qn /norestart /i python.msi. It is up to the MSI
    author to ensure that it abides by the specified UI level.


    On Friday, May 3, 2013 1:53:12 PM UTC-4, Matt F wrote:

    I'm trying to install python (via msi) onto a windows 2008R2 box. I'm
    using puppet 3.1 on the client, 3.0.2 on the puppet server. Here is my
    install.pp:

    class python::install {
    package { 'python':
    ensure => installed,
    provider => 'msi',
    source => '\\\\example.com\\software\\**
    python\\python-2.7.3.amd64.**msi',
    install_options => [ { 'INSTALLDIR' => 'C:\python27' }, {
    'ALLUSERS' => '1' } ],
    }
    }

    I can see the "msiexec" process running on the client, but it seems to
    run forever without installing anything.

    Any help would be greatly appreciated!
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Early Bird discount - save 25%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Klavs Klavsen at May 22, 2013 at 9:16 am
    Try:

    class python::install {
    package { 'python':
    ensure => installed,
    source => "\\\\example.com
    \\software\\python\\python-2.7.3.amd64.msi",
    install_options => [ { 'INSTALLDIR' => 'C:\python27' }, {
    'ALLUSERS' => '1' } ],
    }
    }
    p.s. with puppet 3 - provider should be windows - and should be so pr.
    default.

    notice that it HAS to be a valid UNC path - otherwise you could try to put
    a file resource - to throw the msi to c:\temp f.ex. - and use that as UNC
    path to package.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Kevin D at May 22, 2013 at 9:10 pm
    Matt,

    I tried your class in my test environment. Here are my findings:

    Using Microsoft's Process Monitor<http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx>,
    we capture Puppet's call to MSIEXE, the "command line" value reads:

    msiexec.exe /qn /no restart /i
    \\\\example.com\\temp\\python-2.7.3.amd64.msi INSTALLDIR=C:\python27
    ALLUSERS=1

    It makes sense that you are getting an error because msiexec cannot find
    "\\\\example.com\\temp\\python-2.7.3.amd64.msi".

    In order to successfully install, change the "source" line single quotes
    (') to double quotes("). On next Puupet run, Process Monitor "command
    line" value reads:

    msiexec.exe /qn /no restart /i \\example.com\temp\python-2.7.3.amd64.msi
    INSTALLDIR=C:\python27 ALLUSERS=1

    *Another note:
    *Using Microsoft's orca.exe<http://msdn.microsoft.com/en-us/library/windows/desktop/aa370557%28v=vs.85%29.aspx>,
    the "python-2.7.3.amd64.msi" doesn't contain properties for INSTALLDIR or
    ALLUSERS. These aren't msiexec default properties either. As a result,
    these parameters are being ignored by msiexec. You wouldn't notice this
    because the values you happen provided for these errant keys are the
    defaults. If you comment the " install_options" line, it will still
    install in C:\Python27 for all users.

    If you wanted to specify a custom install directory, you would need to use
    TARGETDIR.
    If you wanted to restrict user access, you would need to use WHICHUSERS.
    WHICHUSERS accepts "ALL" or "JUSTME"

    To install for the current user in specified directory "C:\python273"

    install_options => [ { 'TARGETDIR' => 'C:\python273' }, { 'WHICHUSERS' =>
    'JUSTME' } ],


    Here is your stanza fixed (with the install_options line optional [since
    you are using the defaults]):

    class python::install {
         package { 'python':
             ensure => installed,
             provider => 'msi',
             source => "\\\\example.com
    \\software\\python\\python-2.7.3.amd64.msi",
             #install_options => [ { 'TARGETDIR' => 'C:\python27' }, {
    'WHICHUSER => 'ALL' } ],
         }
    }

    I hope this helps.

    -Kev

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Kevin D at May 22, 2013 at 9:13 pm
    Oops... you should also change the provider as Klavs recommends:

    class python::install {
         package { 'python':
             ensure => installed,
             provider => 'windows',
             source => "\\\\example.com\\software\\
    python\\python-2.7.3.amd64.msi",
             #install_options => [ { 'TARGETDIR' => 'C:\python27' }, {
    'WHICHUSER => 'ALL' } ],
         }
    }

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Gene Fontanilla at Jul 6, 2015 at 1:57 pm

    On Thursday, May 23, 2013 at 5:10:48 AM UTC+8, Kevin D wrote:
    Matt,

    I tried your class in my test environment. Here are my findings:

    Using Microsoft's Process Monitor
    <http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx>, we
    capture Puppet's call to MSIEXE, the "command line" value reads:

    msiexec.exe /qn /no restart /i \\\\example.com\\temp\\python-2.7.3.amd64.msi
    INSTALLDIR=C:\python27 ALLUSERS=1

    It makes sense that you are getting an error because msiexec cannot find
    "\\\\example.com\\temp\\python-2.7.3.amd64.msi".

    In order to successfully install, change the "source" line single quotes
    (') to double quotes("). On next Puupet run, Process Monitor "command
    line" value reads:

    msiexec.exe /qn /no restart /i \\example.com\temp\python-2.7.3.amd64.msi
    INSTALLDIR=C:\python27 ALLUSERS=1


    *Another note:*Using Microsoft's orca.exe
    <http://msdn.microsoft.com/en-us/library/windows/desktop/aa370557%28v=vs.85%29.aspx>,
    the "python-2.7.3.amd64.msi" doesn't contain properties for INSTALLDIR or
    ALLUSERS. These aren't msiexec default properties either. As a result,
    these parameters are being ignored by msiexec. You wouldn't notice this
    because the values you happen provided for these errant keys are the
    defaults. If you comment the " install_options" line, it will still
    install in C:\Python27 for all users.

    If you wanted to specify a custom install directory, you would need to use
    TARGETDIR.
    If you wanted to restrict user access, you would need to use WHICHUSERS.
    WHICHUSERS accepts "ALL" or "JUSTME"

    To install for the current user in specified directory "C:\python273"

    install_options => [ { 'TARGETDIR' => 'C:\python273' }, { 'WHICHUSERS' =>
    'JUSTME' } ],


    Here is your stanza fixed (with the install_options line optional [since
    you are using the defaults]):

    class python::install {
    package { 'python':
    ensure => installed,
    provider => 'msi',
    source => "\\\\example.com
    \\software\\python\\python-2.7.3.amd64.msi",
    #install_options => [ { 'TARGETDIR' => 'C:\python27' }, {
    'WHICHUSER => 'ALL' } ],
    }
    }

    I hope this helps.

    -Kev
    Hi I've been trying to execute what you have checked done here but i still
    get the error of "does not know how to install, here is my code:

      package { "python-2.7.3.amd64":
                     ensure => 'installed',
                     source => "${$installexec}/python-2.7.3.amd64",
                     install_options => [{'TARGETDIR' => 'c:/python27'} ,
    {'WHICHUSERS' => 'ALL'} ]
                     }

    can you help me?


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/c999ebc1-ef6b-46f9-aa4b-d01b140be0c8%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Rob Reynolds at Jul 6, 2015 at 8:00 pm
    On Mon, Jul 6, 2015 at 12:42 AM, Gene Fontanilla wrote:
    On Thursday, May 23, 2013 at 5:10:48 AM UTC+8, Kevin D wrote:

    Matt,

    I tried your class in my test environment. Here are my findings:

    Using Microsoft's Process Monitor
    <http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx>, we
    capture Puppet's call to MSIEXE, the "command line" value reads:

    msiexec.exe /qn /no restart /i \\\\example.com\\temp\\python-2.7.3.amd64.msi
    INSTALLDIR=C:\python27 ALLUSERS=1

    It makes sense that you are getting an error because msiexec cannot find
    "\\\\example.com\\temp\\python-2.7.3.amd64.msi".

    In order to successfully install, change the "source" line single quotes
    (') to double quotes("). On next Puupet run, Process Monitor "command
    line" value reads:

    msiexec.exe /qn /no restart /i \\example.com\temp\python-2.7.3.amd64.msi
    INSTALLDIR=C:\python27 ALLUSERS=1


    *Another note:*Using Microsoft's orca.exe
    <http://msdn.microsoft.com/en-us/library/windows/desktop/aa370557%28v=vs.85%29.aspx>,
    the "python-2.7.3.amd64.msi" doesn't contain properties for INSTALLDIR or
    ALLUSERS. These aren't msiexec default properties either. As a result,
    these parameters are being ignored by msiexec. You wouldn't notice this
    because the values you happen provided for these errant keys are the
    defaults. If you comment the " install_options" line, it will still
    install in C:\Python27 for all users.

    If you wanted to specify a custom install directory, you would need to
    use TARGETDIR.
    If you wanted to restrict user access, you would need to use WHICHUSERS.
    WHICHUSERS accepts "ALL" or "JUSTME"

    To install for the current user in specified directory "C:\python273"

    install_options => [ { 'TARGETDIR' => 'C:\python273' }, { 'WHICHUSERS' =>
    'JUSTME' } ],


    Here is your stanza fixed (with the install_options line optional [since
    you are using the defaults]):

    class python::install {
    package { 'python':
    ensure => installed,
    provider => 'msi',
    source => "\\\\example.com
    \\software\\python\\python-2.7.3.amd64.msi",
    #install_options => [ { 'TARGETDIR' => 'C:\python27' }, {
    'WHICHUSER => 'ALL' } ],
    }
    }

    I hope this helps.

    -Kev
    Hi I've been trying to execute what you have checked done here but i still
    get the error of "does not know how to install, here is my code:

    package { "python-2.7.3.amd64":
    ensure => 'installed',
    source => "${$installexec}/python-2.7.3.amd64",
    Looks like you almost have it. You need the full path to the installer
    file. Should end with the extension ".msi".

    Your package title (e.g. "python-2.7.3.amd64") also needs to exactly match
    what programs and features will list, which is likely 'Python'.

    install_options => [{'TARGETDIR' => 'c:/python27'} ,
    {'WHICHUSERS' => 'ALL'} ]
    }

    can you help me?


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/c999ebc1-ef6b-46f9-aa4b-d01b140be0c8%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/c999ebc1-ef6b-46f9-aa4b-d01b140be0c8%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Adopter discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyAdopter>
    *
    *—**save $349!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAMJiBK6__iT4VB-8z-WKGWZ8ay3cHUWUZXzdHz4eRHnbhwUCbg%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Gene Fontanilla at Jul 7, 2015 at 2:48 am

    Looks like you almost have it. You need the full path to the installer
    file. Should end with the extension ".msi".

    Your package title (e.g. "python-2.7.3.amd64") also needs to exactly match
    what programs and features will list, which is likely 'Python'.
    >


    Hi bob,

    i added .msi file extension and
             package { "python-2.7.5.amd64.msi":
                     ensure => 'installed',
                     source => 'c:/PreRecap/python-2.7.5.amd64.msi',
                     install_options => [{'TARGETDIR' => 'c:/python27'} ,
    {'WHICHUSERS' => 'ALL'} ]
                     }
    now i get the error: Failed to install, FATAL error during installation.


      I don't know what i'm doing wrong.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/a7212f05-22ec-4144-a0e0-67d6d3908e28%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Rob Reynolds at Jul 7, 2015 at 4:40 am

    On Mon, Jul 6, 2015 at 9:48 PM, Gene Fontanilla wrote:

    Looks like you almost have it. You need the full path to the installer
    file. Should end with the extension ".msi".

    Your package title (e.g. "python-2.7.3.amd64") also needs to exactly
    match what programs and features will list, which is likely 'Python'.

    Hi bob,

    i added .msi file extension and
    package { "python-2.7.5.amd64.msi":
    ensure => 'installed',
    source => 'c:/PreRecap/python-2.7.5.amd64.msi',
    install_options => [{'TARGETDIR' => 'c:/python27'} ,
    {'WHICHUSERS' => 'ALL'} ]
    }
    now i get the error: Failed to install, FATAL error during installation.
    To verify, the file you have located at c:/PreRecap/python-2.7.5.amd64.msi
    is actually a downloaded MSI file correct?


    I don't know what i'm doing wrong.


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/a7212f05-22ec-4144-a0e0-67d6d3908e28%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/a7212f05-22ec-4144-a0e0-67d6d3908e28%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Adopter discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyAdopter>
    *
    *—**save $349!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAMJiBK7WE5nG-S7Z9%3DVxH0-fdKj2LOUXNBxT5Md5Lo71srSiNg%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Gene Fontanilla at Jul 7, 2015 at 5:40 am
    To verify, the file you have located at c:/PreRecap/python-2.7.5.
    amd64.msi is actually a downloaded MSI file correct?


    yes bob you are correct

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Rob Reynolds at Jul 8, 2015 at 6:30 pm

    On Tue, Jul 7, 2015 at 12:40 AM, Gene Fontanilla wrote:

    To verify, the file you have located at c:/PreRecap/python-2.7.5.

    amd64.msi is actually a downloaded MSI file correct?


    yes bob you are correct
    So double click the file, it should come up with an install box. Exit it
    without finishing the install. Then try running it from the command line:

    msiexec /norestart /i c:\PreRecap\python.amd64.msi TARGETDIR=c:/python27
    WHICHUSERS=ALL

    Note that msiexec may not like your forward slashes, which may indicate the
    issue.

    If that can go all the way through, then uninstall and try adding '/qn'
    (e.g. 'msiexec /qn /norestart /i ...') and running it again.

    Once you have all of the switches set properly, then you can plug it into
    the built-in package resource.

      --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Adopter discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyAdopter>
    *
    *—**save $349!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAMJiBK5q9V79G1FU-nVicLMyki67a9Y_9D6HDg-KjX2up9E3aA%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Gene Fontanilla at Jul 10, 2015 at 7:12 am
    The install box pops up and still requires me to choose the options

    I tried your script too. still same results.
    On Thursday, July 9, 2015 at 2:30:52 AM UTC+8, Rob Reynolds wrote:



    On Tue, Jul 7, 2015 at 12:40 AM, Gene Fontanilla <ginofon...@gmail.com
    <javascript:>> wrote:
    To verify, the file you have located at c:/PreRecap/python-2.7.5.

    amd64.msi is actually a downloaded MSI file correct?


    yes bob you are correct
    So double click the file, it should come up with an install box. Exit it
    without finishing the install. Then try running it from the command line:

    msiexec /norestart /i c:\PreRecap\python.amd64.msi TARGETDIR=c:/python27
    WHICHUSERS=ALL

    Note that msiexec may not like your forward slashes, which may indicate
    the issue.

    If that can go all the way through, then uninstall and try adding '/qn'
    (e.g. 'msiexec /qn /norestart /i ...') and running it again.

    Once you have all of the switches set properly, then you can plug it into
    the built-in package resource.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Adopter discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyAdopter> *
    *—**save $349!*
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/4e4dc991-f770-45d7-a2fc-068480d7cefd%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Rob Reynolds at Jul 14, 2015 at 3:04 pm

    On Fri, Jul 10, 2015 at 2:12 AM, Gene Fontanilla wrote:

    The install box pops up and still requires me to choose the options

    I tried your script too. still same results.
    On Thursday, July 9, 2015 at 2:30:52 AM UTC+8, Rob Reynolds wrote:



    On Tue, Jul 7, 2015 at 12:40 AM, Gene Fontanilla <ginofon...@gmail.com>
    wrote:
    To verify, the file you have located at c:/PreRecap/python-2.7.5.

    amd64.msi is actually a downloaded MSI file correct?


    yes bob you are correct
    So double click the file, it should come up with an install box. Exit it
    without finishing the install. Then try running it from the command line:

    msiexec /norestart /i c:\PreRecap\python.amd64.msi TARGETDIR=c:/python27
    WHICHUSERS=ALL

    Note that msiexec may not like your forward slashes, which may indicate
    the issue.

    If that can go all the way through, then uninstall and try adding '/qn'
    (e.g. 'msiexec /qn /norestart /i ...') and running it again.
    I'm guessing you didn't make it this far.


    Once you have all of the switches set properly, then you can plug it into
    the built-in package resource.

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/d0203c7f-1d6e-463e-aab3-3b89b9ed9c6f%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Adopter discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyAdopter> *
    *—**save $349!*
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/4e4dc991-f770-45d7-a2fc-068480d7cefd%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/4e4dc991-f770-45d7-a2fc-068480d7cefd%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.


    --
    Rob Reynolds
    Developer, Puppet Labs

    *PuppetConf 2015 <http://2015.puppetconf.com/> is coming to Portland,
    Oregon! Join us October 5-9.*
    *Register now to take advantage of the Early Bird discount
    <https://www.eventbrite.com/e/puppetconf-2015-october-5-9-tickets-13115894995?discount=EarlyBird>
    *
    *—**save $249!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAMJiBK7v3POZN9Yc-5%2B6a9_Mo7mkS4m-is3G0xwqYzscagLR%3DQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 3, '13 at 5:53p
activeJul 14, '15 at 3:04p
posts14
users6
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase