FAQ
Hi guys,

I'm trying to make puppet install packages on windows.

It will install exe files just fine - but msi files won't be installed.
They fail consistently :(

I've tried both having the files on a central directory - and give an UNC
path to it, and with a file resource, putting the file in c:\temp\ - they
both give the same result upon install:

                         package { "sflow":
                                 source => $architecture ? {
                                         'x86' =>
'C:\\temp\\hsflowd-win-1.22.2-x86.msi',
                                         'x64' =>
'\\\\software01\\autorepo$\\hsflowd-win-1.22.2-x64.msi',
                                         default => 'unsupported
architecture'
                                 },
                                 name => $architecture ? {
                                         'x86' => 'sflow',
                                         'x64' => 'sflow',
                                 }
                         }

If I use urls like:
'c:\\temp\\hsflowd-win-1.22.2-x86.msi' - I get Failed to install: The
network name cannot be found - after puppet runs:
msiexec.exe /qn /norestart /i c:\\temp\hsflowd-win-1.22.2-x86.msi

If I use urls like:
'c\:\\temp\\hsflowd-win-1.22.2-x86.msi'

it fails with: Failed to install: Fail on INT 24

Using Puppet-3.1.1 client on Windows Server 2003.

How do you guys install msi's on windows? :(



--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Klavs Klavsen at May 2, 2013 at 2:10 pm
    On windows server 2008 - it works perfectly.

    Den torsdag den 2. maj 2013 15.41.35 UTC+2 skrev Klavs Klavsen:
    Hi guys,

    I'm trying to make puppet install packages on windows.

    It will install exe files just fine - but msi files won't be installed.
    They fail consistently :(

    I've tried both having the files on a central directory - and give an UNC
    path to it, and with a file resource, putting the file in c:\temp\ - they
    both give the same result upon install:

    package { "sflow":
    source => $architecture ? {
    'x86' =>
    'C:\\temp\\hsflowd-win-1.22.2-x86.msi',
    'x64' =>
    '\\\\software01\\autorepo$\\hsflowd-win-1.22.2-x64.msi',
    default => 'unsupported
    architecture'
    },
    name => $architecture ? {
    'x86' => 'sflow',
    'x64' => 'sflow',
    }
    }

    If I use urls like:
    'c:\\temp\\hsflowd-win-1.22.2-x86.msi' - I get Failed to install: The
    network name cannot be found - after puppet runs:
    msiexec.exe /qn /norestart /i c:\\temp\hsflowd-win-1.22.2-x86.msi

    If I use urls like:
    'c\:\\temp\\hsflowd-win-1.22.2-x86.msi'

    it fails with: Failed to install: Fail on INT 24

    Using Puppet-3.1.1 client on Windows Server 2003.

    How do you guys install msi's on windows? :(


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Denmat at May 2, 2013 at 10:20 pm
    Sorry, I don't do much windows so can't be of much help but how does running the install command from the windows command line go? Does that install okay?

    Den
    On 03/05/2013, at 0:08, Klavs Klavsen wrote:

    On windows server 2008 - it works perfectly.

    Den torsdag den 2. maj 2013 15.41.35 UTC+2 skrev Klavs Klavsen:
    Hi guys,

    I'm trying to make puppet install packages on windows.

    It will install exe files just fine - but msi files won't be installed. They fail consistently :(

    I've tried both having the files on a central directory - and give an UNC path to it, and with a file resource, putting the file in c:\temp\ - they both give the same result upon install:

    package { "sflow":
    source => $architecture ? {
    'x86' => 'C:\\temp\\hsflowd-win-1.22.2-x86.msi',
    'x64' => '\\\\software01\\autorepo$\\hsflowd-win-1.22.2-x64.msi',
    default => 'unsupported architecture'
    },
    name => $architecture ? {
    'x86' => 'sflow',
    'x64' => 'sflow',
    }
    }

    If I use urls like:
    'c:\\temp\\hsflowd-win-1.22.2-x86.msi' - I get Failed to install: The network name cannot be found - after puppet runs:
    msiexec.exe /qn /norestart /i c:\\temp\hsflowd-win-1.22.2-x86.msi

    If I use urls like:
    'c\:\\temp\\hsflowd-win-1.22.2-x86.msi'

    it fails with: Failed to install: Fail on INT 24

    Using Puppet-3.1.1 client on Windows Server 2003.

    How do you guys install msi's on windows? :(

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Klavs Klavsen at May 3, 2013 at 6:42 am
    Den fredag den 3. maj 2013 00.22.29 UTC+2 skrev denmat:
    Sorry, I don't do much windows so can't be of much help but how does
    running the install command from the windows command line go? Does that
    install okay?
    Yup - works just fine. The fact that the same paths work fine on windows
    2008 (for that MSI) - I just tested another MSI - and it fails with the
    same INT 24 error on BOTH windows server 2003 and 2008 (whereas on the
    same 2008 - the sflow msi installs fine).

    I'm ripping my hair out here :( - and I'd hate to have to use (and learn)
    altiris on Windows, instead of Puppet.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at May 3, 2013 at 7:03 am

    On Thursday, May 2, 2013, Klavs Klavsen wrote:

    Den fredag den 3. maj 2013 00.22.29 UTC+2 skrev denmat:
    Sorry, I don't do much windows so can't be of much help but how does
    running the install command from the windows command line go? Does that
    install okay?
    Yup - works just fine. The fact that the same paths work fine on windows
    2008 (for that MSI) - I just tested another MSI - and it fails with the
    same INT 24 error on BOTH windows server 2003 and 2008 (whereas on the
    same 2008 - the sflow msi installs fine).

    I'm ripping my hair out here :( - and I'd hate to have to use (and learn)
    altiris on Windows, instead of Puppet.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com <javascript:_e({},
    'cvml', 'puppet-users%2Bunsubscribe@googlegroups.com');>.
    To post to this group, send email to puppet-users@googlegroups.com<javascript:_e({}, 'cvml', 'puppet-users@googlegroups.com');>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    Make sure to specify the package source using backslashes, otherwise
    msiexec gets confused.

    There's a ticket filed to have puppet automatically backslashify the source.

    Josh



    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Early Bird discount - save 25%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stuart Johnston at May 3, 2013 at 4:14 pm
    Klavs,

    I don't think that this is likely to be your problem, but if you do get
    past the puppet issue here, you may run into it - for Windows 2003, you
    have to use the XP build of hsflowd - eg the current release
    hsflowd-winxp-1.22.2-x86.msi<http://sourceforge.net/projects/host-sflow/files/Latest/hsflowd-winxp-1.22.2-x86.msi/download>.
    The MSI that you are trying here is only for Windows 2008/Vista or newer.

    Another minor think I've noticed with msiexec is that you have to be
    careful with the path that you give it - eg msexec /q/ i .\file.msi will
    not work, you must not include the ".\".

    regards,
    Stuart
    On Thursday, 2 May 2013 15:08:39 UTC+1, Klavs Klavsen wrote:

    On windows server 2008 - it works perfectly.

    Den torsdag den 2. maj 2013 15.41.35 UTC+2 skrev Klavs Klavsen:
    Hi guys,

    I'm trying to make puppet install packages on windows.

    It will install exe files just fine - but msi files won't be installed.
    They fail consistently :(

    I've tried both having the files on a central directory - and give an UNC
    path to it, and with a file resource, putting the file in c:\temp\ - they
    both give the same result upon install:

    package { "sflow":
    source => $architecture ? {
    'x86' =>
    'C:\\temp\\hsflowd-win-1.22.2-x86.msi',
    'x64' =>
    '\\\\software01\\autorepo$\\hsflowd-win-1.22.2-x64.msi',
    default => 'unsupported
    architecture'
    },
    name => $architecture ? {
    'x86' => 'sflow',
    'x64' => 'sflow',
    }
    }

    If I use urls like:
    'c:\\temp\\hsflowd-win-1.22.2-x86.msi' - I get Failed to install: The
    network name cannot be found - after puppet runs:
    msiexec.exe /qn /norestart /i c:\\temp\hsflowd-win-1.22.2-x86.msi

    If I use urls like:
    'c\:\\temp\\hsflowd-win-1.22.2-x86.msi'

    it fails with: Failed to install: Fail on INT 24

    Using Puppet-3.1.1 client on Windows Server 2003.

    How do you guys install msi's on windows? :(


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Klavs Klavsen at May 14, 2013 at 2:27 pm
    I switched to the winxp edition - and sflow now installs perfectly.

    I edited path to NSCP - to be EXACTLY the same as I use for sflow agent msi
    - and now it works too - atleast on win2003/x86 machines. Haven't had time
    to test on win2008.

    One odd thing - I'musing a path like this - which works:
    "\\\\my-software01\\autorepo\$\\NSCP-0.4.0.183-Win32.msi"

    However, this path works fine NSCP - the exact same - for the sflow agent
    ONLY works for windows servers on same Domain as the my-software01 machine.
    The machine on this other domain - can easily open
    \\my-software01\autorepo$ in a file explorer on the machine - but msieexec
    says it can't find the network path..

    It seems a pretty fragile package distribution mechanism :(

    Thank you for your help - if you have any ideas as to this multi-domain
    thing - which works for one msi - and NOT for the other msi.. pls. fire
    away :)

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at May 14, 2013 at 9:18 pm

    On Tue, May 14, 2013 at 7:27 AM, Klavs Klavsen wrote:

    I switched to the winxp edition - and sflow now installs perfectly.

    I edited path to NSCP - to be EXACTLY the same as I use for sflow agent
    msi - and now it works too - atleast on win2003/x86 machines. Haven't had
    time to test on win2008.

    One odd thing - I'musing a path like this - which works:
    "\\\\my-software01\\autorepo\$\\NSCP-0.4.0.183-Win32.msi"

    I've updated #20534 with more information. msiexec is fragile that way, as
    is cmd.exe.


    >
    However, this path works fine NSCP - the exact same - for the sflow agent
    ONLY works for windows servers on same Domain as the my-software01 machine.
    The machine on this other domain - can easily open
    \\my-software01\autorepo$ in a file explorer on the machine - but msieexec
    says it can't find the network path..

    If you are running msiexec directly from the command line, and it can't
    connect, but file explorer can, then it sounds like an issue with msiexec.
    Are you using DFS perhaps? Or perhaps an older version of windows installer?


    It seems a pretty fragile package distribution mechanism :(
    You should check out http://chocolatey.org, it's like apt-get for windows.
    There's a puppet chocolatey package provider here:
    https://github.com/chocolatey/puppet-chocolatey

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Early Bird discount - save 25%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 2, '13 at 1:41p
activeMay 14, '13 at 9:18p
posts8
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase