FAQ
I updated some of my gems, and I think it may be the reason I am getting
the following error when the agents try to retrieve a catalog.


err: Could not retrieve catalog from remote server: Error 400 on SERVER:
The single-table inheritance mechanism failed to locate the subclass:
'Host::Managed'. This error is raised because the column 'type' is reserved
for storing the class in case of inheritance. Please rename this column if
you didn't intend it to be used for storing the inheritance class or
overwrite Puppet::Rails::Host.inheritance_column to use another column for
that information.

Ruby 1.8.7, I believe apache is using passenger 2.2.11. I tried 3.0.19,
but then I get errors in the apache log about not finding files in the
/usr/share/puppet/rack/puppetmasterd/public, which AFAICT are application
generated.

Everything was working fine before updating the gems. I was updating the
gems because I was trying to get foreman working again after updating it.

I do not know much about ruby or passenger, so I could use some help
figuring out how to fix this issue. At least puppet-dashboard is working,
it just isn't getting any new reports due to the problems with puppet.

Thanks,

Andy

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ohad Levy at Apr 25, 2013 at 8:19 am

    On Thu, Apr 25, 2013 at 2:00 AM, genanr@allantgroup.com wrote:

    I updated some of my gems, and I think it may be the reason I am getting
    the following error when the agents try to retrieve a catalog.


    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    The single-table inheritance mechanism failed to locate the subclass:
    'Host::Managed'. This error is raised because the column 'type' is reserved
    for storing the class in case of inheritance. Please rename this column if
    you didn't intend it to be used for storing the inheritance class or
    overwrite Puppet::Rails::Host.inheritance_column to use another column for
    that information.
    this looks like the development version of foreman, are you using
    it together with storeconfigs?

    Ohad
    Ruby 1.8.7, I believe apache is using passenger 2.2.11. I tried 3.0.19,
    but then I get errors in the apache log about not finding files in the
    /usr/share/puppet/rack/puppetmasterd/public, which AFAICT are application
    generated.

    Everything was working fine before updating the gems. I was updating the
    gems because I was trying to get foreman working again after updating it.

    I do not know much about ruby or passenger, so I could use some help
    figuring out how to fix this issue. At least puppet-dashboard is working,
    it just isn't getting any new reports due to the problems with puppet.

    Thanks,

    Andy

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Genanr at Apr 25, 2013 at 2:24 pm

    On Thursday, April 25, 2013 3:19:55 AM UTC-5, ohad wrote:


    On Thu, Apr 25, 2013 at 2:00 AM, gen...@allantgroup.com <javascript:> <
    andyr7...@gmail.com <javascript:>> wrote:
    I updated some of my gems, and I think it may be the reason I am getting
    the following error when the agents try to retrieve a catalog.


    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    The single-table inheritance mechanism failed to locate the subclass:
    'Host::Managed'. This error is raised because the column 'type' is reserved
    for storing the class in case of inheritance. Please rename this column if
    you didn't intend it to be used for storing the inheritance class or
    overwrite Puppet::Rails::Host.inheritance_column to use another column for
    that information.
    this looks like the development version of foreman, are you using
    it together with storeconfigs?

    Ohad
    Yes, it is the development version of foreman and yes I am using
    storeconfigs. Is there a solution to this, or should I downgrade foreman
    to stable?

    Thanks,

    Andy

    Ruby 1.8.7, I believe apache is using passenger 2.2.11. I tried 3.0.19,
    but then I get errors in the apache log about not finding files in the
    /usr/share/puppet/rack/puppetmasterd/public, which AFAICT are application
    generated.

    Everything was working fine before updating the gems. I was updating the
    gems because I was trying to get foreman working again after updating it.

    I do not know much about ruby or passenger, so I could use some help
    figuring out how to fix this issue. At least puppet-dashboard is working,
    it just isn't getting any new reports due to the problems with puppet.

    Thanks,

    Andy

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ohad Levy at Apr 26, 2013 at 8:12 am
    On Thu, Apr 25, 2013 at 5:24 PM, genanr@allantgroup.com wrote:
    On Thursday, April 25, 2013 3:19:55 AM UTC-5, ohad wrote:



    On Thu, Apr 25, 2013 at 2:00 AM, gen...@allantgroup.com <
    andyr7...@gmail.com> wrote:
    I updated some of my gems, and I think it may be the reason I am getting
    the following error when the agents try to retrieve a catalog.


    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    The single-table inheritance mechanism failed to locate the subclass:
    'Host::Managed'. This error is raised because the column 'type' is reserved
    for storing the class in case of inheritance. Please rename this column if
    you didn't intend it to be used for storing the inheritance class or
    overwrite Puppet::Rails::Host.**inheritance_column to use another
    column for that information.
    this looks like the development version of foreman, are you using
    it together with storeconfigs?

    Ohad
    Yes, it is the development version of foreman and yes I am using
    storeconfigs. Is there a solution to this, or should I downgrade foreman
    to stable?
    One of the upcoming changes in 1.2 is to no longer share the db with
    storeconfigs (as its being replaced in favor of puppetdb anyway)...
    therefore, if you want to use the latest version and 1.2 at the same time,
    you would need to dump the db into a new foreman db (or puppet).

    Ohad
    Thanks,

    Andy

    Ruby 1.8.7, I believe apache is using passenger 2.2.11. I tried 3.0.19,
    but then I get errors in the apache log about not finding files in the
    /usr/share/puppet/rack/**puppetmasterd/public, which AFAICT are
    application generated.

    Everything was working fine before updating the gems. I was updating
    the gems because I was trying to get foreman working again after updating
    it.

    I do not know much about ruby or passenger, so I could use some help
    figuring out how to fix this issue. At least puppet-dashboard is working,
    it just isn't getting any new reports due to the problems with puppet.

    Thanks,

    Andy


    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@**googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.

    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nikolay Georgieff at Jul 10, 2013 at 5:34 pm
    Hi Ohad,

    I have the same issue since I've upgraded to 1.2. What do you mean with
      "would need to dump the db into a new foreman db (or puppet)"?
    Currently I'm sharing the same database for puppet and foreman. Should I
    just clone the same database and reconfigure Foreman and Puppet to use both
    databases?
    Please advise.

    Thank you in advance,
    Nikolay
    On Friday, April 26, 2013 1:12:36 AM UTC-7, ohad wrote:



    On Thu, Apr 25, 2013 at 5:24 PM, gen...@allantgroup.com <javascript:> <
    andyr7...@gmail.com <javascript:>> wrote:
    On Thursday, April 25, 2013 3:19:55 AM UTC-5, ohad wrote:



    On Thu, Apr 25, 2013 at 2:00 AM, gen...@allantgroup.com <
    andyr7...@gmail.com> wrote:
    I updated some of my gems, and I think it may be the reason I am
    getting the following error when the agents try to retrieve a catalog.


    err: Could not retrieve catalog from remote server: Error 400 on
    SERVER: The single-table inheritance mechanism failed to locate the
    subclass: 'Host::Managed'. This error is raised because the column 'type'
    is reserved for storing the class in case of inheritance. Please rename
    this column if you didn't intend it to be used for storing the inheritance
    class or overwrite Puppet::Rails::Host.**inheritance_column to use
    another column for that information.
    this looks like the development version of foreman, are you using
    it together with storeconfigs?

    Ohad
    Yes, it is the development version of foreman and yes I am using
    storeconfigs. Is there a solution to this, or should I downgrade foreman
    to stable?
    One of the upcoming changes in 1.2 is to no longer share the db with
    storeconfigs (as its being replaced in favor of puppetdb anyway)...
    therefore, if you want to use the latest version and 1.2 at the same time,
    you would need to dump the db into a new foreman db (or puppet).

    Ohad
    Thanks,

    Andy

    Ruby 1.8.7, I believe apache is using passenger 2.2.11. I tried 3.0.19,
    but then I get errors in the apache log about not finding files in the
    /usr/share/puppet/rack/**puppetmasterd/public, which AFAICT are
    application generated.

    Everything was working fine before updating the gems. I was updating
    the gems because I was trying to get foreman working again after updating
    it.

    I do not know much about ruby or passenger, so I could use some help
    figuring out how to fix this issue. At least puppet-dashboard is working,
    it just isn't getting any new reports due to the problems with puppet.

    Thanks,

    Andy


    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@**googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.

    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nikolay Georgieff at Jul 10, 2013 at 11:32 pm
    I solved my issue. Cloned the shared db for Foreman (emptied the type
    column @ hosts table) and updated the external_node.rb with the latest one.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Banjer at Sep 7, 2013 at 7:33 pm
    If you are upgrading to Foreman 1.2, note that you will need to set up
    puppetDB as the typical puppet storeconfigs is no longer used/supported as
    of Foreman 1.2.

    So don't delete or alter your type column in the hosts table, or you'll get
    this issue I was having:
    https://groups.google.com/forum/#!topic/foreman-users/UxON4FtROUk
    On Wednesday, July 10, 2013 7:32:13 PM UTC-4, Nikolay Georgieff wrote:

    I solved my issue. Cloned the shared db for Foreman (emptied the type
    column @ hosts table) and updated the external_node.rb with the latest one.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Banjer at Sep 7, 2013 at 8:04 pm
    Scratch my note about storeconfigs not being supported in Foreman 1.2.
    More clarification about this stuff in
    https://groups.google.com/forum/#!topic/foreman-users/UxON4FtROUk
    On Saturday, September 7, 2013 3:33:05 PM UTC-4, banjer wrote:

    If you are upgrading to Foreman 1.2, note that you will need to set up
    puppetDB as the typical puppet storeconfigs is no longer used/supported as
    of Foreman 1.2.

    So don't delete or alter your type column in the hosts table, or you'll
    get this issue I was having:
    https://groups.google.com/forum/#!topic/foreman-users/UxON4FtROUk
    On Wednesday, July 10, 2013 7:32:13 PM UTC-4, Nikolay Georgieff wrote:

    I solved my issue. Cloned the shared db for Foreman (emptied the type
    column @ hosts table) and updated the external_node.rb with the latest one.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Binoy Daniel at Sep 30, 2013 at 5:47 pm
    Hi Nikolay,

    I too facing same issue, but i could not find external_node.rb, where as we
    have /etc/puppet/nodes.rb but that file does not have any database related
    info...

    How to proceed..please help

    (I think create mysql replica with different name and update the file which
    you specified ?)

    Thanks in advance
    Binoy
    On Thursday, 11 July 2013 00:32:13 UTC+1, Nikolay Georgieff wrote:

    I solved my issue. Cloned the shared db for Foreman (emptied the type
    column @ hosts table) and updated the external_node.rb with the latest one.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 24, '13 at 11:00p
activeSep 30, '13 at 5:47p
posts9
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase