FAQ
Ubuntu 12.04 has Puppet v2.7.11.

These
http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html docs
talk about 2.7.14 and later. Specifically, the puppet module commands.

So, is there a PPA, or another method (other than compiling from source),
to update Puppet?

FYI, I did find https://launchpad.net/~mathiaz/+archive/puppet-backports but
that's a 2.6 version for Lucid. Not helpful for Precise...

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ramin K at Apr 24, 2013 at 11:38 pm

    On 4/24/2013 4:26 PM, David Reagan wrote:
    Ubuntu 12.04 has Puppet v2.7.11.

    These
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html docs
    talk about 2.7.14 and later. Specifically, the puppet module commands.

    So, is there a PPA, or another method (other than compiling from
    source), to update Puppet?
    http://docs.puppetlabs.com/guides/puppetlabs_package_repositories.html#for-debian-and-ubuntu

    Ramin


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David Reagan at Apr 24, 2013 at 11:39 pm
    See http://docs.puppetlabs.com/guides/puppetlabs_package_repositories.html
    Duh.

    Note that just upgrading didn't work to go from 2.7 to 3.1. Nor did
    dist-upgrade. I had to run apt-get purge puppet, then apt-get install
    puppet to get it installed correctly.
    On Wednesday, April 24, 2013 4:26:11 PM UTC-7, David Reagan wrote:

    Ubuntu 12.04 has Puppet v2.7.11.

    These
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html docs
    talk about 2.7.14 and later. Specifically, the puppet module commands.

    So, is there a PPA, or another method (other than compiling from source),
    to update Puppet?

    FYI, I did find https://launchpad.net/~mathiaz/+archive/puppet-backports but
    that's a 2.6 version for Lucid. Not helpful for Precise...
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 24, '13 at 11:26p
activeApr 24, '13 at 11:39p
posts3
users2
websitepuppetlabs.com

2 users in discussion

David Reagan: 2 posts Ramin K: 1 post

People

Translate

site design / logo © 2022 Grokbase