FAQ
Hello,

I am installing puppet and keep getting this error [Puppet could not
request certificate: No route to host -connect(2)]

My DNS is resloving and i can ping the master from the agent.

I have added this line to the iptables [iptables -I INPUT -s 192.168.1.20
-m tcp -p tcp --dport 8140 -j ACCEPT], where the IP is my agent.

I have also added my master ip to /etc/puppet/puppet.conf

Why am I still getting this error?
**

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Schofield at Apr 23, 2013 at 4:38 pm
    Try using "telnet <your_master_fqdn> 8140" This will validate the network
    on the proper port. ping does not use port 8140.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Martpher at Apr 23, 2013 at 10:32 pm
    I am able to ssh to both host. Am now getting the error: [Could not
    request certificate: Connection refused]

    This error is different to the first error. This one seems to deal with IP
    Tables rules.
    On Tuesday, April 23, 2013 12:37:58 PM UTC-4, Schofield wrote:


    Try using "telnet <your_master_fqdn> 8140" This will validate the network
    on the proper port. ping does not use port 8140.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Przemek at Apr 24, 2013 at 12:34 pm
    You get also this error when puppet master server is disabled or
    unresponsive (there is no response to the client and you get error)
    Make sure that your puppet master server is running by command:

    ps -aux

    If process is running and you still get this error message, kill this
    process (kill 'PID') and try run server in no--damenoize mode by command:

    puppet master --no-daemonize --verbose

    then try connect again and observe server responses
    Best Regards

    W dniu wtorek, 23 kwietnia 2013 16:57:02 UTC+2 użytkownik mart...@gmail.com
    napisał:
    Hello,

    I am installing puppet and keep getting this error [Puppet could not
    request certificate: No route to host -connect(2)]

    My DNS is resloving and i can ping the master from the agent.

    I have added this line to the iptables [iptables -I INPUT -s 192.168.1.20
    -m tcp -p tcp --dport 8140 -j ACCEPT], where the IP is my agent.

    I have also added my master ip to /etc/puppet/puppet.conf

    Why am I still getting this error?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Felix Frank at Apr 24, 2013 at 12:42 pm

    On 04/24/2013 02:34 PM, Przemek wrote:
    ps -aux
    That should just be "ps aux", no dash, actually.
    On 04/24/2013 12:24 AM, martpher@gmail.com wrote:
    I am able to ssh to both host. Am now getting the error: [Could not
    request certificate: Connection refused]

    This error is different to the first error. This one seems to deal with
    IP Tables rules.
    It pretty much says that the port is not open. This may or may not be
    iptables related.

    On the agent, make extra sure that "puppet" (or whatever you use as
    servername) resolves to a valid IP of the master machine.

    On the master, use "netstat -tlnp" to verify that there is indeed a
    process listening to port 8140, either on 0.0.0.0 or the dedicated
    master IP address. In the former case, make sure the master IP is bound
    to the machine.

    HTH,
    Felix

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Rony thomas at Apr 6, 2014 at 11:01 pm
    Could you add the hostnames and IP addresses of master and client in
    /etc/hosts on both master and client. On RHEL 5.8, I was able to fix this
    error after flushing the iptables with "iptables -F" and then saving it
    with "service iptables save".


    Kind Regards,
    Rony Thomas

    On Tuesday, 23 April 2013 10:57:02 UTC-4, mart...@gmail.com wrote:

    Hello,

    I am installing puppet and keep getting this error [Puppet could not
    request certificate: No route to host -connect(2)]

    My DNS is resloving and i can ping the master from the agent.

    I have added this line to the iptables [iptables -I INPUT -s 192.168.1.20
    -m tcp -p tcp --dport 8140 -j ACCEPT], where the IP is my agent.

    I have also added my master ip to /etc/puppet/puppet.conf

    Why am I still getting this error?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/7d860866-25b5-473a-97e8-26b7f333ff17%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Amarinder singh at Oct 16, 2014 at 1:57 pm
    Thanks Rony, that worked for me.
    On Sunday, April 6, 2014 5:24:58 AM UTC+1, rony thomas wrote:

    Could you add the hostnames and IP addresses of master and client in
    /etc/hosts on both master and client. On RHEL 5.8, I was able to fix this
    error after flushing the iptables with "iptables -F" and then saving it
    with "service iptables save".


    Kind Regards,
    Rony Thomas

    On Tuesday, 23 April 2013 10:57:02 UTC-4, mart...@gmail.com wrote:

    Hello,

    I am installing puppet and keep getting this error [Puppet could not
    request certificate: No route to host -connect(2)]

    My DNS is resloving and i can ping the master from the agent.

    I have added this line to the iptables [iptables -I INPUT -s
    192.168.1.20 -m tcp -p tcp --dport 8140 -j ACCEPT], where the IP is my
    agent.

    I have also added my master ip to /etc/puppet/puppet.conf

    Why am I still getting this error?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/b652849a-dee4-4ad6-97fc-55c515085e77%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Amarnath Reddy Manam at Nov 13, 2014 at 7:24 pm
    Hi Rony,
    I was having the same issue and given iptables -F and service iptables save
    and it worked. When i gave to open port 8140 on master server in Iptables
    it did not worked, what exactly these command are doing to make it work?
    iptables -F
    service iptables save
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/1d8f27d5-803f-43d5-aeef-cf5446b3fd8e%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Vishal Biyani at Mar 26, 2015 at 1:52 pm
    +1 to "iptables -F"

    I was saving exactly same issue on a setup I created using Vagrant - one
    master and some slaves. The agents won't connect to master no matter what
    ping/ssh etc. said. Telnet didn't work of course in spite of all other
    right configurations. Thanks for making my day!
    On Tuesday, April 23, 2013 at 8:27:02 PM UTC+5:30, mart...@gmail.com wrote:

    Hello,

    I am installing puppet and keep getting this error [Puppet could not
    request certificate: No route to host -connect(2)]

    My DNS is resloving and i can ping the master from the agent.

    I have added this line to the iptables [iptables -I INPUT -s 192.168.1.20
    -m tcp -p tcp --dport 8140 -j ACCEPT], where the IP is my agent.

    I have also added my master ip to /etc/puppet/puppet.conf

    Why am I still getting this error?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/d80656ab-57d6-4bb5-8a64-c8b2e66806ea%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Karel Lenc at Apr 27, 2016 at 12:17 pm
    Just for a reference, what worked for me was to reconfigure the firewall:

    firewall-cmd --zone=public --add-port=8140/tcp --permanent

    firewall-cmd --reload


    Source: http://www.unixmen.com/install-puppet-server-centos-7/

    No need to flush all iptables rules...


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/455d0bb5-d2aa-4da8-9633-b40ab7c26350%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Swapnil Abnave at May 4, 2016 at 4:15 pm
    @Karel Lenc
    After hours and days of headbang.
    That did worked.
    Thanks!!!
    On Wednesday, 27 April 2016 17:47:50 UTC+5:30, Karel Lenc wrote:

    Just for a reference, what worked for me was to reconfigure the firewall:

    firewall-cmd --zone=public --add-port=8140/tcp --permanent

    firewall-cmd --reload


    Source: http://www.unixmen.com/install-puppet-server-centos-7/

    No need to flush all iptables rules...

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/fdc3e95c-5c28-4a55-aba3-68ffb39f8d29%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 23, '13 at 2:57p
activeMay 4, '16 at 4:15p
posts11
users10
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase