FAQ
hi,

I want to use the jlyheden/puppet-tcpwrapper module for my hosts.allow/deny
but I can't get it working. On the puppet client (called with name "fai") I
get:

----------

err: Could not run Puppet configuration client:
Could not find dependent Exec[concat_] for
File[/var/lib/puppet/concat//fragments/15_hosts_deny_sshd]
at
/etc/puppet/environments/production/modules/concat/manifests/fragment.pp:51

---------

puppet-concat is installed and plugin-sync is enabled too. The classes
comes from LDAP and my definition looks like:

---------

cat /etc/puppet/manifests/classes/tcpwrapper.pp include concat::setup
tcpwrapper::hosts::allow { "sshd": pattern => "127.0.0.1 127.0.0.2
192.168.1.0/24" } tcpwrapper::hosts::deny { "sshd": pattern => "ALL" }

---------



If I comment out the tcpwrapper lines, /etc/hosts.allow|deny are replaced
with an empty file (except the "manged by puppet" line)

What I have done wrong?

Some more information: on the puppet client:

---------

root@FAI:~# find /var/lib/puppet/concat/

/var/lib/puppet/concat/
/var/lib/puppet/concat/_etc_hosts.allow
/var/lib/puppet/concat/_etc_hosts.allow/fragments
/var/lib/puppet/concat/_etc_hosts.allow/fragments/01_hosts_allow
/var/lib/puppet/concat/_etc_hosts.allow/fragments.concat
/var/lib/puppet/concat/_etc_hosts.allow/fragments.concat.out
/var/lib/puppet/concat/bin
/var/lib/puppet/concat/bin/concatfragments.sh
/var/lib/puppet/concat/_etc_hosts.deny
/var/lib/puppet/concat/_etc_hosts.deny/fragments
/var/lib/puppet/concat/_etc_hosts.deny/fragments/01_hosts_deny
/var/lib/puppet/concat/_etc_hosts.deny/fragments.concat
/var/lib/puppet/concat/_etc_hosts.deny/fragments.concat.out

root@FAI:~# cat /var/lib/puppet/concat/_etc_hosts.deny/fragments/01_hosts_deny
# MANAGED BY PUPPET


---------

What is strange: the directory "/var/lib/puppet/concat//fragments" doesn't
exists.

any suggestions?


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 11, '13 at 4:09p
activeApr 11, '13 at 4:09p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Denny Schierz: 1 post

People

Translate

site design / logo © 2022 Grokbase