FAQ
Hi guys,

I'm trying to understand the error below, but I'm stuck on it.

root@puppet1:~# puppet module install ispavailability-logstash --modulepath
/etc/puppet/modules-0/
Notice: Preparing to install into /etc/puppet/modules-0 ...
Notice: Downloading from https://forge.puppetlabs.com ...
Error: Could not install module 'ispavailability-logstash' (latest: v0.1.0)
No version of 'puppetlabs-stdlib' will satisfy dependencies
'ispavailability-logstash' (v0.1.0) requires 'puppetlabs-stdlib' (>=
3.0.0)
'puppetlabs-activemq' (v0.1.6) requires 'puppetlabs-stdlib' (>= 0.1.6)
'puppetlabs-apache' (v0.4.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
'puppetlabs-apt' (v0.0.4) requires 'puppetlabs-stdlib' (>= 2.2.1)
'puppetlabs-java' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
'puppetlabs-mysql' (v0.5.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
'puppetlabs-nginx' (v0.0.1) requires 'puppetlabs-stdlib' (>= 0.1.6)
'puppetlabs-ntp' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
'puppetlabs-postgresql' (v1.0.0) requires 'puppetlabs-stdlib' (v2.x)
Use `puppet module install --ignore-dependencies` to install only this
module

Puppet module shows my stdlib as invalid

├── puppetlabs-stdlib (v3.2.0) invalid

I remember I used --force last time to upgrade stdlib because of the same
dependencies issue above.

Any help is welcome.

Regards,
Felipe

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ryan Coleman at Mar 25, 2013 at 11:18 pm
    Hi Felipe,

    Comment in-line.

    On Mon, Mar 25, 2013 at 4:06 PM, Felipe Salum wrote:

    Hi guys,

    I'm trying to understand the error below, but I'm stuck on it.

    root@puppet1:~# puppet module install ispavailability-logstash
    --modulepath /etc/puppet/modules-0/
    Notice: Preparing to install into /etc/puppet/modules-0 ...
    Notice: Downloading from https://forge.puppetlabs.com ...
    Error: Could not install module 'ispavailability-logstash' (latest: v0.1.0)
    No version of 'puppetlabs-stdlib' will satisfy dependencies
    'ispavailability-logstash' (v0.1.0) requires 'puppetlabs-stdlib' (>=
    3.0.0)
    'puppetlabs-activemq' (v0.1.6) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-apache' (v0.4.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-apt' (v0.0.4) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-java' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-mysql' (v0.5.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-nginx' (v0.0.1) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-ntp' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-postgresql' (v1.0.0) requires 'puppetlabs-stdlib' (v2.x)
    It's breaking because logstash requires stdlib version 3 or greater but
    puppetlabs-postgresql requires something in the 2.x series.

    Version 1.2.1 of postgresql looks like it removes this restriction.
    https://github.com/puppetlabs/puppet-postgresql/blob/master/Modulefile#L10
    If you try again, are you getting the latest version of postgresql? Given
    the output provided, I don't see why you're getting 1.0.0 of postgresql.

    As you noted, you can use --ignore-dependencies to skip this validation and
    manually install the modules you need.

    Use `puppet module install --ignore-dependencies` to install only this
    module

    Puppet module shows my stdlib as invalid

    ├── puppetlabs-stdlib (v3.2.0) invalid

    I remember I used --force last time to upgrade stdlib because of the same
    dependencies issue above.

    Any help is welcome.

    Regards,
    Felipe

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Ryan Coleman | Modules & Forge | @ryanycoleman | ryancoleman in #puppet

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Felipe Salum at Mar 26, 2013 at 12:50 am
    Thanks Ryan.

    After a few upgrades (inifile,puppetdb,postgresql and a few others) I got
    my dependency issue fixed :)

    Regards,
    Felipe
    On Mon, Mar 25, 2013 at 4:17 PM, Ryan Coleman wrote:

    Hi Felipe,

    Comment in-line.

    On Mon, Mar 25, 2013 at 4:06 PM, Felipe Salum wrote:

    Hi guys,

    I'm trying to understand the error below, but I'm stuck on it.

    root@puppet1:~# puppet module install ispavailability-logstash
    --modulepath /etc/puppet/modules-0/
    Notice: Preparing to install into /etc/puppet/modules-0 ...
    Notice: Downloading from https://forge.puppetlabs.com ...
    Error: Could not install module 'ispavailability-logstash' (latest:
    v0.1.0)
    No version of 'puppetlabs-stdlib' will satisfy dependencies
    'ispavailability-logstash' (v0.1.0) requires 'puppetlabs-stdlib' (>=
    3.0.0)
    'puppetlabs-activemq' (v0.1.6) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-apache' (v0.4.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-apt' (v0.0.4) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-java' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-mysql' (v0.5.0) requires 'puppetlabs-stdlib' (>= 2.2.1)
    'puppetlabs-nginx' (v0.0.1) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-ntp' (v0.2.0) requires 'puppetlabs-stdlib' (>= 0.1.6)
    'puppetlabs-postgresql' (v1.0.0) requires 'puppetlabs-stdlib' (v2.x)
    It's breaking because logstash requires stdlib version 3 or greater but
    puppetlabs-postgresql requires something in the 2.x series.

    Version 1.2.1 of postgresql looks like it removes this restriction.
    https://github.com/puppetlabs/puppet-postgresql/blob/master/Modulefile#L10
    If you try again, are you getting the latest version of postgresql? Given
    the output provided, I don't see why you're getting 1.0.0 of postgresql.

    As you noted, you can use --ignore-dependencies to skip this validation
    and manually install the modules you need.

    Use `puppet module install --ignore-dependencies` to install only
    this module

    Puppet module shows my stdlib as invalid

    ├── puppetlabs-stdlib (v3.2.0) invalid

    I remember I used --force last time to upgrade stdlib because of the same
    dependencies issue above.

    Any help is welcome.

    Regards,
    Felipe

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Ryan Coleman | Modules & Forge | @ryanycoleman | ryancoleman in #puppet


    --
    You received this message because you are subscribed to a topic in the
    Google Groups "Puppet Users" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/puppet-users/DMl5OPNvtfQ/unsubscribe?hl=en
    .
    To unsubscribe from this group and all its topics, send an email to
    puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 25, '13 at 11:06p
activeMar 26, '13 at 12:50a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Felipe Salum: 2 posts Ryan Coleman: 1 post

People

Translate

site design / logo © 2021 Grokbase