FAQ
Hi,



I am using puppet 2.6.2-5 in debian 6.0.3.

I would like to execute puppet in standalone, with "puppet apply", but
puppet does not start because it can't resolv the hostname to any IP (which
is normal since i have no reason to have a hostname that resolves to an IP)
Is it possible to somehow disable this check in puppet, so that it starts
without trying to resolv the hostname ?
I don't want the execution to be dependant of whether the hostname resolv
to something or not.


Here is an example of what happens:



root@server1:/etc/puppet/modules# more sshd_server/manifests/init.pp

node default {

include sshd_server

}

class sshd_server {


file { 'sshd_config':

path => '/etc/ssh/sshd_config',

ensure => file,

owner => 'root',

group => 'root',

mode => '0644',

content =>
template("/etc/puppet/modules/sshd_server/templates/sshd_config.erb"),
notify => Service['sshd-server'],
}



service { 'sshd-server':

name => 'ssh',

ensure => running,

provider => debian,

enable => true,

hasrestart => true,

hasstatus => true,

}

}


root@server1:/etc/puppet/modules# puppet apply
sshd_server/manifests/init.pp --verbose --debug
Could not retrieve hostname: getaddrinfo: Name or service not known

Could not retrieve hostname: getaddrinfo: Name or service not known

dnsdomainname: Name or service not known

/usr/lib/ruby/1.8/puppet/defaults.rb:190: undefined method `downcase' for
nil:NilClass (NoMethodError)
from /usr/lib/ruby/1.8/puppet.rb:100:in `require'

from /usr/lib/ruby/1.8/puppet.rb:100

from /usr/lib/ruby/1.8/puppet/application.rb:278:in `require'

from /usr/lib/ruby/1.8/puppet/application.rb:278:in `initialize'

from /usr/lib/ruby/1.8/puppet/util/command_line.rb:55:in `new'

from /usr/lib/ruby/1.8/puppet/util/command_line.rb:55:in `execute'

from /usr/bin/puppet:4

root@server1:/etc/puppet/modules# more /etc/hosts

127.0.0.1 localhost.localdomain localhost

root@server1:/etc/puppet/modules# hostname

server1

root@server1:/etc/puppet/modules#

Any ideas ?
Thx

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Keith Burdis at Mar 22, 2013 at 5:26 pm
    Try adding an entry for your hostname in /etc/hosts - for example:

    127.0.0.1 server1

    - Keith
    On 22 Mar 2013 08:38, "bibop554" wrote:


    Hi,



    I am using puppet 2.6.2-5 in debian 6.0.3.

    I would like to execute puppet in standalone, with "puppet apply", but
    puppet does not start because it can't resolv the hostname to any IP (which
    is normal since i have no reason to have a hostname that resolves to an IP)
    Is it possible to somehow disable this check in puppet, so that it starts
    without trying to resolv the hostname ?
    I don't want the execution to be dependant of whether the hostname resolv
    to something or not.


    Here is an example of what happens:



    root@server1:/etc/puppet/modules# more sshd_server/manifests/init.pp

    node default {

    include sshd_server

    }

    class sshd_server {


    file { 'sshd_config':

    path => '/etc/ssh/sshd_config',

    ensure => file,

    owner => 'root',

    group => 'root',

    mode => '0644',

    content =>
    template("/etc/puppet/modules/sshd_server/templates/sshd_config.erb"),
    notify => Service['sshd-server'],
    }



    service { 'sshd-server':

    name => 'ssh',

    ensure => running,

    provider => debian,

    enable => true,

    hasrestart => true,

    hasstatus => true,

    }

    }


    root@server1:/etc/puppet/modules# puppet apply
    sshd_server/manifests/init.pp --verbose --debug
    Could not retrieve hostname: getaddrinfo: Name or service not known

    Could not retrieve hostname: getaddrinfo: Name or service not known

    dnsdomainname: Name or service not known

    /usr/lib/ruby/1.8/puppet/defaults.rb:190: undefined method `downcase' for
    nil:NilClass (NoMethodError)
    from /usr/lib/ruby/1.8/puppet.rb:100:in `require'

    from /usr/lib/ruby/1.8/puppet.rb:100

    from /usr/lib/ruby/1.8/puppet/application.rb:278:in `require'

    from /usr/lib/ruby/1.8/puppet/application.rb:278:in `initialize'

    from /usr/lib/ruby/1.8/puppet/util/command_line.rb:55:in `new'

    from /usr/lib/ruby/1.8/puppet/util/command_line.rb:55:in `execute'

    from /usr/bin/puppet:4

    root@server1:/etc/puppet/modules# more /etc/hosts

    127.0.0.1 localhost.localdomain localhost

    root@server1:/etc/puppet/modules# hostname

    server1

    root@server1:/etc/puppet/modules#

    Any ideas ?
    Thx


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 22, '13 at 8:38a
activeMar 22, '13 at 5:26p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Keith Burdis: 1 post Bibop554: 1 post

People

Translate

site design / logo © 2022 Grokbase