FAQ
Hi all,

1)I installed puppet agent in one of the server and i gave the name of the
master for which it needs to be connected as puppet. But am unable to
connect to the host..the certificate is not present in the master when i
searched for it with this command *puppet cert list -all *am getting this
error in the master *err: Could not call list: header too long header too
long.*
**
2)When am trying to connect through the agent to the master with *puppet
agent --test , *am getting host name look up failure..and unable to connect
to there..

3) You can see the result of *puppet agent --test* in this link - *
http://192.168.24.171:8080/softwares/connect*<http://192.168.24.171:8080/softwares/connect>
* *

4) You can see the result of *puppet agent --test --debug* in this link -* *
*http://192.168.24.171:8080/softwares/debug*<http://192.168.24.171:8080/softwares/debug>

*dnsdomainname: Host name lookup failure
dnsdomainname: Host name lookup failure
*
this is common in the starting two lines of both the commands

Can any one please suggest me a solution for this..

Regards,

Ramya Y

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Yarlagadda ramya at Mar 20, 2013 at 6:08 am

    On Wednesday, 20 March 2013 11:36:30 UTC+5:30, yarlagadda ramya wrote:
    Hi all,
    I tried disabling selinux also..i disabled it..but still am getting the
    same errors.
    1)I installed puppet agent in one of the server and i gave the name of the
    master for which it needs to be connected as puppet. But am unable to
    connect to the host..the certificate is not present in the master when i
    searched for it with this command *puppet cert list -all *am getting this
    error in the master *err: Could not call list: header too long header
    too long.*
    **
    2)When am trying to connect through the agent to the master with *puppet
    agent --test , *am getting host name look up failure..and unable to
    connect to there..

    3) You can see the result of *puppet agent --test* in this link - *
    http://192.168.24.171:8080/softwares/connect*<http://192.168.24.171:8080/softwares/connect>
    * *

    4) You can see the result of *puppet agent --test --debug* in this link -*
    **http://192.168.24.171:8080/softwares/debug*<http://192.168.24.171:8080/softwares/debug>

    *dnsdomainname: Host name lookup failure
    dnsdomainname: Host name lookup failure
    *
    this is common in the starting two lines of both the commands

    Can any one please suggest me a solution for this..

    Regards,

    Ramya Y
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Krish at Mar 20, 2013 at 6:21 am
    Please refrain from multi-posting the same problem. :)


    --
    Krish

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Felix Frank at Mar 21, 2013 at 1:17 pm
    Uhm - those links you posted use an unroutable address. So that's not
    going to work for anyone.
    On 03/20/2013 07:06 AM, yarlagadda ramya wrote:
    *dnsdomainname: Host name lookup failure
    dnsdomainname: Host name lookup failure
    *
    this is common in the starting two lines of both the commands
    Facter cannot detect your host's FQDN because dnsdomainname -f isn't
    working.

    The easiest way to resolve this is adding a suitable line near the top
    of your /etc/hosts file. You can generate this line like this:

    echo `facter ipaddress` my.fully-qualfied-name.domain `facter hostname`

    of course, replacing my.fully-qualfied-name.domain with the actual fqdn.

    Puppet cannot work until "facter fqdn" returns a sensible value.

    HTH,
    Felix

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 20, '13 at 6:06a
activeMar 21, '13 at 1:17p
posts4
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase