FAQ
I'm trying to connect multiple masters to one dashboard and I'm having
trouble with Facter. I started out initially with one master connected to
the dashboard and that one works perfectly fine. Then I added a second
master by setting the reporturl to point to the dashboard. The new nodes
appeared and it shows the run results without any problems. The issue I'm
having is when I try to look at the facts all I have is an error saying "Could
not retrieve facts from inventory service: 404 "Could not find facts
xxxx.domain" where xxx.domain is my actual hostname. I know facter works
because on the second puppet master I can run a puppet facts find command
and pull the facts about the machine. Has anybody else attempted this
before and run into this problem?

Thanks!

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Nathan Long at Mar 19, 2013 at 4:45 pm
    I ended up figuring it out myself finally. In order to accomplish this you
    need to set up PuppetDB. Then you point all masters to PuppetDB as the
    inventory service and Puppet Dashboard will pull from there instead of the
    master directly. Of course, in order to point multiple masters at PuppetDB
    you need to have a central CA. In my case the nodes connecting to my second
    master didn't have direct access to the CA so I had to set up apache with
    passenger and proxy my CA requests to the central CA. Now everything works
    and I'm getting facts for all machines in my dashboard.
    On Thursday, March 14, 2013 4:56:04 PM UTC-5, Nathan Long wrote:

    I'm trying to connect multiple masters to one dashboard and I'm having
    trouble with Facter. I started out initially with one master connected to
    the dashboard and that one works perfectly fine. Then I added a second
    master by setting the reporturl to point to the dashboard. The new nodes
    appeared and it shows the run results without any problems. The issue I'm
    having is when I try to look at the facts all I have is an error saying "Could
    not retrieve facts from inventory service: 404 "Could not find facts
    xxxx.domain" where xxx.domain is my actual hostname. I know facter works
    because on the second puppet master I can run a puppet facts find command
    and pull the facts about the machine. Has anybody else attempted this
    before and run into this problem?

    Thanks!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 16, '13 at 1:27a
activeMar 19, '13 at 4:45p
posts2
users1
websitepuppetlabs.com

1 user in discussion

Nathan Long: 2 posts

People

Translate

site design / logo © 2022 Grokbase