FAQ
I really hate to bother everyone with with something I'm sure is super
basic, but I'm stumped.

I've read the module serving guide, I checked my syntax with puppet-lint, I
think I have everything in place, yet I keep getting the same error:


Tue Mar 12 11:49:28 -0500 2013 Puppet (notice): Starting Puppet client
version 2.6.17
Tue Mar 12 11:49:28 -0500 2013 /File[/var/lib/puppet/lib] (err): Could not
evaluate: Could not retrieve information from environment production
source(s) puppet://puppet/plugins
Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//File[/etc/ssh/sshd_config]
(err): Could not evaluate: Could not retrieve information from environment
production source(s) puppet:///modules/sshd/sshd_config at
/etc/puppet/manifests/site.pp:20
Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (notice):
Dependency File[/etc/ssh/sshd_config] has failures: true
Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (warning):
Skipping because of failed dependencies
I was thinking there was some sort of permissions error somewhere? But
since I'm running as root, I don't think that's likely, plus I have even
777 the sshd_config to test. Here is my site.pp, if anyone can look it over
and at least point me in the right direction it would be greatly
appreciated. I've already scoured this forum, but I think I'm missing
something.

package { 'openssh':
ensure => installed,
}

file { '/etc/ssh/sshd_config':
source => 'puppet:///modules/sshd/sshd_config',
owner => root,
group => root,
mode => '0640',
notify => Service['sshd'], #restart sshd.
require => Package['openssh'],
}

service { 'sshd':
ensure => running,
enable => true,
hasstatus => true,
hasrestart => true,
}
Any help would be greatly appreciated.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ellison Marks at Mar 12, 2013 at 5:51 pm
    Might be an auth.conf problem. Have you changed anything in there?
    On Tuesday, March 12, 2013 10:16:02 AM UTC-7, Race Boyer wrote:

    I really hate to bother everyone with with something I'm sure is super
    basic, but I'm stumped.

    I've read the module serving guide, I checked my syntax with puppet-lint,
    I think I have everything in place, yet I keep getting the same error:


    Tue Mar 12 11:49:28 -0500 2013 Puppet (notice): Starting Puppet client
    version 2.6.17
    Tue Mar 12 11:49:28 -0500 2013 /File[/var/lib/puppet/lib] (err): Could
    not evaluate: Could not retrieve information from environment production
    source(s) puppet://puppet/plugins
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//File[/etc/ssh/sshd_config]
    (err): Could not evaluate: Could not retrieve information from environment
    production source(s) puppet:///modules/sshd/sshd_config at
    /etc/puppet/manifests/site.pp:20
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (notice):
    Dependency File[/etc/ssh/sshd_config] has failures: true
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (warning):
    Skipping because of failed dependencies
    I was thinking there was some sort of permissions error somewhere? But
    since I'm running as root, I don't think that's likely, plus I have even
    777 the sshd_config to test. Here is my site.pp, if anyone can look it over
    and at least point me in the right direction it would be greatly
    appreciated. I've already scoured this forum, but I think I'm missing
    something.

    package { 'openssh':
    ensure => installed,
    }

    file { '/etc/ssh/sshd_config':
    source => 'puppet:///modules/sshd/sshd_config',
    owner => root,
    group => root,
    mode => '0640',
    notify => Service['sshd'], #restart sshd.
    require => Package['openssh'],
    }

    service { 'sshd':
    ensure => running,
    enable => true,
    hasstatus => true,
    hasrestart => true,
    }
    Any help would be greatly appreciated.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Race Boyer at Mar 12, 2013 at 6:02 pm
    No, I've never looked at it before. Should it be changed or remain
    unchanged? Or configured to allow one to access modules?
    On Tuesday, March 12, 2013 12:45:51 PM UTC-5, Ellison Marks wrote:

    Might be an auth.conf problem. Have you changed anything in there?
    On Tuesday, March 12, 2013 10:16:02 AM UTC-7, Race Boyer wrote:

    I really hate to bother everyone with with something I'm sure is super
    basic, but I'm stumped.

    I've read the module serving guide, I checked my syntax with puppet-lint,
    I think I have everything in place, yet I keep getting the same error:


    Tue Mar 12 11:49:28 -0500 2013 Puppet (notice): Starting Puppet client
    version 2.6.17
    Tue Mar 12 11:49:28 -0500 2013 /File[/var/lib/puppet/lib] (err): Could
    not evaluate: Could not retrieve information from environment production
    source(s) puppet://puppet/plugins
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//File[/etc/ssh/sshd_config]
    (err): Could not evaluate: Could not retrieve information from environment
    production source(s) puppet:///modules/sshd/sshd_config at
    /etc/puppet/manifests/site.pp:20
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (notice):
    Dependency File[/etc/ssh/sshd_config] has failures: true
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (warning):
    Skipping because of failed dependencies
    I was thinking there was some sort of permissions error somewhere? But
    since I'm running as root, I don't think that's likely, plus I have even
    777 the sshd_config to test. Here is my site.pp, if anyone can look it over
    and at least point me in the right direction it would be greatly
    appreciated. I've already scoured this forum, but I think I'm missing
    something.

    package { 'openssh':
    ensure => installed,
    }

    file { '/etc/ssh/sshd_config':
    source => 'puppet:///modules/sshd/sshd_config',
    owner => root,
    group => root,
    mode => '0640',
    notify => Service['sshd'], #restart sshd.
    require => Package['openssh'],
    }

    service { 'sshd':
    ensure => running,
    enable => true,
    hasstatus => true,
    hasrestart => true,
    }
    Any help would be greatly appreciated.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ellison Marks at Mar 12, 2013 at 8:34 pm
    If you haven't touched it, it should be fine. Other things to keep in mind:

    The puppetmaster is probably running as the user puppet, not root, and even
    if the file itself is readable by all, the intervening directories might be
    more restrictive.
    On Tuesday, March 12, 2013 11:02:01 AM UTC-7, Race Boyer wrote:

    No, I've never looked at it before. Should it be changed or remain
    unchanged? Or configured to allow one to access modules?
    On Tuesday, March 12, 2013 12:45:51 PM UTC-5, Ellison Marks wrote:

    Might be an auth.conf problem. Have you changed anything in there?
    On Tuesday, March 12, 2013 10:16:02 AM UTC-7, Race Boyer wrote:

    I really hate to bother everyone with with something I'm sure is super
    basic, but I'm stumped.

    I've read the module serving guide, I checked my syntax with
    puppet-lint, I think I have everything in place, yet I keep getting the
    same error:


    Tue Mar 12 11:49:28 -0500 2013 Puppet (notice): Starting Puppet client
    version 2.6.17
    Tue Mar 12 11:49:28 -0500 2013 /File[/var/lib/puppet/lib] (err): Could
    not evaluate: Could not retrieve information from environment production
    source(s) puppet://puppet/plugins
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//File[/etc/ssh/sshd_config]
    (err): Could not evaluate: Could not retrieve information from environment
    production source(s) puppet:///modules/sshd/sshd_config at
    /etc/puppet/manifests/site.pp:20
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (notice):
    Dependency File[/etc/ssh/sshd_config] has failures: true
    Tue Mar 12 11:49:29 -0500 2013 /Stage[main]//Service[sshd] (warning):
    Skipping because of failed dependencies
    I was thinking there was some sort of permissions error somewhere? But
    since I'm running as root, I don't think that's likely, plus I have even
    777 the sshd_config to test. Here is my site.pp, if anyone can look it over
    and at least point me in the right direction it would be greatly
    appreciated. I've already scoured this forum, but I think I'm missing
    something.

    package { 'openssh':
    ensure => installed,
    }

    file { '/etc/ssh/sshd_config':
    source => 'puppet:///modules/sshd/sshd_config',
    owner => root,
    group => root,
    mode => '0640',
    notify => Service['sshd'], #restart sshd.
    require => Package['openssh'],
    }

    service { 'sshd':
    ensure => running,
    enable => true,
    hasstatus => true,
    hasrestart => true,
    }
    Any help would be greatly appreciated.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at Mar 13, 2013 at 1:14 pm

    On Tuesday, March 12, 2013 3:34:25 PM UTC-5, Ellison Marks wrote:
    If you haven't touched it, it should be fine. Other things to keep in mind:

    The puppetmaster is probably running as the user puppet, not root, and
    even if the file itself is readable by all, the intervening directories
    might be more restrictive.
    To amplify a bit, in case it's unclear: even though the error is reported
    on the client, it occurs on the master. The fact that the agent is
    running as root is irrelevant. It appears to me that the agent is
    successfully retrieving a catalog (running the agent with debug messages
    turned on should confirm), so your manifest syntax is fine. What appears
    to be happening is a failure when the agent requests the sshd_config
    content from the master's built-in file server. Very likely either the
    master process is prevented from reading the file, or else the file is not
    located where the master is looking for it in the first place.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 12, '13 at 5:20p
activeMar 13, '13 at 1:14p
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase