FAQ
Hi,

i have 3 machines running facter (1.6.16), puppet (3.0.1) and mcollective
(2.2.1).

node1 is puppetmaster, which has activemq installed.
node2 and node3 are clients.

Actually everything works fine. When i do "mco find hosts" all nodes are
listed.
Sometimes (after a while) it seems there is no connection to mcollective on
node1.
When i do: "mco find hosts" on node1 the result is:
node2
node3

When i restart mcollective on node1 everything is fine and the result is:
node1
node2
node3

On all nodes i use ntp:
node1
Mi 6. Mär 11:36:32 CET 2013

node2
Mi 6. Mär 11:36:33 CET 2013

node3
Mi 6. Mär 11:36:33 CET 2013

This looks like ok to me.

Can anyone help me?

Greetz

Tim

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • R.I.Pienaar at Mar 6, 2013 at 10:45 am

    ----- Original Message -----
    From: "Spter" <tschmeling.obrigheim@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Wednesday, March 6, 2013 10:37:39 AM
    Subject: [Puppet Users] Mcollective, sometimes connection loss

    Hi,

    i have 3 machines running facter (1.6.16), puppet (3.0.1) and mcollective
    (2.2.1).

    node1 is puppetmaster, which has activemq installed.
    node2 and node3 are clients.

    Actually everything works fine. When i do "mco find hosts" all nodes are
    listed.
    Sometimes (after a while) it seems there is no connection to mcollective on
    node1.
    When i do: "mco find hosts" on node1 the result is:
    node2
    node3

    When i restart mcollective on node1 everything is fine and the result is:
    node1
    node2
    node3

    On all nodes i use ntp:
    node1
    Mi 6. Mär 11:36:32 CET 2013

    node2
    Mi 6. Mär 11:36:33 CET 2013

    node3
    Mi 6. Mär 11:36:33 CET 2013

    This looks like ok to me.

    Can anyone help me?

    Generally this happens because firewalls, NAT routers or session state
    tracking kills idle connections.

    When mcollective isn't used the connection is 100% idle so when these devices
    drop the connection the TCP layer of your OS doesnt even become aware.

    If that's the problem just setting:

    registerinterval = 300
    registration = Agentlist

    will probably solve it for you, if not we need to look further and will need
    to see debug logs or something.

    mcollective has its own list on google groups called mcollective-users, best
    to send these questions there if this doesnt resolve it for you

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Spter at Mar 7, 2013 at 8:20 am
    Hi,

    Am Mittwoch, 6. März 2013 11:45:31 UTC+1 schrieb R.I. Pienaar:
    Generally this happens because firewalls, NAT routers or session state
    tracking kills idle connections.

    When mcollective isn't used the connection is 100% idle so when these
    devices
    drop the connection the TCP layer of your OS doesnt even become aware.

    If that's the problem just setting:

    registerinterval = 300
    registration = Agentlist
    that works fine for me, since i changed the config.

    Thanks!

    Greetz

    Tim

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 6, '13 at 10:37a
activeMar 7, '13 at 8:20a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Spter: 2 posts R.I.Pienaar: 1 post

People

Translate

site design / logo © 2022 Grokbase