FAQ
I have try to start puppet on node and see this

debug: Exec[create_conf_dir](provider=posix): Executing check
'/usr/bin/test -d /etc/hadoop-0.20/conf'
debug: Executing '/usr/bin/test -d /etc/hadoop-0.20/conf'
debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
b64_zlib_yaml
debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
b64_zlib_yaml



then i go to htop and see 100% cpu load on one core, i try to strace and
see a lot of this:


rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
^CProcess 13207 detached


any suggestions to resolv or debug ?

Additional info:

[root@someserver ~]# puppet --version
2.7.20

[root@hd-102 ~]# facter --version
1.6.16


[root@someserver ~]# uname -a
Linux someserver 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC
2012 x86_64 x86_64 x86_64 GNU/Linux
[root@hd-102 ~]# cat /etc/issue
CentOS release 6.3 (Final)
Kernel \r on an \m

puppet master uses 2.7.20 puppet with ree and passenger.












--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Andrey Kononov at Mar 6, 2013 at 12:05 pm
    Sorry guys, it was my problem, there is recurse option enabled on big
    directory.


    среда, 6 марта 2013 г., 14:52:19 UTC+4 пользователь Andrey Kononov написал:
    I have try to start puppet on node and see this

    debug: Exec[create_conf_dir](provider=posix): Executing check
    '/usr/bin/test -d /etc/hadoop-0.20/conf'
    debug: Executing '/usr/bin/test -d /etc/hadoop-0.20/conf'
    debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
    b64_zlib_yaml
    debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
    b64_zlib_yaml



    then i go to htop and see 100% cpu load on one core, i try to strace and
    see a lot of this:


    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    ^CProcess 13207 detached


    any suggestions to resolv or debug ?

    Additional info:

    [root@someserver ~]# puppet --version
    2.7.20

    [root@hd-102 ~]# facter --version
    1.6.16


    [root@someserver ~]# uname -a
    Linux someserver 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC
    2012 x86_64 x86_64 x86_64 GNU/Linux
    [root@hd-102 ~]# cat /etc/issue
    CentOS release 6.3 (Final)
    Kernel \r on an \m

    puppet master uses 2.7.20 puppet with ree and passenger.











    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 6, '13 at 10:52a
activeMar 6, '13 at 12:05p
posts2
users1
websitepuppetlabs.com

1 user in discussion

Andrey Kononov: 2 posts

People

Translate

site design / logo © 2022 Grokbase