FAQ
Hi

I am new in Puppet and i have one error when i test Postgresql module in
infrastructure mode.
I'm using Puppet 3.1.0 in Debian squeeze or 6.0.7

i tape the next command puppetd -t -v and this is the error

info: Retrieving plugin
info: Loading facts in pe_version
info: Loading facts in postgres_default_version
info: Loading facts in iptables
info: Loading facts in puppet_vardir
info: Loading facts in root_home
info: Loading facts in facter_dot_d
info: Loading facts in pe_version
info: Loading facts in postgres_default_version
info: Loading facts in iptables
info: Loading facts in puppet_vardir
info: Loading facts in root_home
info: Loading facts in facter_dot_d
err: Could not retrieve catalog from remote server: Error 400 on SERVER:
Unsupported osfamily: operatingsystem: Debian, module postgresql currently
only supports osfamily RedHat and Debian at
/etc/puppet/modules/postgresql/manifests/params.pp:158 on node
client.crous-nancy-metz.fr
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Maarten Thibaut (mthibaut) at Mar 1, 2013 at 12:52 am
    Are you sure your client is using 3.x? This error typically crops up with older facter versions which don't define the osfamily variable.

    To test, run "facter" on your client and see if osfamily is listed.

    Sent from my iPhone

    On 01 Mar 2013, at 01:47, "Alejandro Betancourt" wrote:

    Hi

    I am new in Puppet and i have one error when i test Postgresql module in infrastructure mode.
    I'm using Puppet 3.1.0 in Debian squeeze or 6.0.7

    i tape the next command puppetd -t -v and this is the error

    info: Retrieving plugin
    info: Loading facts in pe_version
    info: Loading facts in postgres_default_version
    info: Loading facts in iptables
    info: Loading facts in puppet_vardir
    info: Loading facts in root_home
    info: Loading facts in facter_dot_d
    info: Loading facts in pe_version
    info: Loading facts in postgres_default_version
    info: Loading facts in iptables
    info: Loading facts in puppet_vardir
    info: Loading facts in root_home
    info: Loading facts in facter_dot_d
    err: Could not retrieve catalog from remote server: Error 400 on SERVER: Unsupported osfamily: operatingsystem: Debian, module postgresql currently only supports osfamily RedHat and Debian at /etc/puppet/modules/postgresql/manifests/params.pp:158 on node client.crous-nancy-metz.fr<http://client.crous-nancy-metz.fr>
    warning: Not using cache on failed catalog
    err: Could not retrieve catalog; skipping run


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com .
    To post to this group, send email to puppet-users@googlegroups.com .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alejandro Betancourt at Mar 1, 2013 at 3:55 am
    No i have a puppetmaster 3.1.0 and when i tape "facter --version" i have
    "1.6.17" and if i tape "facter operatingsystem" i have "Debian"
    are you french? because i speak french
    El viernes, 1 de marzo de 2013 01:44:35 UTC+1, Alejandro Betancourt
    escribió:
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 1, '13 at 12:47a
activeMar 1, '13 at 3:55a
posts3
users2
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase