FAQ
I just built a new puppet master, and whenever I run puppet on it, it
throws an error while processing a service resource:

# puppet agent -t
Info: Retrieving plugin
Info: Caching catalog for i-45dc2b1d
Info: Applying configuration version 'g
9ea47ad19bc706a754c00f00a024309948d3ea03'
Error: /Stage[main]/Ipa::Client::Basic/Service[sssd]: Could not evaluate:
invalid byte sequence in US-ASCII
Notice: Finished catalog run in 15.37 seconds

The debug output:

Debug: Executing '/sbin/status sssd'
Debug: Executing '/sbin/initctl --version'
Error: /Stage[main]/Ipa::Client::Basic/Service[sssd]: Could not evaluate:
invalid byte sequence in US-ASCII


This is what the manifest for that resource looks like:
service { 'sssd':
ensure => running,
enable => true,
hasstatus => true,
hasrestart => true,
require => [ Package['sssd'], File['/etc/sssd/sssd.conf'], ],
}


This is with ubuntu 12.04 and puppet 3.1
Any ideas?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Patrick Hemmer at Feb 19, 2013 at 5:02 am
    No, but it's not related to the manifest. The manifest this resource is
    in actually hasn't changed in months. Also I can reboot the box and it
    goes away. Other boxes that aren't doing it will sometimes start doing
    it when they reboot. (at least that's the behaviour I've been observing,
    but I have only rebooted a few boxes since this started occurring).
    So it seems like it's environmental, but I have no clue what.

    -Patrick

    On 02/18/2013 11:57 PM, Conor wrote:

    Have you looked for non-printable characters?

    `cat -v <filename>` is one of the easier ways to check.

    -Conor

    On Feb 18, 2013 11:54 AM, "Patrick" wrote:

    I just built a new puppet master, and whenever I run puppet on it,
    it throws an error while processing a service resource:

    # puppet agent -t
    Info: Retrieving plugin
    Info: Caching catalog for i-45dc2b1d
    Info: Applying configuration version 'g
    9ea47ad19bc706a754c00f00a024309948d3ea03'
    Error: /Stage[main]/Ipa::Client::Basic/Service[sssd]: Could
    not evaluate: invalid byte sequence in US-ASCII
    Notice: Finished catalog run in 15.37 seconds


    The debug output:

    Debug: Executing '/sbin/status sssd'
    Debug: Executing '/sbin/initctl --version'
    Error: /Stage[main]/Ipa::Client::Basic/Service[sssd]: Could
    not evaluate: invalid byte sequence in US-ASCII



    This is what the manifest for that resource looks like:

    service { 'sssd':
    ensure => running,
    enable => true,
    hasstatus => true,
    hasrestart => true,
    require => [ Package['sssd'], File['/etc/sssd/sssd.conf'], ],
    }



    This is with ubuntu 12.04 and puppet 3.1
    Any ideas?

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to puppet-users+unsubscribe@googlegroups.com
    To post to this group, send email to puppet-users@googlegroups.com
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at Feb 19, 2013 at 2:14 pm

    On Monday, February 18, 2013 11:02:05 PM UTC-6, Patrick wrote:
    No, but it's not related to the manifest. The manifest this resource is
    in actually hasn't changed in months. Also I can reboot the box and it goes
    away. Other boxes that aren't doing it will sometimes start doing it when
    they reboot. (at least that's the behaviour I've been observing, but I have
    only rebooted a few boxes since this started occurring).
    So it seems like it's environmental, but I have no clue what.
    I concur. The diagnostic messages appear to indicate that one of the
    system tools Puppet is using to manage the service (probably /sbin/initctl)
    fails with the given error message. That could well mean that the
    underlying init script (if any) or the daemon binary itself is failing, and
    initctl is just passing on the result.

    You said that the error occurs whenever you run Puppet, but you also said
    it goes away if you reboot. I'm not sure how to reconcile those. It may
    matter, because one of the potential problem areas involves whether the
    system tools return the correct response to the service's 'status'
    command. If they don't, then Puppet could try to start it when it is
    already running, to which the service might object.

    You could try to troubleshoot by running the service status, start, stop,
    and restart commands manually, and seeing what happens. Make sure to use a
    shell with the minimum possible environment -- maybe just a minimal PATH --
    because that's what the agent will do. Capture not just the behavior and
    any messages, but also the status code returned by each command.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Mateusz Fiołka at May 20, 2013 at 4:06 am
    I'm not sure if it is related to the services. It rather looks like puppet
    related to me.
    I'm having a similar problem on a newly created vps. When I do puppet apply
    first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in US-ASCII
    at 3:/root/mf-prod.pp
    Error: Could not set 'present' on ensure: invalid byte sequence in US-ASCII
    at 3:/root/mf-prod.pp
    Wrapped exception:
    invalid byte sequence in US-ASCII
    Error: /Stage[main]//Package[nginx]/ensure: change from purged to present
    failed: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp

    The mentioned file looks like this:
    package { "nginx":
             ensure => "installed"
    }

    service { "nginx":
             enable => "true",
             ensure => "running"
    }

    Hexdump:

    00000000 70 61 63 6b 61 67 65 20 7b 20 22 6e 67 69 6e 78 |package {
    "nginx|
    00000010 22 3a 0a 20 20 20 20 20 20 20 20 65 6e 73 75 72 |":.
    ensur|
    00000020 65 20 3d 3e 20 22 69 6e 73 74 61 6c 6c 65 64 22 |e =>
    "installed"|
    00000030 0a 7d 0a 0a 73 65 72 76 69 63 65 20 7b 20 22 6e |.}..service {
    "n|
    00000040 67 69 6e 78 22 3a 0a 09 65 6e 61 62 6c 65 20 3d |ginx":..enable
    =|
    00000050 3e 20 22 74 72 75 65 22 2c 0a 09 65 6e 73 75 72 |>
    "true",..ensur|
    00000060 65 20 3d 3e 20 22 72 75 6e 6e 69 6e 67 22 0a 7d |e =>
    "running".}|
    00000070 0a |.|
    00000071

    puppet version: 3.2.1-rc1
    ruby version: 2.0.0p0 (2013-02-24 revision 39474) [i686-linux]
    os: arch linux with systemd service provider

    On Tuesday, February 19, 2013 3:14:47 PM UTC+1, jcbollinger wrote:


    On Monday, February 18, 2013 11:02:05 PM UTC-6, Patrick wrote:

    No, but it's not related to the manifest. The manifest this resource is
    in actually hasn't changed in months. Also I can reboot the box and it goes
    away. Other boxes that aren't doing it will sometimes start doing it when
    they reboot. (at least that's the behaviour I've been observing, but I have
    only rebooted a few boxes since this started occurring).
    So it seems like it's environmental, but I have no clue what.
    I concur. The diagnostic messages appear to indicate that one of the
    system tools Puppet is using to manage the service (probably /sbin/initctl)
    fails with the given error message. That could well mean that the
    underlying init script (if any) or the daemon binary itself is failing, and
    initctl is just passing on the result.

    You said that the error occurs whenever you run Puppet, but you also said
    it goes away if you reboot. I'm not sure how to reconcile those. It may
    matter, because one of the potential problem areas involves whether the
    system tools return the correct response to the service's 'status'
    command. If they don't, then Puppet could try to start it when it is
    already running, to which the service might object.

    You could try to troubleshoot by running the service status, start, stop,
    and restart commands manually, and seeing what happens. Make sure to use a
    shell with the minimum possible environment -- maybe just a minimal PATH --
    because that's what the agent will do. Capture not just the behavior and
    any messages, but also the status code returned by each command.


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David Schmitt at May 21, 2013 at 9:43 am

    On 19.05.2013 14:18, Mateusz Fiołka wrote:
    I'm not sure if it is related to the services. It rather looks like
    puppet related to me.
    I'm having a similar problem on a newly created vps. When I do puppet
    apply first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp
    I've seen this error when the puppet master process started by init
    receives a different locale environment than when it is started from the
    command line.

    Check /proc/$pid/env of the running puppet master process for LANG/LC_*
    and compare that to your shell env.


    Regards, David

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • William Van Hevelingen at Sep 3, 2013 at 6:42 am
    I get the same error when running puppet-lint.... puppet 3.1.x regression?

    rake aborted!
    invalid byte sequence in US-ASCII
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `[]'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `block in tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:40:in
    `load_data'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:54:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint.rb:155:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:23:in
    `block (3 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `block (2 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:13:in
    `block in initialize'
    Tasks: TOP => lint


    On Tue, May 21, 2013 at 2:43 AM, David Schmitt wrote:
    On 19.05.2013 14:18, Mateusz Fiołka wrote:

    I'm not sure if it is related to the services. It rather looks like
    puppet related to me.
    I'm having a similar problem on a newly created vps. When I do puppet
    apply first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp
    I've seen this error when the puppet master process started by init
    receives a different locale environment than when it is started from the
    command line.

    Check /proc/$pid/env of the running puppet master process for LANG/LC_*
    and compare that to your shell env.


    Regards, David


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@**googlegroups.com<puppet-users%2Bunsubscribe@googlegroups.com>
    .
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .


    --
    Thanks,
    William

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • William Van Hevelingen at Sep 3, 2013 at 6:47 am
    Found the bug that Jeff created

    http://projects.puppetlabs.com/issues/11303

    On Mon, Sep 2, 2013 at 11:42 PM, William Van Hevelingen wrote:

    I get the same error when running puppet-lint.... puppet 3.1.x regression?

    rake aborted!
    invalid byte sequence in US-ASCII
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `[]'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `block in tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:40:in
    `load_data'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:54:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint.rb:155:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:23:in
    `block (3 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `block (2 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:13:in
    `block in initialize'
    Tasks: TOP => lint


    On Tue, May 21, 2013 at 2:43 AM, David Schmitt wrote:
    On 19.05.2013 14:18, Mateusz Fiołka wrote:

    I'm not sure if it is related to the services. It rather looks like
    puppet related to me.
    I'm having a similar problem on a newly created vps. When I do puppet
    apply first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp
    I've seen this error when the puppet master process started by init
    receives a different locale environment than when it is started from the
    command line.

    Check /proc/$pid/env of the running puppet master process for LANG/LC_*
    and compare that to your shell env.


    Regards, David


    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@**googlegroups.com<puppet-users%2Bunsubscribe@googlegroups.com>
    .
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .


    --
    Thanks,
    William


    --
    Thanks,
    William

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • William Van Hevelingen at Sep 3, 2013 at 6:50 am
    Actually the umbrella bug is now.

    http://projects.puppetlabs.com/issues/20522

    On Mon, Sep 2, 2013 at 11:47 PM, William Van Hevelingen wrote:

    Found the bug that Jeff created

    http://projects.puppetlabs.com/issues/11303

    On Mon, Sep 2, 2013 at 11:42 PM, William Van Hevelingen wrote:

    I get the same error when running puppet-lint.... puppet 3.1.x regression?

    rake aborted!
    invalid byte sequence in US-ASCII
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `[]'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:120:in
    `block in tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/lexer.rb:119:in
    `tokenise'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:40:in
    `load_data'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/plugin.rb:54:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint.rb:155:in
    `run'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:23:in
    `block (3 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `each'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:21:in
    `block (2 levels) in initialize'
    /shadow/home/blkperl/.rvm/gems/ruby-1.9.3-p194/gems/puppet-lint-0.3.2/lib/puppet-lint/tasks/puppet-lint.rb:13:in
    `block in initialize'
    Tasks: TOP => lint


    On Tue, May 21, 2013 at 2:43 AM, David Schmitt wrote:
    On 19.05.2013 14:18, Mateusz Fiołka wrote:

    I'm not sure if it is related to the services. It rather looks like
    puppet related to me.
    I'm having a similar problem on a newly created vps. When I do puppet
    apply first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp
    I've seen this error when the puppet master process started by init
    receives a different locale environment than when it is started from the
    command line.

    Check /proc/$pid/env of the running puppet master process for LANG/LC_*
    and compare that to your shell env.


    Regards, David


    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users+unsubscribe@**googlegroups.com<puppet-users%2Bunsubscribe@googlegroups.com>
    .
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/**group/puppet-users?hl=en<http://groups.google.com/group/puppet-users?hl=en>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .


    --
    Thanks,
    William


    --
    Thanks,
    William


    --
    Thanks,
    William

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nawaid Shamim at Dec 18, 2013 at 2:24 pm
    Setting system locales worked

    Try running "dpkg-reconfigure locales"

    Thanks,

    Nawaid.
    On Tuesday, May 21, 2013 10:43:06 AM UTC+1, David Schmitt wrote:
    On 19.05.2013 14:18, Mateusz Fiołka wrote:
    I'm not sure if it is related to the services. It rather looks like
    puppet related to me.
    I'm having a similar problem on a newly created vps. When I do puppet
    apply first time I get the message:

    Error: Could not set 'present' on ensure: invalid byte sequence in
    US-ASCII at 3:/root/mf-prod.pp
    I've seen this error when the puppet master process started by init
    receives a different locale environment than when it is started from the
    command line.

    Check /proc/$pid/env of the running puppet master process for LANG/LC_*
    and compare that to your shell env.


    Regards, David
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/d903dbcb-3d3b-4671-87f8-de70e1f8a412%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 18, '13 at 7:54p
activeDec 18, '13 at 2:24p
posts9
users6
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase