FAQ
Hello Guys;

Any clue what might be causing this? I am using MCollective on FreeBSD.


MCollective::Agent::Puppet: MCollective::DDLValidationError
I, [2013-02-14T20:06:07.516501 #9435] INFO -- : mcollectived:31 The
Marionette Collective 2.1.1 started logging at info level
E, [2013-02-14T20:06:07.546737 #9438] ERROR -- : agent.rb:58:in `load_ddl'
Failed to load DDL for the 'puppet' agent, DDLs are required:
NoMethodError: undefined method `requires' for
#<MCollective::DDL:0x801d36860>
E, [2013-02-14T20:06:07.546946 #9438] ERROR -- : agents.rb:71:in
`loadagent' Loading agent puppet failed: Could not create instance of
plugin MCollective::Agent::Puppet: MCollective::DDLValidationError


Thanks!
Bee

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • R.I.Pienaar at Feb 14, 2013 at 8:15 pm

    ----- Original Message -----
    From: "Worker Bee" <beeworker08@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Thursday, February 14, 2013 8:08:37 PM
    Subject: [Puppet Users] Mcollective on FreeBSD Error

    Hello Guys;

    Any clue what might be causing this? I am using MCollective on FreeBSD.


    MCollective::Agent::Puppet: MCollective::DDLValidationError
    I, [2013-02-14T20:06:07.516501 #9435] INFO -- : mcollectived:31 The
    Marionette Collective 2.1.1 started logging at info level
    E, [2013-02-14T20:06:07.546737 #9438] ERROR -- : agent.rb:58:in `load_ddl'
    Failed to load DDL for the 'puppet' agent, DDLs are required:
    NoMethodError: undefined method `requires' for
    #<MCollective::DDL:0x801d36860>
    E, [2013-02-14T20:06:07.546946 #9438] ERROR -- : agents.rb:71:in
    `loadagent' Loading agent puppet failed: Could not create instance of
    plugin MCollective::Agent::Puppet: MCollective::DDLValidationError
    the new puppet agent requires version 2.2.2 of mcollective at least

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 14, '13 at 8:08p
activeFeb 14, '13 at 8:15p
posts2
users2
websitepuppetlabs.com

2 users in discussion

R.I.Pienaar: 1 post Worker Bee: 1 post

People

Translate

site design / logo © 2021 Grokbase