FAQ
Hi,
When i m using Postgresql database with puppetdb in puppet 3.0.2,
following error is coming.
err: Could not retrieve catalog from remote server: Error 400 on SERVER:
Failed to submit 'replace facts' command for abcd.example.com to PuppetDB
at puppet-DB.example.com:8081: Connection refused - connect(2)
Can anyone have any solution regarding this?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ken Barber at Feb 12, 2013 at 10:32 am
    Hi Heena,

    Is your puppetdb system separate from your puppetmaster? If so, you
    probably need to make sure that PuppetDB is listening on the correct
    interface. By default we only listen on 127.0.0.1.

    Take a look at:

    /etc/puppetdb/conf.d/jetty.ini

    And set the 'ssl-host' entry to your public interface, that can either
    be a specific IP address you wish to listen to, or 0.0.0.0 to listen
    on all ipv4 interfaces.

    Note: you will need to restart puppetdb before the setting takes affect.

    ken.
    On Tue, Feb 12, 2013 at 10:14 AM, Heena wrote:
    Hi,
    When i m using Postgresql database with puppetdb in puppet 3.0.2, following
    error is coming.
    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Failed to submit 'replace facts' command for abcd.example.com to PuppetDB at
    puppet-DB.example.com:8081: Connection refused - connect(2)
    Can anyone have any solution regarding this?

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Heena at Feb 12, 2013 at 10:55 am
    Hi,

    Thanks for the reply.
    I am using same system for puppetmaster and puppetdb.

    On Tuesday, February 12, 2013 4:02:18 PM UTC+5:30, Ken Barber wrote:

    Hi Heena,

    Is your puppetdb system separate from your puppetmaster? If so, you
    probably need to make sure that PuppetDB is listening on the correct
    interface. By default we only listen on 127.0.0.1.

    Take a look at:

    /etc/puppetdb/conf.d/jetty.ini

    And set the 'ssl-host' entry to your public interface, that can either
    be a specific IP address you wish to listen to, or 0.0.0.0 to listen
    on all ipv4 interfaces.

    Note: you will need to restart puppetdb before the setting takes affect.

    ken.

    On Tue, Feb 12, 2013 at 10:14 AM, Heena <rush...@gmail.com <javascript:>>
    wrote:
    Hi,
    When i m using Postgresql database with puppetdb in puppet 3.0.2, following
    error is coming.
    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Failed to submit 'replace facts' command for abcd.example.com to
    PuppetDB at
    puppet-DB.example.com:8081: Connection refused - connect(2)
    Can anyone have any solution regarding this?

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ken Barber at Feb 12, 2013 at 11:01 am
    Regardless, if the hostname 'puppet-DB.example.com' in your settings
    points to a public IP address that is not 127.0.0.1, PuppetDB might
    not be listening on that interface. Double check this, and potentially
    change the 'ssl-host' setting as suggested to see if it resolves your
    issue.
    On Tue, Feb 12, 2013 at 10:55 AM, Heena wrote:
    Hi,

    Thanks for the reply.
    I am using same system for puppetmaster and puppetdb.


    On Tuesday, February 12, 2013 4:02:18 PM UTC+5:30, Ken Barber wrote:

    Hi Heena,

    Is your puppetdb system separate from your puppetmaster? If so, you
    probably need to make sure that PuppetDB is listening on the correct
    interface. By default we only listen on 127.0.0.1.

    Take a look at:

    /etc/puppetdb/conf.d/jetty.ini

    And set the 'ssl-host' entry to your public interface, that can either
    be a specific IP address you wish to listen to, or 0.0.0.0 to listen
    on all ipv4 interfaces.

    Note: you will need to restart puppetdb before the setting takes affect.

    ken.
    On Tue, Feb 12, 2013 at 10:14 AM, Heena wrote:
    Hi,
    When i m using Postgresql database with puppetdb in puppet 3.0.2,
    following
    error is coming.
    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Failed to submit 'replace facts' command for abcd.example.com to
    PuppetDB at
    puppet-DB.example.com:8081: Connection refused - connect(2)
    Can anyone have any solution regarding this?

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an
    email to puppet-users...@googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • at0S at Feb 13, 2013 at 9:49 am
    Hi Ken,

    In my case the issue was *ssl-host = <fqdn>* in jetty.ini
    Changed to *ssl-host = 0.0.0.0*
    and now it is fine, thank you!

    вторник, 12 февраля 2013 г., 21:14:31 UTC+11 пользователь Heena написал:
    Hi,
    When i m using Postgresql database with puppetdb in puppet 3.0.2,
    following error is coming.
    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Failed to submit 'replace facts' command for abcd.example.com to PuppetDB
    at puppet-DB.example.com:8081: Connection refused - connect(2)
    Can anyone have any solution regarding this?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 12, '13 at 10:14a
activeFeb 13, '13 at 9:49a
posts5
users3
websitepuppetlabs.com

3 users in discussion

Heena: 2 posts Ken Barber: 2 posts at0S: 1 post

People

Translate

site design / logo © 2022 Grokbase