FAQ
I am in the process of upgrading a Tomcat module to support version 7. As
such I copied one of the template files and made the slightest change to
the filename, from etc-initd-tomcat6 to etc-initd-tomcat7. The permissions
and ownership on the files are identical however when invoking Puppet it
throws the following error.

err: /File[/etc/init.d/tomcat_sso01]: Could not evaluate: Could not
retrieve information from environment dev source(s)
puppet:///modules/tomcat/etc-initd-tomcat7

I validated that it isn't the contents of the file as I've tried changing
the file to only include simple text with no difference.

The File code is:

file { "/etc/init.d/tomcat_sso01":
source => "puppet:///modules/tomcat/etc-initd-tomcat7",
mode => 755,
owner => root,
group => root,
ensure => present
}

If I change the 7 to a 6 in the source line everything works fine. As you
can see, the files and permissions are the same.

-rw-rw-r-- 1 root root 2848 Nov 15 18:07 etc-sysconfig-tomcat6.erb
-rw-rw-r-- 1 root root 2848 Nov 15 18:07 etc-sysconfig-tomcat7.erb


I'm running Puppet 2.6.17.

I've tried running the server in debug mode but no errors are reported on
that side. When running the agent in debug mode it doesn't show anything
indicative of a problem:

debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson
err: /File[/etc/init.d/tomcat_sso01]: Could not evaluate: Could not
retrieve information from environment dev source(s)
puppet:///modules/tomcat/etc-initd-tomcat7 at
/mnt/nas01/puppetmaster/src/lib/dev/tomcat/manifests/defines/app_builder.pp:225
debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
pson



I've been using Puppet for 3 years and have never seen anything like this.
Any thoughts?

Thanks,

John

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • John Martin at Feb 11, 2013 at 7:30 pm
    Solved the issue. It was simply that I was referencing source instead of
    template in the File resource. The pre-existing code had scripts in both
    the files and templates directories, which I didn't realize. I copied the
    file in the templates directory instead of files. Such a rookie mistake...

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 11, '13 at 5:26p
activeFeb 11, '13 at 7:30p
posts2
users1
websitepuppetlabs.com

1 user in discussion

John Martin: 2 posts

People

Translate

site design / logo © 2022 Grokbase