I'm working with Foreman 1.1RC4 on CentOS 6.3 and a PostgreSQL 9.1.7

I'm noticing that our Windows agents will report with a hostname that is
uppercase (which it is on the agent), which show up fine in the Foreman GUI
and the PSQL DB.
The puppet certname in lowercase, of course.

When a user clicks on the hostname in the GUI, it throws a "Host not found"
page. e.g. http://foreman:3000/hosts/1OFOURSERVERS.domain.tld
If you then add a '/facts' in the above URL, it goes through successfully
to the hosts' facts page. This also works with '/audits' and '/reports'.

I have also removed the uppercased host, renamed the Windows servers to a
lowercase name and it all works okay. We just can't do this manual process
for each of our three hundred machines.

Can anyone help me with a workaround or help fix this bug?


p.s. Apologizes for the xpost from the foreman users group.

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
postedFeb 11, '13 at 9:40p
activeFeb 11, '13 at 9:40p

1 user in discussion

Tim Owens: 1 post



site design / logo © 2023 Grokbase