FAQ

----- Original Message -----
From: "Worker Bee" <beeworker08@gmail.com>
To: puppet-users@googlegroups.com
Sent: Friday, February 8, 2013 6:27:25 PM
Subject: [Puppet Users] Mcollective/Puppet Plug-In

Hi Everyone;

I am stumped. I have installed Mcollective and the puppet plugin on both
RHEL and AIX. Everything is working fine on RHEL. However, I keep getting
the following error on my AIX boxes. I have verified the configuration,
etc....

On AIX, I do install everything into /opt/puppet. So, I am wondeting if
there is some pathing issue that I cannot find. perhaps. At any rate, any
help/advice would be greatly appreciated!

Both the puupetmaster and the Mcollective Client are running on RHEL
servers.


[root@puppet5 ~]# mco puppet runonce --server aixbox -v

The puppet application failed to run, use -v for full error details: Cannot
validate input: Unknown validator: 'puppet_server_address'.

Cannot validate input: Unknown validator: 'puppet_server_address'.
(MCollective::DDLValidationError)
from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/base.rb:144:in
`validate_input_argument' <----
from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:167:in
`validate_rpc_request'
from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
`each'
from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
`validate_rpc_request'
from /usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:219:in
`method_missing'
from /usr/libexec/mcollective/mcollective/application/puppet.rb:280:in
`runonce_command'
from /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
`send'
from /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
`main'
from /usr/lib/ruby/site_ruby/1.8/mcollective/application.rb:285:in `run'
from /usr/lib/ruby/site_ruby/1.8/mcollective/applications.rb:23:in `run'
from /usr/sbin/mco:20

seems that $mco_libdir/mcollective/validator/puppet_server_address.* isn't installed

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Worker Bee at Feb 8, 2013 at 9:48 pm
    You are correct, I do not.

    I followed these instructions explicitly...
    http://projects.puppetlabs.com/projects/mcollective-plugins/wiki/InstallingPlugins

    Do I need to copy all of the directories and files in the zip distro to
    $mco_libdir?

    Thanks! Bee

    On Fri, Feb 8, 2013 at 1:37 PM, R.I.Pienaar wrote:


    ----- Original Message -----
    From: "Worker Bee" <beeworker08@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Friday, February 8, 2013 6:27:25 PM
    Subject: [Puppet Users] Mcollective/Puppet Plug-In

    Hi Everyone;

    I am stumped. I have installed Mcollective and the puppet plugin on both
    RHEL and AIX. Everything is working fine on RHEL. However, I keep getting
    the following error on my AIX boxes. I have verified the configuration,
    etc....

    On AIX, I do install everything into /opt/puppet. So, I am wondeting if
    there is some pathing issue that I cannot find. perhaps. At any rate, any
    help/advice would be greatly appreciated!

    Both the puupetmaster and the Mcollective Client are running on RHEL
    servers.


    [root@puppet5 ~]# mco puppet runonce --server aixbox -v

    The puppet application failed to run, use -v for full error details: Cannot
    validate input: Unknown validator: 'puppet_server_address'.

    Cannot validate input: Unknown validator: 'puppet_server_address'.
    (MCollective::DDLValidationError)
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/base.rb:144:in
    `validate_input_argument' <----
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:167:in
    `validate_rpc_request'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
    `each'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
    `validate_rpc_request'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:219:in
    `method_missing'
    from
    /usr/libexec/mcollective/mcollective/application/puppet.rb:280:in
    `runonce_command'
    from
    /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
    `send'
    from
    /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
    `main'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/application.rb:285:in `run'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/applications.rb:23:in `run'
    from /usr/sbin/mco:20

    seems that $mco_libdir/mcollective/validator/puppet_server_address.* isn't
    installed

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • R.I.Pienaar at Feb 8, 2013 at 8:58 pm

    ----- Original Message -----
    From: "Worker Bee" <beeworker08@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Friday, February 8, 2013 8:06:07 PM
    Subject: Re: [Puppet Users] Mcollective/Puppet Plug-In

    You are correct, I do not.

    I followed these instructions explicitly...
    http://projects.puppetlabs.com/projects/mcollective-plugins/wiki/InstallingPlugins

    Do I need to copy all of the directories and files in the zip distro to
    $mco_libdir?
    yeah - expect a refresh of those docs soonish sorry about that.

    copy all of them except spec yes

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Worker Bee at Feb 9, 2013 at 2:35 am
    Thanks!
    On Fri, Feb 8, 2013 at 2:12 PM, R.I.Pienaar wrote:


    ----- Original Message -----
    From: "Worker Bee" <beeworker08@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Friday, February 8, 2013 8:06:07 PM
    Subject: Re: [Puppet Users] Mcollective/Puppet Plug-In

    You are correct, I do not.

    I followed these instructions explicitly...
    http://projects.puppetlabs.com/projects/mcollective-plugins/wiki/InstallingPlugins
    Do I need to copy all of the directories and files in the zip distro to
    $mco_libdir?
    yeah - expect a refresh of those docs soonish sorry about that.

    copy all of them except spec yes

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Worker Bee at Feb 9, 2013 at 2:03 am
    Hi Everyone;

    I am stumped. I have installed Mcollective and the puppet plugin on both
    RHEL and AIX. Everything is working fine on RHEL. However, I keep getting
    the following error on my AIX boxes. I have verified the configuration,
    etc....

    On AIX, I do install everything into /opt/puppet. So, I am wondeting if
    there is some pathing issue that I cannot find. perhaps. At any rate, any
    help/advice would be greatly appreciated!

    Both the puupetmaster and the Mcollective Client are running on RHEL
    servers.


    [root@puppet5 ~]# mco puppet runonce --server aixbox -v

    The puppet application failed to run, use -v for full error details: Cannot
    validate input: Unknown validator: 'puppet_server_address'.

    Cannot validate input: Unknown validator: 'puppet_server_address'.
    (MCollective::DDLValidationError)
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/base.rb:144:in
    `validate_input_argument' <----
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:167:in
    `validate_rpc_request'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
    `each'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/ddl/agentddl.rb:159:in
    `validate_rpc_request'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:219:in
    `method_missing'
    from /usr/libexec/mcollective/mcollective/application/puppet.rb:280:in
    `runonce_command'
    from /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
    `send'
    from /usr/libexec/mcollective/mcollective/application/puppet.rb:317:in
    `main'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/application.rb:285:in `run'
    from /usr/lib/ruby/site_ruby/1.8/mcollective/applications.rb:23:in `run'
    from /usr/sbin/mco:20


    Thanks!
    Bee

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 8, '13 at 7:31p
activeFeb 9, '13 at 2:35a
posts5
users2
websitepuppetlabs.com

2 users in discussion

Worker Bee: 3 posts R.I.Pienaar: 2 posts

People

Translate

site design / logo © 2022 Grokbase