FAQ
Hi Gary,

Thanks for clearing that up, so would it be possible just to upgrade the puppet part of the PE stack?

Or would that cause untold amount of issues?

Thanks in advance

Jim

Sent from my iPhone
On 8 Feb 2013, at 16:35, Gary Larizza wrote:

Hi there,

I can absolutely see how this is confusing, let me see if I can help clear it up for you. The open source version of Puppet is currently at version 3.1.0, however Puppet Enterprise (the product stack) is at version 2.7.1 which is based on version 2.7.19 of the open source version of Puppet. Puppet Enterprise is comprised of several projects (Puppet, Facter, MCollective, Puppet Enterprise Console, Cloud Provisioner, etc...), and so its version is entirely decoupled from Puppet's current version (but they're so close in version numbers that it becomes confusing).

Hope that helps!

On Fri, Feb 8, 2013 at 3:52 AM, jim wrote:
Hello all,

I've seen post about Puppet 3.x being available for download but doesn't mention Enterprise ?

Is this the same thing ? from puppet labs site i can only find 2.7.x

regards

James
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.


--
Gary Larizza
Professional Services Engineer
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jim at Feb 8, 2013 at 9:03 pm
    Hello all,

    I've seen post about Puppet 3.x being available for download but doesn't
    mention Enterprise ?

    Is this the same thing ? from puppet labs site i can only find 2.7.x

    regards

    James

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Gary Larizza at Feb 9, 2013 at 1:29 am
    Hi there,

    I can absolutely see how this is confusing, let me see if I can help clear
    it up for you. The open source version of Puppet is currently at version
    3.1.0, however Puppet Enterprise (the product stack) is at version 2.7.1
    which is based on version 2.7.19 of the open source version of Puppet.
    Puppet Enterprise is comprised of several projects (Puppet, Facter,
    MCollective, Puppet Enterprise Console, Cloud Provisioner, etc...), and so
    its version is entirely decoupled from Puppet's current version (but
    they're so close in version numbers that it becomes confusing).

    Hope that helps!

    On Fri, Feb 8, 2013 at 3:52 AM, jim wrote:

    Hello all,

    I've seen post about Puppet 3.x being available for download but doesn't
    mention Enterprise ?

    Is this the same thing ? from puppet labs site i can only find 2.7.x

    regards

    James

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Gary Larizza
    Professional Services Engineer

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Gary Larizza at Feb 9, 2013 at 3:54 am
    Puppet Enterprise installs specific versions of its components into
    /opt/puppet and locks them in at that version (Puppet Enterprise is
    essentially our 'stable' build that lags behind the open source version).
    Upgrading Puppet in its 'vendored' location is a very bad idea for many
    reasons. Puppet Enterprise will move to Puppet 3.x.x eventually - is there
    something specific in the 3.x.x branch that you're needing?

    On Fri, Feb 8, 2013 at 8:41 AM, James Matthews wrote:

    Hi Gary,

    Thanks for clearing that up, so would it be possible just to upgrade the
    puppet part of the PE stack?

    Or would that cause untold amount of issues?

    Thanks in advance

    Jim

    Sent from my iPhone

    On 8 Feb 2013, at 16:35, Gary Larizza wrote:

    Hi there,

    I can absolutely see how this is confusing, let me see if I can help clear
    it up for you. The open source version of Puppet is currently at version
    3.1.0, however Puppet Enterprise (the product stack) is at version 2.7.1
    which is based on version 2.7.19 of the open source version of Puppet.
    Puppet Enterprise is comprised of several projects (Puppet, Facter,
    MCollective, Puppet Enterprise Console, Cloud Provisioner, etc...), and so
    its version is entirely decoupled from Puppet's current version (but
    they're so close in version numbers that it becomes confusing).

    Hope that helps!

    On Fri, Feb 8, 2013 at 3:52 AM, jim wrote:

    Hello all,

    I've seen post about Puppet 3.x being available for download but doesn't
    mention Enterprise ?

    Is this the same thing ? from puppet labs site i can only find 2.7.x

    regards

    James

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Gary Larizza
    Professional Services Engineer

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Gary Larizza
    Professional Services Engineer

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 8, '13 at 4:48p
activeFeb 9, '13 at 3:54a
posts4
users2
websitepuppetlabs.com

2 users in discussion

Gary Larizza: 2 posts Jim: 2 posts

People

Translate

site design / logo © 2022 Grokbase