FAQ
Hi joe,

Thanks for getting back, that doen't work. And i was thinking that the
following syntaxe's are for:
Collecting Virtual resources -> <| |>
Collecting exported resources -> <|| ||>

Please correct me if i am wrong.
On Friday, February 8, 2013 11:08:20 AM UTC-8, joe wrote:

I think your collector syntax is off. Try this:

File <| tag == 'tmp-file' |> (note the fewer | characters)

That should probably be a syntax error...
On Friday, February 8, 2013 10:25:37 AM UTC-7, ashrith wrote:

I am trying to export store config's using puppetdb as follows:

node test {
@@file { "/tmp/test":
content => "test file",
tag => "tmp-file",
}
}

node test2 {
File <|| tag == 'tmp-file' ||>
}

And, then when I run puppet on node test the resource is being exported
and can be verified by looking into puppetdb (table: catalog_resources).
But, when I run puppet on node test2 strangely the resource is not being
realized and created.

Mean while my nagios module developed based on stored-configs is working
fine, this module was able to export as well as realize stored-configs from
puppetdb.

Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

I kind of stuck and cannot find a way to resolve this issue, any help is
appreciated.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ashrith at Feb 9, 2013 at 2:26 am
    I am trying to export store config's using puppetdb as follows:

    node test {
    @@file { "/tmp/test":
    content => "test file",
    tag => "tmp-file",
    }
    }

    node test2 {
    File <|| tag == 'tmp-file' ||>
    }

    And, then when I run puppet on node test the resource is being exported and
    can be verified by looking into puppetdb (table: catalog_resources). But,
    when I run puppet on node test2 strangely the resource is not being
    realized and created.

    Mean while my nagios module developed based on stored-configs is working
    fine, this module was able to export as well as realize stored-configs from
    puppetdb.

    Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

    I kind of stuck and cannot find a way to resolve this issue, any help is
    appreciated.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Joe at Feb 8, 2013 at 11:22 pm
    I think your collector syntax is off. Try this:

    File <| tag == 'tmp-file' |> (note the fewer | characters)

    That should probably be a syntax error...
    On Friday, February 8, 2013 10:25:37 AM UTC-7, ashrith wrote:

    I am trying to export store config's using puppetdb as follows:

    node test {
    @@file { "/tmp/test":
    content => "test file",
    tag => "tmp-file",
    }
    }

    node test2 {
    File <|| tag == 'tmp-file' ||>
    }

    And, then when I run puppet on node test the resource is being exported
    and can be verified by looking into puppetdb (table: catalog_resources).
    But, when I run puppet on node test2 strangely the resource is not being
    realized and created.

    Mean while my nagios module developed based on stored-configs is working
    fine, this module was able to export as well as realize stored-configs from
    puppetdb.

    Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

    I kind of stuck and cannot find a way to resolve this issue, any help is
    appreciated.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Gary Larizza at Feb 9, 2013 at 2:54 am
    It's actually <<| |>> -->
    http://docs.puppetlabs.com/guides/exported_resources.html

    On Fri, Feb 8, 2013 at 11:28 AM, ashrith wrote:

    Hi joe,

    Thanks for getting back, that doen't work. And i was thinking that the
    following syntaxe's are for:
    Collecting Virtual resources -> <| |>
    Collecting exported resources -> <|| ||>

    Please correct me if i am wrong.

    On Friday, February 8, 2013 11:08:20 AM UTC-8, joe wrote:

    I think your collector syntax is off. Try this:

    File <| tag == 'tmp-file' |> (note the fewer | characters)

    That should probably be a syntax error...
    On Friday, February 8, 2013 10:25:37 AM UTC-7, ashrith wrote:

    I am trying to export store config's using puppetdb as follows:

    node test {
    @@file { "/tmp/test":
    content => "test file",
    tag => "tmp-file",
    }
    }

    node test2 {
    File <|| tag == 'tmp-file' ||>
    }

    And, then when I run puppet on node test the resource is being exported
    and can be verified by looking into puppetdb (table: catalog_resources).
    But, when I run puppet on node test2 strangely the resource is not being
    realized and created.

    Mean while my nagios module developed based on stored-configs is working
    fine, this module was able to export as well as realize stored-configs from
    puppetdb.

    Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

    I kind of stuck and cannot find a way to resolve this issue, any help is
    appreciated.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Gary Larizza
    Professional Services Engineer

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ashrith at Feb 8, 2013 at 8:40 pm
    Sorry for the confusion, you are right Gary its <<| |>> (for collecting
    exported resources). But for some reason its still not collecting the
    resource. Is there any way to force puppet to collect the exported resource?

    Thanks,
    Ashrith.
    On Friday, February 8, 2013 11:29:40 AM UTC-8, Gary Larizza wrote:

    It's actually <<| |>> -->
    http://docs.puppetlabs.com/guides/exported_resources.html


    On Fri, Feb 8, 2013 at 11:28 AM, ashrith <ash...@cloudwick.com<javascript:>
    wrote:
    Hi joe,

    Thanks for getting back, that doen't work. And i was thinking that the
    following syntaxe's are for:
    Collecting Virtual resources -> <| |>
    Collecting exported resources -> <|| ||>

    Please correct me if i am wrong.

    On Friday, February 8, 2013 11:08:20 AM UTC-8, joe wrote:

    I think your collector syntax is off. Try this:

    File <| tag == 'tmp-file' |> (note the fewer | characters)

    That should probably be a syntax error...
    On Friday, February 8, 2013 10:25:37 AM UTC-7, ashrith wrote:

    I am trying to export store config's using puppetdb as follows:

    node test {
    @@file { "/tmp/test":
    content => "test file",
    tag => "tmp-file",
    }
    }

    node test2 {
    File <|| tag == 'tmp-file' ||>
    }

    And, then when I run puppet on node test the resource is being exported
    and can be verified by looking into puppetdb (table: catalog_resources).
    But, when I run puppet on node test2 strangely the resource is not being
    realized and created.

    Mean while my nagios module developed based on stored-configs is
    working fine, this module was able to export as well as realize
    stored-configs from puppetdb.

    Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

    I kind of stuck and cannot find a way to resolve this issue, any help
    is appreciated.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Gary Larizza
    Professional Services Engineer
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jakov Sosic at Feb 9, 2013 at 12:59 am

    On 02/08/2013 08:39 PM, ashrith wrote:
    Sorry for the confusion, you are right Gary its <<| |>> (for collecting
    exported resources). But for some reason its still not collecting the
    resource. Is there any way to force puppet to collect the exported resource?
    Try to remove dash (-) from your tag, maybe that confuses it?


    node test {
    @@file { "/tmp/test":
    content => "test file",
    tag => 'tmpfile',
    }
    }

    node test2 {
    File <<| tag == 'tmpfile' |>>
    }

    Also, can you maybe show puppetdb log, do you see both "replacing facts"
    and "replacing catalog" on a node 'test' agent run?




    --
    Jakov Sosic
    www.srce.unizg.hr

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 8, '13 at 7:29p
activeFeb 9, '13 at 2:54a
posts6
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase