FAQ
I think your collector syntax is off. Try this:

File <| tag == 'tmp-file' |> (note the fewer | characters)

That should probably be a syntax error...
On Friday, February 8, 2013 10:25:37 AM UTC-7, ashrith wrote:

I am trying to export store config's using puppetdb as follows:

node test {
@@file { "/tmp/test":
content => "test file",
tag => "tmp-file",
}
}

node test2 {
File <|| tag == 'tmp-file' ||>
}

And, then when I run puppet on node test the resource is being exported
and can be verified by looking into puppetdb (table: catalog_resources).
But, when I run puppet on node test2 strangely the resource is not being
realized and created.

Mean while my nagios module developed based on stored-configs is working
fine, this module was able to export as well as realize stored-configs from
puppetdb.

Puppet version being used is 3.1.0 and puppetdb version is 1.1.1.

I kind of stuck and cannot find a way to resolve this issue, any help is
appreciated.
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 8, '13 at 11:22p
activeFeb 8, '13 at 11:22p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Joe: 1 post

People

Translate

site design / logo © 2022 Grokbase