Hi there,

Can anyone please tell me (or explain) what's I'm doing wrong here:

Have the Nagios module installed and this is a Nagios check, where I'm
facing the problem.

nagios_service { "check_dns_${::my_cname}":
use => 'generic-service',
check_command => "check_remote_dns!${::my_cname}",
service_description => "CON: ${::my_cname}",
display_name => 'Check DNS (talend JobServer)',
servicegroups => 'talend',
hostgroup_name => 'talend-job',

*"my_cname" *is custom-fact, which I'm using in various other places
without nay problem. But here, the value is not getting substituted. All I
get this:

define service {
display_name Check DNS (talend JobServer)
servicegroups talend
service_description CON:
hostgroup_name talend-job
## --PUPPET_NAME-- (called '_naginator_name' in the
manifest) check_dns_{my_cname}
use generic-service
check_command check_remote_dns!
on the Nagios server (in the nagios_service.cfg). Any idea what's I'm doing
wrong? cheers!!

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
postedFeb 8, '13 at 9:46p
activeFeb 8, '13 at 9:46p

1 user in discussion

Sans: 1 post



site design / logo © 2023 Grokbase