FAQ
Hi everyone,


I am trying to use the option '--configdir' with puppet node but it doesn't
seem to work:
sudo puppet --configdir=/etc/puppet/conf --terminus puppetdb servername.fqdn
See 'puppet help' for help on available puppet subcommands

Needed info:
# cat /etc/debian_version
6.0.6
# dpkg -l '*puppetdb*'
Desired=Unknown/Install/Remove/Purge/Hold

Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
/ Name Version
Description
+++-===========================================-===========================================-======================================================================================================
ii puppetdb 1.1.0-1puppetlabs1
PuppetDB Centralized Storage.
ii puppetdb-terminus 1.1.0-1puppetlabs1
Connect Puppet to PuppetDB by setting up a terminus for
PuppetDB.


Any idea if this option will be backported?

When I copy the puppet.conf in /etc/puppet:
sudo puppet node status servername.fqdn --verbose --terminus puppetdb
servername.fqdn
Currently active
Last catalog: 2013-01-30T09:17:49.000Z
Last facts: 2013-01-30T09:17:23.606Z



Regards,
JM

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Dominic Cleal at Jan 30, 2013 at 12:42 pm

    On 30/01/13 12:27, Antidot SAS wrote:

    I am trying to use the option '--configdir' with puppet node but it
    doesn't seem to work:
    sudo puppet --configdir=/etc/puppet/conf --terminus puppetdb servername.fqdn
    See 'puppet help' for help on available puppet subcommands
    You're missing the "node status" subcommand out of this, plus the config
    setting is --confdir or --config. Try this instead:

    puppet node status --confdir=/etc/puppet/conf --terminus puppetdb
    servername.fqdn

    See
    http://docs.puppetlabs.com/references/stable/configuration.html#confdir
    for the settings.

    --
    Dominic Cleal
    Red Hat Engineering

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Antidot SAS at Jan 30, 2013 at 1:46 pm
    You are right sorry for the disturbance...


    On Wed, Jan 30, 2013 at 1:42 PM, Dominic Cleal wrote:
    On 30/01/13 12:27, Antidot SAS wrote:

    I am trying to use the option '--configdir' with puppet node but it
    doesn't seem to work:
    sudo puppet --configdir=/etc/puppet/conf --terminus puppetdb
    servername.fqdn
    See 'puppet help' for help on available puppet subcommands
    You're missing the "node status" subcommand out of this, plus the config
    setting is --confdir or --config. Try this instead:

    puppet node status --confdir=/etc/puppet/conf --terminus puppetdb
    servername.fqdn

    See
    http://docs.puppetlabs.com/references/stable/configuration.html#confdir
    for the settings.

    --
    Dominic Cleal
    Red Hat Engineering

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 30, '13 at 12:28p
activeJan 30, '13 at 1:46p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Antidot SAS: 2 posts Dominic Cleal: 1 post

People

Translate

site design / logo © 2022 Grokbase