FAQ
Hi,
I have a problem with puppet upgrade from 2.7 to 3.0 on centos 5.
I have included the puppet dependencies repo for el5
(http://yum.puppetlabs.com/el/5/dependencies/x86_64/) to upgrade my ruby
version to 1.8.7.
However a "yum install ruby" will give me ruby 1.8.5 from the centos base
repo.
If i disable the base repo i get ruby 1.8.7 but ruby-libs has depsolving
problems - it requires libtk8.4.so which is not present in any of my repos.

Resolving Dependencies
--> Running transaction check
---> Package ruby.x86_64 0:1.8.7.370-1.el5 set to be updated
--> Processing Dependency: ruby-libs = 1.8.7.370-1.el5 for package: ruby
--> Running transaction check
---> Package ruby-libs.x86_64 0:1.8.7.370-1.el5 set to be updated
--> Processing Dependency: libtk8.4.so()(64bit) for package: ruby-libs
--> Finished Dependency Resolution
ruby-libs-1.8.7.370-1.el5.x86_64 from puppetlabs-deps has depsolving
problems
--> Missing Dependency: libtk8.4.so()(64bit) is needed by package
ruby-libs-1.8.7.370-1.el5.x86_64 (puppetlabs-deps)
Error: Missing Dependency: libtk8.4.so()(64bit) is needed by package
ruby-libs-1.8.7.370-1.el5.x86_64 (puppetlabs-deps)

Anyone can help me sort out the problem?

Thanks
Pascal

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/H5RoktnypwwJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Dan White at Jan 23, 2013 at 2:47 pm
    Use both repos with the puppetlabs repo at a higher priority (Google: yum priority)


    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    ----- Original Message -----
    From: "Pascal Schmiel" <pascal.schmiel@gmail.com>
    To: puppet-users@googlegroups.com
    Sent: Wednesday, January 23, 2013 5:32:37 AM
    Subject: [Puppet Users] Problem with Puppet upgrade 2.7 => 3.0 on Centos 5 using puppetlabs dependencies repo.

    Hi,
    I have a problem with puppet upgrade from 2.7 to 3.0 on centos 5.
    I have included the puppet dependencies repo for el5 (http://yum.puppetlabs.com/el/5/dependencies/x86_64/) to upgrade my ruby version to 1.8.7.
    However a "yum install ruby" will give me ruby 1.8.5 from the centos base repo.
    If i disable the base repo i get ruby 1.8.7 but ruby-libs has depsolving problems - it requires libtk8.4.so which is not present in any of my repos.



    Resolving Dependencies
    --> Running transaction check
    ---> Package ruby.x86_64 0:1.8.7.370-1.el5 set to be updated
    --> Processing Dependency: ruby-libs = 1.8.7.370-1.el5 for package: ruby
    --> Running transaction check
    ---> Package ruby-libs.x86_64 0:1.8.7.370-1.el5 set to be updated
    --> Processing Dependency: libtk8.4.so()(64bit) for package: ruby-libs
    --> Finished Dependency Resolution
    ruby-libs-1.8.7.370-1.el5.x86_64 from puppetlabs-deps has depsolving problems
    --> Missing Dependency: libtk8.4.so()(64bit) is needed by package ruby-libs-1.8.7.370-1.el5.x86_64 (puppetlabs-deps)
    Error: Missing Dependency: libtk8.4.so()(64bit) is needed by package ruby-libs-1.8.7.370-1.el5.x86_64 (puppetlabs-deps)


    Anyone can help me sort out the problem?


    Thanks
    Pascal

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/H5RoktnypwwJ .
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 23, '13 at 2:25p
activeJan 23, '13 at 2:47p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Pascal Schmiel: 1 post Dan White: 1 post

People

Translate

site design / logo © 2021 Grokbase