FAQ
Hi

I am trying to install cloud provisioner on windows puppet. I just used
"puppet module install puppetlabs/cloudprovisioner". It gave the following
error. Error: `puppet module` actions are currently not supported on
Microsoft Windows.
It is that we should work with cloudprovisioner tarball on windows puppet.
Please help me out in working with the tarball


Regards

PuppetUser

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/l8r5BMr2CPUJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Josh Cooper at Jan 11, 2013 at 4:09 pm

    On Thu, Jan 10, 2013 at 10:34 PM, PuppetUser wrote:
    Hi

    I am trying to install cloud provisioner on windows puppet. I just used
    "puppet module install puppetlabs/cloudprovisioner". It gave the following
    error. Error: `puppet module` actions are currently not supported on
    Microsoft Windows.
    It is that we should work with cloudprovisioner tarball on windows puppet.
    Please help me out in working with the tarball


    Regards

    PuppetUser

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/l8r5BMr2CPUJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    We currently do not support running the module tool on windows due to
    its reliance on tar as a packing format. This will be fixed in a
    future release, see http://projects.puppetlabs.com/issues/11276.

    The workflow instead is to install the module on your master, and run
    `puppet agent` on the windows host, which will pluginsync the
    necessary files from the master to the agent host.

    The puppetlabs-registry module provides more details about how this
    process works on windows:
    https://forge.puppetlabs.com/puppetlabs/registry

    If instead you want to use `puppet apply`, then you can extract the
    tarball and point your modulepath at it as described here:
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • GRANIER Bernard (MORPHO) at Jan 11, 2013 at 4:24 pm
    Hi,

    For export control reasons, I am looking for an information.

    Puppet is using cryptography and certificates, is it with openssl only ?

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51


    #
    " This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Peter Brown at Jan 13, 2013 at 10:44 pm
    Yes Puppet uses openssl for it's certificates.
    If you use mod_passenger and apache you can specify which cyphers it uses
    so that may help you if you need to restrict it to a particular set of
    cyphers.

    On 12 January 2013 02:23, GRANIER Bernard (MORPHO) wrote:

    Hi,

    For export control reasons, I am looking for an information.

    Puppet is using cryptography and certificates, is it with openssl only ?

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51


    #
    " This e-mail and any attached documents may contain confidential or
    proprietary information. If you are not the intended recipient, you are
    notified that any dissemination, copying of this e-mail and any attachments
    thereto or use of their contents by any means whatsoever is strictly
    prohibited. If you have received this e-mail in error, please advise the
    sender immediately and delete this e-mail and all attached documents from
    your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • GRANIER Bernard (MORPHO) at Jan 11, 2013 at 4:53 pm
    Hi,

    Is there an Eclipse plugin and a Maven plugin to develop and package Puppet modules ?

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51

    #
    " This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Luke Tislow at Jan 11, 2013 at 4:27 pm
    http://puppetlabs.com/blog/geppetto-a-puppet-ide/

    I'm not sure about maven.
    On Jan 11, 2013 11:25 AM, "GRANIER Bernard (MORPHO)" wrote:

    Hi,

    Is there an Eclipse plugin and a Maven plugin to develop and package
    Puppet modules ?

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51

    #
    " This e-mail and any attached documents may contain confidential or
    proprietary information. If you are not the intended recipient, you are
    notified that any dissemination, copying of this e-mail and any attachments
    thereto or use of their contents by any means whatsoever is strictly
    prohibited. If you have received this e-mail in error, please advise the
    sender immediately and delete this e-mail and all attached documents from
    your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • GRANIER Bernard (MORPHO) at Jan 11, 2013 at 4:29 pm
    Ok thanks for the answer.

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51

    From: puppet-users@googlegroups.com On Behalf Of Luke Tislow
    Sent: Friday, January 11, 2013 5:27 PM
    To: puppet-users@googlegroups.com
    Subject: Re: [Puppet Users] Eclipse plugin, Manifest and module


    http://puppetlabs.com/blog/geppetto-a-puppet-ide/

    I'm not sure about maven.
    On Jan 11, 2013 11:25 AM, "GRANIER Bernard (MORPHO)" wrote:
    Hi,

    Is there an Eclipse plugin and a Maven plugin to develop and package Puppet modules ?

    Cordialement,

    Bernard Granier
    CE Plateforme Système
    bernard.granier@morpho.com
    01 58 11 32 51

    #
    " This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com .
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com .
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com .
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com .
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    #
    " This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
    #

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • PuppetUser at Jan 16, 2013 at 7:21 am
    So give me any other solution to install cloud provisioner tool to open
    source windows puppet. Also give me info of connecting puppet to AWS. I
    surfed a lot on youtube dint get any info. Please help me out.

    Regards

    PuppetUser
    On Friday, January 11, 2013 9:39:41 PM UTC+5:30, Josh Cooper wrote:
    On Thu, Jan 10, 2013 at 10:34 PM, PuppetUser wrote:
    Hi

    I am trying to install cloud provisioner on windows puppet. I just used
    "puppet module install puppetlabs/cloudprovisioner". It gave the following
    error. Error: `puppet module` actions are currently not supported on
    Microsoft Windows.
    It is that we should work with cloudprovisioner tarball on windows puppet.
    Please help me out in working with the tarball


    Regards

    PuppetUser

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/l8r5BMr2CPUJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    We currently do not support running the module tool on windows due to
    its reliance on tar as a packing format. This will be fixed in a
    future release, see http://projects.puppetlabs.com/issues/11276.

    The workflow instead is to install the module on your master, and run
    `puppet agent` on the windows host, which will pluginsync the
    necessary files from the master to the agent host.

    The puppetlabs-registry module provides more details about how this
    process works on windows:
    https://forge.puppetlabs.com/puppetlabs/registry

    If instead you want to use `puppet apply`, then you can extract the
    tarball and point your modulepath at it as described here:
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/bdHRBhTuB2EJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Denmat at Jan 16, 2013 at 11:39 am
    Hi,

    I believe that this is supposed to be installed on the puppet master - and since you can't run puppet master on windows you are out of luck.

    Sorry,
    Den
    On 16/01/2013, at 11:21, PuppetUser wrote:

    So give me any other solution to install cloud provisioner tool to open source windows puppet. Also give me info of connecting puppet to AWS. I surfed a lot on youtube dint get any info. Please help me out.

    Regards

    PuppetUser
    On Friday, January 11, 2013 9:39:41 PM UTC+5:30, Josh Cooper wrote:
    On Thu, Jan 10, 2013 at 10:34 PM, PuppetUser wrote:
    Hi

    I am trying to install cloud provisioner on windows puppet. I just used
    "puppet module install puppetlabs/cloudprovisioner". It gave the following
    error. Error: `puppet module` actions are currently not supported on
    Microsoft Windows.
    It is that we should work with cloudprovisioner tarball on windows puppet.
    Please help me out in working with the tarball


    Regards

    PuppetUser

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/l8r5BMr2CPUJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    We currently do not support running the module tool on windows due to
    its reliance on tar as a packing format. This will be fixed in a
    future release, see http://projects.puppetlabs.com/issues/11276.

    The workflow instead is to install the module on your master, and run
    `puppet agent` on the windows host, which will pluginsync the
    necessary files from the master to the agent host.

    The puppetlabs-registry module provides more details about how this
    process works on windows:
    https://forge.puppetlabs.com/puppetlabs/registry

    If instead you want to use `puppet apply`, then you can extract the
    tarball and point your modulepath at it as described here:
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/bdHRBhTuB2EJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • PuppetUser at Jan 18, 2013 at 3:13 am
    Hi,

    I learnt that we can install master on linux machine with cloud provisioner
    installed and client to be run on windows. This way we can work out with
    cloud provisioner on windows. Can any one please give me details of the
    steps to be followed. Give me the link for the page where the details are
    mentioned.

    Thanks,

    PuppetUser
    On Wednesday, January 16, 2013 4:12:47 PM UTC+5:30, denmat wrote:

    Hi,

    I believe that this is supposed to be installed on the puppet master - and
    since you can't run puppet master on windows you are out of luck.

    Sorry,
    Den

    On 16/01/2013, at 11:21, PuppetUser <sriniva...@gmail.com <javascript:>>
    wrote:

    So give me any other solution to install cloud provisioner tool to open
    source windows puppet. Also give me info of connecting puppet to AWS. I
    surfed a lot on youtube dint get any info. Please help me out.

    Regards

    PuppetUser
    On Friday, January 11, 2013 9:39:41 PM UTC+5:30, Josh Cooper wrote:

    On Thu, Jan 10, 2013 at 10:34 PM, PuppetUser <sriniva...@gmail.com>
    wrote:
    Hi

    I am trying to install cloud provisioner on windows puppet. I just used
    "puppet module install puppetlabs/cloudprovisioner". It gave the following
    error. Error: `puppet module` actions are currently not supported on
    Microsoft Windows.
    It is that we should work with cloudprovisioner tarball on windows puppet.
    Please help me out in working with the tarball


    Regards

    PuppetUser

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/l8r5BMr2CPUJ.
    To post to this group, send email to puppet...@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    We currently do not support running the module tool on windows due to
    its reliance on tar as a packing format. This will be fixed in a
    future release, see http://projects.puppetlabs.com/issues/11276.

    The workflow instead is to install the module on your master, and run
    `puppet agent` on the windows host, which will pluginsync the
    necessary files from the master to the agent host.

    The puppetlabs-registry module provides more details about how this
    process works on windows:
    https://forge.puppetlabs.com/puppetlabs/registry

    If instead you want to use `puppet apply`, then you can extract the
    tarball and point your modulepath at it as described here:
    http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/bdHRBhTuB2EJ.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    puppet-users...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/bmOBN6vAebIJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 11, '13 at 11:58a
activeJan 18, '13 at 3:13a
posts10
users6
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase