FAQ
Hello,

when I run on my proxy server:

# puppet device --debug --deviceconf /etc/puppet/device/F5-lb-test.conf

I get this error:
info: starting applying configuration to F5-lb-test at
https://operating:operating4lbtest@F5-lb-test/Common
debug: Puppet::Device::F5: connecting to F5 device F5-lb-test.
debug: Puppet::Device::F5: connecting to partition Common.
*err: Can't load f5 for F5-lb-test: Connection refused - connect(2) (://:0)*

The credentials are ok. The F5 GUI uses a self-signed certificate. Could
that be a problem?? maybe I need first to locally intall the self-signed
certificate somewhere??

Any help will be really appreciated.

Thanks!

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/QJw6oU-Vm-cJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Gavin Williams at Jan 9, 2013 at 4:39 pm
    Hi there,

    I've done some work with the F5 network device support in our env, and
    haven't had any issues with self-signed certs...

    Sounds more likely that it's a network/firewall issue...
    Can you telnet from the puppet server to F5 on port 443?

    Cheers
    Gavin
    On Wednesday, 9 January 2013 16:28:43 UTC, MrTeleBird wrote:

    Hello,

    when I run on my proxy server:

    # puppet device --debug --deviceconf /etc/puppet/device/F5-lb-test.conf

    I get this error:
    info: starting applying configuration to F5-lb-test at
    https://operating:operating4lbtest@F5-lb-test/Common
    debug: Puppet::Device::F5: connecting to F5 device F5-lb-test.
    debug: Puppet::Device::F5: connecting to partition Common.
    *err: Can't load f5 for F5-lb-test: Connection refused - connect(2)
    (://:0)*

    The credentials are ok. The F5 GUI uses a self-signed certificate. Could
    that be a problem?? maybe I need first to locally intall the self-signed
    certificate somewhere??

    Any help will be really appreciated.

    Thanks!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/gl4VujrUqSAJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • MrTeleBird at Jan 10, 2013 at 9:06 am
    Hi Gavin!

    ok, yes that make sense. We do have a firewall in-between and I had only
    enable access to the BIG-IP from the proxy not from the pupept master. I
    will give it a try. Thanks a lot for the hint!

    Cheers,
    Cesar
    On Wednesday, January 9, 2013 5:39:44 PM UTC+1, Gavin Williams wrote:

    Hi there,

    I've done some work with the F5 network device support in our env, and
    haven't had any issues with self-signed certs...

    Sounds more likely that it's a network/firewall issue...
    Can you telnet from the puppet server to F5 on port 443?

    Cheers
    Gavin
    On Wednesday, 9 January 2013 16:28:43 UTC, MrTeleBird wrote:

    Hello,

    when I run on my proxy server:

    # puppet device --debug --deviceconf /etc/puppet/device/F5-lb-test.conf

    I get this error:
    info: starting applying configuration to F5-lb-test at
    https://operating:operating4lbtest@F5-lb-test/Common
    debug: Puppet::Device::F5: connecting to F5 device F5-lb-test.
    debug: Puppet::Device::F5: connecting to partition Common.
    *err: Can't load f5 for F5-lb-test: Connection refused - connect(2)
    (://:0)*

    The credentials are ok. The F5 GUI uses a self-signed certificate. Could
    that be a problem?? maybe I need first to locally intall the self-signed
    certificate somewhere??

    Any help will be really appreciated.

    Thanks!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/b7IX1XTL7dYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • MrTeleBird at Jan 10, 2013 at 9:46 am
    No, still not workinig :-(, same error as before. I verified the logs on
    the firewall and there is no more traffic blocked from puppet master and
    from the proxy. Additionally, I can telnet my F5 on port 443 without any
    problem from both servers.

    Any other idea what could be the causing this problem??

    Thanks
    On Thursday, January 10, 2013 10:06:25 AM UTC+1, MrTeleBird wrote:

    Hi Gavin!

    ok, yes that make sense. We do have a firewall in-between and I had only
    enable access to the BIG-IP from the proxy not from the pupept master. I
    will give it a try. Thanks a lot for the hint!

    Cheers,
    Cesar
    On Wednesday, January 9, 2013 5:39:44 PM UTC+1, Gavin Williams wrote:

    Hi there,

    I've done some work with the F5 network device support in our env, and
    haven't had any issues with self-signed certs...

    Sounds more likely that it's a network/firewall issue...
    Can you telnet from the puppet server to F5 on port 443?

    Cheers
    Gavin
    On Wednesday, 9 January 2013 16:28:43 UTC, MrTeleBird wrote:

    Hello,

    when I run on my proxy server:

    # puppet device --debug --deviceconf /etc/puppet/device/F5-lb-test.conf

    I get this error:
    info: starting applying configuration to F5-lb-test at
    https://operating:operating4lbtest@F5-lb-test/Common
    debug: Puppet::Device::F5: connecting to F5 device F5-lb-test.
    debug: Puppet::Device::F5: connecting to partition Common.
    *err: Can't load f5 for F5-lb-test: Connection refused - connect(2)
    (://:0)*

    The credentials are ok. The F5 GUI uses a self-signed certificate. Could
    that be a problem?? maybe I need first to locally intall the self-signed
    certificate somewhere??

    Any help will be really appreciated.

    Thanks!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Ti45S8c4FJcJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 9, '13 at 4:28p
activeJan 10, '13 at 9:46a
posts4
users2
websitepuppetlabs.com

2 users in discussion

MrTeleBird: 3 posts Gavin Williams: 1 post

People

Translate

site design / logo © 2022 Grokbase