FAQ
Hi everyone,

I recently ran into an issue where my puppetmaster can't run puppet on
itself. It errors out with the following:
Error: Could not retrieve catalog from remote server: execution expired
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

I'm running Puppet 3 with passanger and puppetdb (hsql). I've tried
restarting puppetdb and apache to no effect. If I wipe out puppetdb, it'll
work again until all 17 servers are back into the catalog and it times out
from then on. The puppet master is also my nagios node so it does have a
huge amount of resources to assemble.

Can I configure puppet to wait longer for the catalog generation step? I've
search the docs without anything standing out to me.

Thanks,
~Rob

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/GeJ_iqjePasJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Joshua Buss at Jan 17, 2013 at 12:19 am
    Wow, I just found this by googling for the error message and I'm getting
    the exact same problem.. unable to run puppet agent on the same machine
    where I have the puppet master running.. times out on loading plugin. I'm
    running on ubuntu server 11.10, version 2.7.1-1ubuntu3.7
    On Monday, January 7, 2013 1:19:41 PM UTC-6, Rob Smith wrote:

    Hi everyone,

    I recently ran into an issue where my puppetmaster can't run puppet on
    itself. It errors out with the following:
    Error: Could not retrieve catalog from remote server: execution expired
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog; skipping run

    I'm running Puppet 3 with passanger and puppetdb (hsql). I've tried
    restarting puppetdb and apache to no effect. If I wipe out puppetdb, it'll
    work again until all 17 servers are back into the catalog and it times out
    from then on. The puppet master is also my nagios node so it does have a
    huge amount of resources to assemble.

    Can I configure puppet to wait longer for the catalog generation step?
    I've search the docs without anything standing out to me.

    Thanks,
    ~Rob
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/om1VqCu2HbgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Luke Bigum at Jan 17, 2013 at 9:02 am
    I'm not sure if there's a way to increase the timeout for exported resource
    reconstruction, however rather than doing a Puppet resource collection you
    can query the raw data from PuppetDB:

    https://github.com/dalen/puppet-puppetdbquery

    Here is an example a colleague of mine used to vastly speed up the catalog
    of our Nagios server. Here it queries exported 'hostgroup_member' resources
    with a specific tag, then uses the returned hash of data in a template to
    define all Nagios hostgroups:

    $hostgroup_members = pdbresourcequery(
    [ 'and',
    [ '=', 'tag', $nagios::params::sites ],
    [ '=', 'type', 'Nagios::Config::Hostgroup_member' ],
    [ '=', 'exported', true ]
    ]
    )
    file { $nagios::params::hostgroups_yaml:
    content => template('nagios/nagios_hostgroups.yaml.erb'),
    notify => Class['nagios::service'],
    }

    This cut our catalog down from over 2 minutes in compile/collect time to
    around 20-30 seconds.

    Hope that helps,

    -Luke
    On Wednesday, January 16, 2013 11:35:23 PM UTC, Joshua Buss wrote:

    Wow, I just found this by googling for the error message and I'm getting
    the exact same problem.. unable to run puppet agent on the same machine
    where I have the puppet master running.. times out on loading plugin. I'm
    running on ubuntu server 11.10, version 2.7.1-1ubuntu3.7
    On Monday, January 7, 2013 1:19:41 PM UTC-6, Rob Smith wrote:

    Hi everyone,

    I recently ran into an issue where my puppetmaster can't run puppet on
    itself. It errors out with the following:
    Error: Could not retrieve catalog from remote server: execution expired
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog; skipping run

    I'm running Puppet 3 with passanger and puppetdb (hsql). I've tried
    restarting puppetdb and apache to no effect. If I wipe out puppetdb, it'll
    work again until all 17 servers are back into the catalog and it times out
    from then on. The puppet master is also my nagios node so it does have a
    huge amount of resources to assemble.

    Can I configure puppet to wait longer for the catalog generation step?
    I've search the docs without anything standing out to me.

    Thanks,
    ~Rob
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ffFFsG4HM0YJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Shell heriyanto at Feb 20, 2013 at 3:36 am
    Hi i also have this problem when working with nagios, always expire... is
    that any solution for this, from puppet configuration byself? my nagios
    production server can't working anymore. Even i already use puppetDB. I see
    many people have same problem on the net.

    Thanks,
    ~Heriyanto

    On Thu, Jan 17, 2013 at 4:02 PM, Luke Bigum wrote:

    I'm not sure if there's a way to increase the timeout for exported
    resource reconstruction, however rather than doing a Puppet resource
    collection you can query the raw data from PuppetDB:

    https://github.com/dalen/puppet-puppetdbquery

    Here is an example a colleague of mine used to vastly speed up the catalog
    of our Nagios server. Here it queries exported 'hostgroup_member' resources
    with a specific tag, then uses the returned hash of data in a template to
    define all Nagios hostgroups:

    $hostgroup_members = pdbresourcequery(
    [ 'and',
    [ '=', 'tag', $nagios::params::sites ],
    [ '=', 'type', 'Nagios::Config::Hostgroup_member' ],
    [ '=', 'exported', true ]
    ]
    )
    file { $nagios::params::hostgroups_yaml:
    content => template('nagios/nagios_hostgroups.yaml.erb'),
    notify => Class['nagios::service'],
    }

    This cut our catalog down from over 2 minutes in compile/collect time to
    around 20-30 seconds.

    Hope that helps,

    -Luke
    On Wednesday, January 16, 2013 11:35:23 PM UTC, Joshua Buss wrote:

    Wow, I just found this by googling for the error message and I'm getting
    the exact same problem.. unable to run puppet agent on the same machine
    where I have the puppet master running.. times out on loading plugin. I'm
    running on ubuntu server 11.10, version 2.7.1-1ubuntu3.7
    On Monday, January 7, 2013 1:19:41 PM UTC-6, Rob Smith wrote:

    Hi everyone,

    I recently ran into an issue where my puppetmaster can't run puppet on
    itself. It errors out with the following:
    Error: Could not retrieve catalog from remote server: execution expired
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog; skipping run

    I'm running Puppet 3 with passanger and puppetdb (hsql). I've tried
    restarting puppetdb and apache to no effect. If I wipe out puppetdb, it'll
    work again until all 17 servers are back into the catalog and it times out
    from then on. The puppet master is also my nagios node so it does have a
    huge amount of resources to assemble.

    Can I configure puppet to wait longer for the catalog generation step?
    I've search the docs without anything standing out to me.

    Thanks,
    ~Rob
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/ffFFsG4HM0YJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 7, '13 at 7:26p
activeFeb 20, '13 at 3:36a
posts4
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase