FAQ
I am trying to write a manifest that does not create the home directory for
the user as it will be on a NAS volume. It seems that RHEL/Oracle requires
your explicitly to use the "-M" options. Is there a way to do this with
puppet?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/F3gtVEOcfZ8J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • 刘长元 at Dec 29, 2012 at 5:58 am
    user resource use managehome attribute to decide if need to create home
    directory.
    and it's default value is false, just try, you can check the results.

    On Saturday, December 29, 2012 4:38:07 AM UTC+8, mi...@mikerochford.com
    wrote:
    I am trying to write a manifest that does not create the home directory
    for the user as it will be on a NAS volume. It seems that RHEL/Oracle
    requires your explicitly to use the "-M" options. Is there a way to do this
    with puppet?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/i2GlFN8ruf0J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • John Guthrie at Dec 29, 2012 at 4:25 am
    Also make certain that your shadow-utils package is up to date. Older package version had an issue where they didn't allow puppet to handle non-local user names very well. If your home directories are on a NAS, then I suspect that you might be running into a similar issue as well. I found that updating shadow-utils seemed to fix the issue.

    John Guthrie
    jguthrie@book.com
    ________________________________________
    From: puppet-users@googlegroups.com [puppet-users@googlegroups.com] on behalf of 刘长元 [liucy1983@gmail.com]
    Sent: Friday, December 28, 2012 10:02 PM
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Re: RHEL/Oracle Linux - user creation.

    user resource use managehome attribute to decide if need to create home directory.
    and it's default value is false, just try, you can check the results.

    On Saturday, December 29, 2012 4:38:07 AM UTC+8, mi...@mikerochford.com wrote:
    I am trying to write a manifest that does not create the home directory for the user as it will be on a NAS volume. It seems that RHEL/Oracle requires your explicitly to use the "-M" options. Is there a way to do this with puppet?

    This electronic mail message contains information that (a) is or
    may be CONFIDENTIAL, PROPRIETARY IN NATURE, OR OTHERWISE
    PROTECTED
    BY LAW FROM DISCLOSURE, and (b) is intended only for the use of
    the addressee(s) named herein. If you are not an intended
    recipient, please contact the sender immediately and take the
    steps necessary to delete the message completely from your
    computer system.

    Not Intended as a Substitute for a Writing: Notwithstanding the
    Uniform Electronic Transaction Act or any other law of similar
    effect, absent an express statement to the contrary, this e-mail
    message, its contents, and any attachments hereto are not
    intended
    to represent an offer or acceptance to enter into a contract and
    are not otherwise intended to bind this sender,
    barnesandnoble.com
    llc, barnesandnoble.com inc. or any other person or entity.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Mike Rochford at Dec 31, 2012 at 2:47 am
    It looks like I need to file a bug report as Oracle change the name of
    their linux distribution.

    <snippet /usr/lib/ruby/site_ruby/1.8/puppet/provider/user/useradd.rb t>
    def check_manage_home
    cmd = []
    if @resource.managehome?
    cmd << "-m"
    elsif %w{Fedora RedHat CentOS OEL
    OVS}.include?(Facter.value(:operatingsystem))
    cmd << "-M"
    end
    cmd
    end
    </snippet>

    <facter output>
    ol6-3:~ # facter operatingsystem
    OracleLinux
    ol6-3:~ #
    </facter output>

    -Mike
    On Fri, Dec 28, 2012 at 9:58 PM, John Guthrie wrote:
    Also make certain that your shadow-utils package is up to date. Older package version had an issue where they didn't allow puppet to handle non-local user names very well. If your home directories are on a NAS, then I suspect that you might be running into a similar issue as well. I found that updating shadow-utils seemed to fix the issue.

    John Guthrie
    jguthrie@book.com
    ________________________________________
    From: puppet-users@googlegroups.com [puppet-users@googlegroups.com] on behalf of 刘长元 [liucy1983@gmail.com]
    Sent: Friday, December 28, 2012 10:02 PM
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Re: RHEL/Oracle Linux - user creation.

    user resource use managehome attribute to decide if need to create home directory.
    and it's default value is false, just try, you can check the results.

    On Saturday, December 29, 2012 4:38:07 AM UTC+8, mi...@mikerochford.com wrote:
    I am trying to write a manifest that does not create the home directory for the user as it will be on a NAS volume. It seems that RHEL/Oracle requires your explicitly to use the "-M" options. Is there a way to do this with puppet?

    This electronic mail message contains information that (a) is or
    may be CONFIDENTIAL, PROPRIETARY IN NATURE, OR OTHERWISE
    PROTECTED
    BY LAW FROM DISCLOSURE, and (b) is intended only for the use of
    the addressee(s) named herein. If you are not an intended
    recipient, please contact the sender immediately and take the
    steps necessary to delete the message completely from your
    computer system.

    Not Intended as a Substitute for a Writing: Notwithstanding the
    Uniform Electronic Transaction Act or any other law of similar
    effect, absent an express statement to the contrary, this e-mail
    message, its contents, and any attachments hereto are not
    intended
    to represent an offer or acceptance to enter into a contract and
    are not otherwise intended to bind this sender,
    barnesandnoble.com
    llc, barnesandnoble.com inc. or any other person or entity.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Garrett Honeycutt at Jan 2, 2013 at 8:53 pm

    On 12/30/12 9:47 PM, Mike Rochford wrote:
    It looks like I need to file a bug report as Oracle change the name of
    their linux distribution.

    <snippet /usr/lib/ruby/site_ruby/1.8/puppet/provider/user/useradd.rb t>
    def check_manage_home
    cmd = []
    if @resource.managehome?
    cmd << "-m"
    elsif %w{Fedora RedHat CentOS OEL
    OVS}.include?(Facter.value(:operatingsystem))
    cmd << "-M"
    end
    cmd
    end
    </snippet>

    <facter output>
    ol6-3:~ # facter operatingsystem
    OracleLinux
    ol6-3:~ #
    </facter output>

    -Mike
    On Fri, Dec 28, 2012 at 9:58 PM, John Guthrie wrote:
    Also make certain that your shadow-utils package is up to date. Older package version had an issue where they didn't allow puppet to handle non-local user names very well. If your home directories are on a NAS, then I suspect that you might be running into a similar issue as well. I found that updating shadow-utils seemed to fix the issue.

    John Guthrie
    jguthrie@book.com
    ________________________________________
    From: puppet-users@googlegroups.com [puppet-users@googlegroups.com] on behalf of 刘长元 [liucy1983@gmail.com]
    Sent: Friday, December 28, 2012 10:02 PM
    To: puppet-users@googlegroups.com
    Subject: [Puppet Users] Re: RHEL/Oracle Linux - user creation.

    user resource use managehome attribute to decide if need to create home directory.
    and it's default value is false, just try, you can check the results.

    On Saturday, December 29, 2012 4:38:07 AM UTC+8, mi...@mikerochford.com wrote:
    I am trying to write a manifest that does not create the home directory for the user as it will be on a NAS volume. It seems that RHEL/Oracle requires your explicitly to use the "-M" options. Is there a way to do this with puppet?
    Thanks for bringing this up. We were able to get this fixed and merged
    in master for release in 3.1.0. You could back port by checking out the
    small changes from the commit[1].

    [1] - https://github.com/puppetlabs/puppet/pull/1359/files

    -g

    --
    Garrett Honeycutt

    206.414.8658
    http://puppetlabs.com

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 28, '12 at 11:33p
activeJan 2, '13 at 8:53p
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase