FAQ
Hi,

I installed Open source puppet 3.0 .1in Windows machine and puppet master
3.0.1 in red hat linux machine. I did all the necessary configurations.
C:\Documents and Settings\All Users\Application
Data\PuppetLabs\puppet\etc\puppet.conf- > server = test.posmaster.internal
Added entry in hosts file.

While execute ping command ping (ping test.posmaster.internal) giving
response.
But while executing "puppet agent --server test.posmaster.internal --debug"
I am getting below error

*Info: Retrieving plugin*
*Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
Could*
* not find default node or by name with
'testposagentoneinternal.ec2.internal, te*
*stposagentoneinternal.ec2, testposagentoneinternal' on node
testposagentoneinter*
*nal.ec2.internal*
*Warning: Not using cache on failed catalog*
*Error: Could not retrieve catalog; skipping run*
*
*
Please help me to solve this.

With Regards,
Krishna Bhaskar.
*
*
*
*

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/31uDPx-NhuIJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Jcbollinger at Dec 19, 2012 at 2:07 pm

    On Wednesday, December 19, 2012 5:47:50 AM UTC-6, krishna bhaskara rao wrote:

    Hi,

    I installed Open source puppet 3.0 .1in Windows machine and puppet master
    3.0.1 in red hat linux machine. I did all the necessary configurations.
    C:\Documents and Settings\All Users\Application
    Data\PuppetLabs\puppet\etc\puppet.conf- > server = test.posmaster.internal
    Added entry in hosts file.

    While execute ping command ping (ping test.posmaster.internal) giving
    response.
    But while executing "puppet agent --server test.posmaster.internal
    --debug" I am getting below error

    *Info: Retrieving plugin*
    *Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Could*
    * not find default node or by name with
    'testposagentoneinternal.ec2.internal, te*
    *stposagentoneinternal.ec2, testposagentoneinternal' on node
    testposagentoneinter*
    *nal.ec2.internal*
    *Warning: Not using cache on failed catalog*
    *Error: Could not retrieve catalog; skipping run*
    *
    *
    Please help me to solve this.
    Puppet is telling you that it cannot match the client to any node it knows
    about, and you have not declared default node configuration for it to fall
    back on. Consult the Puppet language docs for full details
    (http://docs.puppetlabs.com/puppet/3/reference/lang_node_definitions.html),
    but the quickest, simplest (but most temporary) solution is to add this to
    your site.pp:

    node default {
    }

    Note that although that should silence the error message, it does not
    declare any classes or resources to apply to your nodes. Do digest the
    node (and other) documentation to understand how to go on from there.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ZNlPJZoYSAgJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Krishna bhaskara rao at Dec 19, 2012 at 5:23 pm
    Hi John,

    Thank you for your response.

    But why should I create site.pp in agent node(Windows). As my
    understanding, site.pp should be in puppet master server it self and it
    will execute the catalog in agent node.

    Can you give me clarification on this If my understanding is wrong?.
    Same scenario working in linux(puppet master) to linux(puppet agent). There
    I didnt create any site.pp in agent node.


    With Regards,
    Krishna Bhaskar.
    On Wednesday, 19 December 2012 19:37:27 UTC+5:30, jcbollinger wrote:



    On Wednesday, December 19, 2012 5:47:50 AM UTC-6, krishna bhaskara rao
    wrote:
    Hi,

    I installed Open source puppet 3.0 .1in Windows machine and puppet master
    3.0.1 in red hat linux machine. I did all the necessary configurations.
    C:\Documents and Settings\All Users\Application
    Data\PuppetLabs\puppet\etc\puppet.conf- > server = test.posmaster.internal
    Added entry in hosts file.

    While execute ping command ping (ping test.posmaster.internal) giving
    response.
    But while executing "puppet agent --server test.posmaster.internal
    --debug" I am getting below error

    *Info: Retrieving plugin*
    *Error: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Could*
    * not find default node or by name with
    'testposagentoneinternal.ec2.internal, te*
    *stposagentoneinternal.ec2, testposagentoneinternal' on node
    testposagentoneinter*
    *nal.ec2.internal*
    *Warning: Not using cache on failed catalog*
    *Error: Could not retrieve catalog; skipping run*
    *
    *
    Please help me to solve this.
    Puppet is telling you that it cannot match the client to any node it knows
    about, and you have not declared default node configuration for it to fall
    back on. Consult the Puppet language docs for full details (
    http://docs.puppetlabs.com/puppet/3/reference/lang_node_definitions.html),
    but the quickest, simplest (but most temporary) solution is to add this to
    your site.pp:

    node default {
    }

    Note that although that should silence the error message, it does not
    declare any classes or resources to apply to your nodes. Do digest the
    node (and other) documentation to understand how to go on from there.


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/VQR482wdzCMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Matthew Burgess at Dec 19, 2012 at 8:20 pm

    On Wed, Dec 19, 2012 at 5:23 PM, krishna bhaskara rao wrote:
    Hi John,

    Thank you for your response.

    But why should I create site.pp in agent node(Windows). As my understanding,
    site.pp should be in puppet master server it self and it will execute the
    catalog in agent node.

    Can you give me clarification on this If my understanding is wrong?.
    Same scenario working in linux(puppet master) to linux(puppet agent). There
    I didnt create any site.pp in agent node.
    Your understanding (of Puppet) is correct, the site.pp should reside
    on the puppet master.

    I can't see where John suggested you create a site.pp on the agent though.

    What does your site.pp on the puppet master look like?

    Regards,

    Matt.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Krishna bhaskara rao at Dec 20, 2012 at 9:36 am
    Hi Matt,

    While executing the command "*puppet agent --server test.puppetmaster.com
    --debug*" in puppet agent on Windows I am getting mentioned exception.
    As per my understanding, While executing said command, agent will send a
    request to pupet master for certificate sign off, it's not happening. That
    is the issue I am facing.

    With Regards,
    Krishna Bhaskar.
    On Thursday, 20 December 2012 01:50:14 UTC+5:30, Matthew Burgess wrote:

    On Wed, Dec 19, 2012 at 5:23 PM, krishna bhaskara rao
    <krish...@gmail.com <javascript:>> wrote:
    Hi John,

    Thank you for your response.

    But why should I create site.pp in agent node(Windows). As my
    understanding,
    site.pp should be in puppet master server it self and it will execute the
    catalog in agent node.

    Can you give me clarification on this If my understanding is wrong?.
    Same scenario working in linux(puppet master) to linux(puppet agent). There
    I didnt create any site.pp in agent node.
    Your understanding (of Puppet) is correct, the site.pp should reside
    on the puppet master.

    I can't see where John suggested you create a site.pp on the agent though.

    What does your site.pp on the puppet master look like?

    Regards,

    Matt.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/BDdzUiyYKqYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Matthew Burgess at Dec 20, 2012 at 10:43 am

    On Thu, Dec 20, 2012 at 9:36 AM, krishna bhaskara rao wrote:
    Hi Matt,

    While executing the command "puppet agent --server test.puppetmaster.com
    --debug" in puppet agent on Windows I am getting mentioned exception.
    I generally dislike specifying the server on the command line. What
    does the following command give you, when run on the agent?

    puppet agent --test

    Do you have a 'server =' line in your agent's puppet.conf file? This
    isn't strictly necessary if 'agent.your-domain.com' can successfully
    resolve a DNS query for 'puppet'. As you're on Windows, running
    'nslookup puppet' is enough to test this. Or, confirm that your hosts
    file contains a suitable entry for 'puppet'.

    Regards,

    Matt.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Krishna bhaskara rao at Dec 20, 2012 at 12:17 pm
    Hi Matt,

    I have configured hostname of the master in hosts file as below in windows
    agent.
    10.248.113.198 test.master.internal puppetmaster
    and added an entry "server=test.master.internal" in agent in windows
    puppet.conf.

    If I execute command *puppet agent --test,* I am getting same error like
    below

    *Info: Retrieving plugin*
    *Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Could*
    * not find default node or by name with 'testagentoneinternal.ec2.internal,
    te*
    *stagentoneinternal.ec2, testagentoneinternal' on node testagentoneinter*
    *nal.ec2.internal*
    *Warning: Not using cache on failed catalog*
    *Error: Could not retrieve catalog; skipping run*
    *
    *
    I am not getting any solution to resolve it.

    With Regards,
    Krishna Bhaskar.

    On Thursday, 20 December 2012 16:13:06 UTC+5:30, Matthew Burgess wrote:

    On Thu, Dec 20, 2012 at 9:36 AM, krishna bhaskara rao
    <krish...@gmail.com <javascript:>> wrote:
    Hi Matt,

    While executing the command "puppet agent --server test.puppetmaster.com
    --debug" in puppet agent on Windows I am getting mentioned exception.
    I generally dislike specifying the server on the command line. What
    does the following command give you, when run on the agent?

    puppet agent --test

    Do you have a 'server =' line in your agent's puppet.conf file? This
    isn't strictly necessary if 'agent.your-domain.com' can successfully
    resolve a DNS query for 'puppet'. As you're on Windows, running
    'nslookup puppet' is enough to test this. Or, confirm that your hosts
    file contains a suitable entry for 'puppet'.

    Regards,

    Matt.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/PXtizbqnrDYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Matthew Burgess at Dec 20, 2012 at 12:26 pm

    On Thu, Dec 20, 2012 at 12:17 PM, krishna bhaskara rao wrote:
    Hi Matt,

    I have configured hostname of the master in hosts file as below in windows
    agent.
    10.248.113.198 test.master.internal puppetmaster
    and added an entry "server=test.master.internal" in agent in windows
    puppet.conf.
    So, what's in your /etc/puppet/manifests/site.pp on the master then?

    At the minimum, it should have:

    node default {
    }

    Thanks,

    Matt.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jcbollinger at Dec 20, 2012 at 2:06 pm

    On Thursday, December 20, 2012 6:26:07 AM UTC-6, Matthew Burgess wrote:

    So, what's in your /etc/puppet/manifests/site.pp on the master then?

    At the minimum, it should have:

    node default {
    }
    Now where did I see that before? :-)


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ebyZQxn082UJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Matthew Burgess at Dec 20, 2012 at 2:23 pm

    On Thu, Dec 20, 2012 at 2:06 PM, jcbollinger wrote:

    Now where did I see that before? :-)
    Ha, I thought you'd mentioned it before, but gmail's stupid interface
    (I always blame my tools!) meant I skimmed straight past it when I was
    double-checking) :-)

    Cheers,

    Matt.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Krishna bhaskara rao at Dec 20, 2012 at 4:47 pm
    Hi John,

    I have nodes.pp as
    node basenode {
    }
    node 'test.master.com' inherits basenode { }

    site.pp as
    import 'nodes'
    node 'test.agent.com' {
    }



    With Regards,
    Krishna Bhaskar.'
    On Thursday, 20 December 2012 19:36:36 UTC+5:30, jcbollinger wrote:


    On Thursday, December 20, 2012 6:26:07 AM UTC-6, Matthew Burgess wrote:


    So, what's in your /etc/puppet/manifests/site.pp on the master then?

    At the minimum, it should have:

    node default {
    }
    Now where did I see that before? :-)


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/NYbWYppES-cJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Krishna bhaskara rao at Dec 20, 2012 at 4:48 pm
    Hi Matt,

    I have nodes.pp as
    node basenode {
    }
    node 'test.master.com' inherits basenode { }

    site.pp as
    import 'nodes'
    node 'test.agent.com' {
    }


    With Regards,
    Krishna Bhaskar.'
    On Thursday, 20 December 2012 17:56:07 UTC+5:30, Matthew Burgess wrote:

    On Thu, Dec 20, 2012 at 12:17 PM, krishna bhaskara rao
    <krish...@gmail.com <javascript:>> wrote:
    Hi Matt,

    I have configured hostname of the master in hosts file as below in windows
    agent.
    10.248.113.198 test.master.internal
    puppetmaster
    and added an entry "server=test.master.internal" in agent in windows
    puppet.conf.
    So, what's in your /etc/puppet/manifests/site.pp on the master then?

    At the minimum, it should have:

    node default {
    }

    Thanks,

    Matt.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/Y3XAbkVweXYJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Matthew Burgess at Dec 20, 2012 at 4:59 pm

    On Thu, Dec 20, 2012 at 4:48 PM, krishna bhaskara rao wrote:
    Hi Matt,

    I have nodes.pp as
    node basenode {
    }
    node 'test.master.com' inherits basenode { }

    site.pp as
    import 'nodes'
    node 'test.agent.com' {
    }
    Have you just obfuscated those due to posting on a mailing list? Your
    original error message stated that a node definition for
    testagentoneinternal.ec2.internal couldn't be found, and neither could
    a default node definition.

    As you're using nodes.pp and site.pp, your nodes.pp needs:

    node default {
    }

    it could also have (either in addition, or instead of the above
    default node definition):

    node 'testagentoneinternal.ec2.internal' {
    }

    And your site.pp just needs the 'import "nodes"' line that it looks
    like it does already; to avoid confusion, I'd remove the explicit node
    definition from site.pp.

    Regards,

    Matt.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 19, '12 at 11:47a
activeDec 20, '12 at 4:59p
posts13
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase