FAQ
On a fresh Dashboard installation I get these:
Puppet Dashboard encountered an error.

Something went wrong, and Puppet Dashboard was unable to render the
requested page. Please contact your site’s help desk or systems
administrator; if that happens to be you, please check Dashboard’s logs for
more information.


Processing ReportsController#search (for 93.38.53.173 at 2012-12-13
23:55:51) [GET]
Parameters: {"controller"=>"reports", "action"=>"search"}
Rendering template within layouts/application
Rendering reports/search

ActionView::TemplateError (undefined local variable or method `errors' for
#<ActionView::Base:0x7fc3aef36848>) on line #9 of
app/views/reports/search.html.haml:
6: Search Latest Inspect Reports
7:
8: .item
9: - if errors.present?
10: %div{:class => "section error"}
11: %h3 Errors
12: - errors.each do |messages|

app/views/reports/search.html.haml:9:in
`_run_haml_app47views47reports47search46html46haml'
haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
`render'
haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
`render'
sass (3.1.2) [v] rails/./lib/sass/plugin/rack.rb:54:in `call'
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

Rendering /usr/share/puppet-dashboard/public/500.html (500 Internal Server
Error)


Any idea on what could be the problem?

Thanks

Luca

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/u9bg24moPsMJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Ivan Arsenault at Dec 14, 2012 at 7:05 pm
    Change ./app/views/reports/search.html.haml like this :

    .item
    - if flash[:errors].present?
    %div{:class => "section error"}
    %h3 Errors
    - flash[:errors].each do |messages|
    %p
    - messages.each do |message|
    %li= h message


    Voilà

    Ivan




    Le jeudi 13 décembre 2012 18:19:44 UTC-5, Luca Gioppo a écrit :
    On a fresh Dashboard installation I get these:
    Puppet Dashboard encountered an error.

    Something went wrong, and Puppet Dashboard was unable to render the
    requested page. Please contact your site’s help desk or systems
    administrator; if that happens to be you, please check Dashboard’s logs for
    more information.


    Processing ReportsController#search (for 93.38.53.173 at 2012-12-13
    23:55:51) [GET]
    Parameters: {"controller"=>"reports", "action"=>"search"}
    Rendering template within layouts/application
    Rendering reports/search

    ActionView::TemplateError (undefined local variable or method `errors' for
    #<ActionView::Base:0x7fc3aef36848>) on line #9 of
    app/views/reports/search.html.haml:
    6: Search Latest Inspect Reports
    7:
    8: .item
    9: - if errors.present?
    10: %div{:class => "section error"}
    11: %h3 Errors
    12: - errors.each do |messages|

    app/views/reports/search.html.haml:9:in
    `_run_haml_app47views47reports47search46html46haml'
    haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
    `render'
    haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
    `render'
    sass (3.1.2) [v] rails/./lib/sass/plugin/rack.rb:54:in `call'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

    Rendering /usr/share/puppet-dashboard/public/500.html (500 Internal Server
    Error)


    Any idea on what could be the problem?

    Thanks

    Luca
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/pm0CwOWeacoJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Aaron Stone at Dec 17, 2012 at 11:24 pm
    Please try this PR:
    https://github.com/puppetlabs/puppet-dashboard/pull/150

    On Fri, Dec 14, 2012 at 11:03 AM, wrote:


    Change ./app/views/reports/search.html.haml like this :

    .item
    - if flash[:errors].present?

    %div{:class => "section error"}
    %h3 Errors
    - flash[:errors].each do |messages|
    %p
    - messages.each do |message|
    %li= h message


    Voilà

    Ivan




    Le jeudi 13 décembre 2012 18:19:44 UTC-5, Luca Gioppo a écrit :
    On a fresh Dashboard installation I get these:
    Puppet Dashboard encountered an error.

    Something went wrong, and Puppet Dashboard was unable to render the
    requested page. Please contact your site’s help desk or systems
    administrator; if that happens to be you, please check Dashboard’s logs for
    more information.


    Processing ReportsController#search (for 93.38.53.173 at 2012-12-13
    23:55:51) [GET]
    Parameters: {"controller"=>"reports", "action"=>"search"}
    Rendering template within layouts/application
    Rendering reports/search

    ActionView::TemplateError (undefined local variable or method `errors'
    for #<ActionView::Base:**0x7fc3aef36848>) on line #9 of
    app/views/reports/search.html.**haml:
    6: Search Latest Inspect Reports
    7:
    8: .item
    9: - if errors.present?
    10: %div{:class => "section error"}
    11: %h3 Errors
    12: - errors.each do |messages|

    app/views/reports/search.html.**haml:9:in `_run_haml_**
    app47views47reports47search46h**tml46haml'
    haml (3.1.2) [v] rails/./lib/haml/helpers/**action_view_mods.rb:13:in
    `render'
    haml (3.1.2) [v] rails/./lib/haml/helpers/**action_view_mods.rb:13:in
    `render'
    sass (3.1.2) [v] rails/./lib/sass/plugin/rack.**rb:54:in `call'
    /usr/lib/ruby/1.8/webrick/**httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/**httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/webrick/**server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/**server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/**server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/**server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/**server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/**server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/**server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/**server.rb:82:in `start'

    Rendering /usr/share/puppet-dashboard/**public/500.html (500 Internal
    Server Error)


    Any idea on what could be the problem?

    Thanks

    Luca

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/pm0CwOWeacoJ.

    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Aaron Stone at Dec 29, 2012 at 6:15 pm
    For closure on the thread, this is now fixed in Dashboard 1.2.16.

    On Thu, Dec 13, 2012 at 3:19 PM, Luca Gioppo wrote:

    On a fresh Dashboard installation I get these:
    Puppet Dashboard encountered an error.

    Something went wrong, and Puppet Dashboard was unable to render the
    requested page. Please contact your site’s help desk or systems
    administrator; if that happens to be you, please check Dashboard’s logs for
    more information.


    Processing ReportsController#search (for 93.38.53.173 at 2012-12-13
    23:55:51) [GET]
    Parameters: {"controller"=>"reports", "action"=>"search"}
    Rendering template within layouts/application
    Rendering reports/search

    ActionView::TemplateError (undefined local variable or method `errors' for
    #<ActionView::Base:0x7fc3aef36848>) on line #9 of
    app/views/reports/search.html.haml:
    6: Search Latest Inspect Reports
    7:
    8: .item
    9: - if errors.present?
    10: %div{:class => "section error"}
    11: %h3 Errors
    12: - errors.each do |messages|

    app/views/reports/search.html.haml:9:in
    `_run_haml_app47views47reports47search46html46haml'
    haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
    `render'
    haml (3.1.2) [v] rails/./lib/haml/helpers/action_view_mods.rb:13:in
    `render'
    sass (3.1.2) [v] rails/./lib/sass/plugin/rack.rb:54:in `call'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'

    Rendering /usr/share/puppet-dashboard/public/500.html (500 Internal Server
    Error)


    Any idea on what could be the problem?

    Thanks

    Luca

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/puppet-users/-/u9bg24moPsMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 13, '12 at 11:27p
activeDec 29, '12 at 6:15p
posts4
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase