FAQ
Hi, i spent all day trying to work the vcsrepo module, without success. Im
doing my own class like this:

class rta-frontend {



vcsrepo { "/var/www/home":



ensure => present,



provider => git,



source => "git@home.org:home.git",


require => [ File["/root/.ssh/id_rsa.pub"], Package["git"] ],



}



class { "nginx":



worker_connections => 4096,



keepalive_timeout => 120,



client_max_body_size => "200m",



}



nginx::vhost { "$fqdn" :



docroot => "/var/www/home",



}



}

I dont know why but im getting this error...

Error 400 on SERVER: Puppet::Parser::AST::Resource failed with error
ArgumentError: Invalid resource type vcsrepo

Any ideas?¿ Cheers!

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/TLfTqvhPSMwJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Drew Blessing at Dec 6, 2012 at 3:33 pm
    Hi Fran,

    There's a couple of things you can try. First, make sure you have the
    module in your modules directory. I'm fairly sure you have this step done
    but just in case. Then, since vcsrepo uses plugins to accomplish it's
    tasks you need to ensure that the plugins are on both the puppet master and
    on the client. Do a puppet run on both the puppet master and the client
    with the --pluginsync flag and you will likely see a bunch of plugins being
    installed at the beginning of those puppet runs. You will probably not see
    the errors any more.
    On Wednesday, December 5, 2012 11:00:20 AM UTC-6, Fran Rodríguez wrote:

    Hi, i spent all day trying to work the vcsrepo module, without success. Im
    doing my own class like this:

    class rta-frontend {



    vcsrepo { "/var/www/home":



    ensure => present,



    provider => git,



    source => "git@home.org:home.git",


    require => [ File["/root/.ssh/id_rsa.pub"], Package["git"] ],



    }



    class { "nginx":



    worker_connections => 4096,



    keepalive_timeout => 120,



    client_max_body_size => "200m",



    }



    nginx::vhost { "$fqdn" :



    docroot => "/var/www/home",



    }



    }

    I dont know why but im getting this error...

    Error 400 on SERVER: Puppet::Parser::AST::Resource failed with error
    ArgumentError: Invalid resource type vcsrepo

    Any ideas?¿ Cheers!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/uOR73TFdZK4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Fran Rodríguez at Dec 7, 2012 at 12:16 pm
    Hi Drew,

    Yes, i did all what you suggest, ive checked out if the module is in
    master, ive used pluginsync on client so i dont know what to do... how i
    follow...:S

    Cheers and thanks for the answer
    On Thursday, 6 December 2012 13:48:15 UTC+1, Drew Blessing wrote:

    Hi Fran,

    There's a couple of things you can try. First, make sure you have the
    module in your modules directory. I'm fairly sure you have this step done
    but just in case. Then, since vcsrepo uses plugins to accomplish it's
    tasks you need to ensure that the plugins are on both the puppet master and
    on the client. Do a puppet run on both the puppet master and the client
    with the --pluginsync flag and you will likely see a bunch of plugins being
    installed at the beginning of those puppet runs. You will probably not see
    the errors any more.
    On Wednesday, December 5, 2012 11:00:20 AM UTC-6, Fran Rodríguez wrote:

    Hi, i spent all day trying to work the vcsrepo module, without success.
    Im doing my own class like this:

    class rta-frontend {



    vcsrepo { "/var/www/home":



    ensure => present,



    provider => git,



    source => "git@home.org:home.git",



    require => [ File["/root/.ssh/id_rsa.pub"], Package["git"] ],



    }



    class { "nginx":



    worker_connections => 4096,



    keepalive_timeout => 120,



    client_max_body_size => "200m",



    }



    nginx::vhost { "$fqdn" :



    docroot => "/var/www/home",



    }



    }

    I dont know why but im getting this error...

    Error 400 on SERVER: Puppet::Parser::AST::Resource failed with error
    ArgumentError: Invalid resource type vcsrepo

    Any ideas?¿ Cheers!
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/8zKvHPsqWX4J.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 5, '12 at 5:00p
activeDec 7, '12 at 12:16p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Fran Rodríguez: 2 posts Drew Blessing: 1 post

People

Translate

site design / logo © 2022 Grokbase