FAQ
Hi everyone!
we installed Puppet master 2.7.18 from debian backports
Configured it with storeconfig using Postgresql 9.1 and ENC Foreman 1.0.1
When we started migration from old puppet master with LDAP ENC we received
parser errors that he could not insert to db tempate with string
*; Use Sybase-style magic quotes (escape ' with '' instead of \').*
and it look like he does not escapes the quotes. we have pg 0.14.1

any suggestions why is it so?
on old puppetmaster it worked great.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/pKhcqxG4O88J.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Andrei Burd at Dec 6, 2012 at 11:11 am
    we figured out, that the problem was that in Postgres 9.1 they made
    *standard_conforming_strings* was ON by default, that causes problem in
    inserting escape characters to DB.
    On Wednesday, December 5, 2012 9:30:28 PM UTC+2, Andrei Burd wrote:

    Hi everyone!
    we installed Puppet master 2.7.18 from debian backports
    Configured it with storeconfig using Postgresql 9.1 and ENC Foreman 1.0.1
    When we started migration from old puppet master with LDAP ENC we received
    parser errors that he could not insert to db tempate with string
    *; Use Sybase-style magic quotes (escape ' with '' instead of \').*
    and it look like he does not escapes the quotes. we have pg 0.14.1

    any suggestions why is it so?
    on old puppetmaster it worked great.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/ZvuJ21YMbwMJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 5, '12 at 7:30p
activeDec 6, '12 at 11:11a
posts2
users1
websitepuppetlabs.com

1 user in discussion

Andrei Burd: 2 posts

People

Translate

site design / logo © 2022 Grokbase