FAQ
I have two puppet master servers in my fledgling puppet infrastructure, a
production one and a dev one.

I have configured the production one as the authoritative CA, and I have
one test agent machine which I'm switching back and forth with the "server"
option in /etc/puppet/puppet.conf.

When I point the agent at the production server and do puppet agent -t, it
sets /var/lib/puppet/lib to be mode 2755.
When I have the production server (which is its own master) do puppet agent
-t, it sets /var/lib/puppet/lib to be mode 2755.

When I point the agent at the development server and do puppet agent -t, it
sets /var/lib/puppet/lib to be mode 0755.
When I have the development server (which is its own master) do puppet
agent -t, it sets /var/lib/puppet/lib to be mode 0755.

I'm running "service puppetmaster start", and "puppet agent -t", as root on
both servers. The ownership and modes of the directories above
/var/lib/puppet/lib in their trees are identical.

/var/lib/puppet/lib isn't _in_ the modules and manifests paths on either
master.

The only differences in the puppet.confs of the two masters are:
- each master points at itself
- the development one has ca = false and ca_server = production.server.fqdn

How can I determine where /var/lib/puppet/lib's mode should be determined
(and since it's not even in the modules, why are the two masters trying to
control it on the agent)?

--Shawn

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/QfWzlwgEkLEJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Shawn Knight at Dec 3, 2012 at 9:03 pm
    Correction; the mode the production server wants for that directory is
    2775, not 2755. I'm still baffled why the two masters are different and
    managing that directory on the agent.

    --Shawn

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/QKyBO0f2P8oJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 3, '12 at 8:24p
activeDec 3, '12 at 9:03p
posts2
users1
websitepuppetlabs.com

1 user in discussion

Shawn Knight: 2 posts

People

Translate

site design / logo © 2022 Grokbase