I have installed two modules under $confdir/modules:

erwbgy's system module (which depends on augeasproviders)
and augeasproviders

I have a hiera entry:

value: /etc/issue.net

When I do the first "puppet agent --test" run, it always fails with
following error:
Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
Could not autoload puppet/type/sshd_config: Could not autoload
puppet/provider/sshd_config/augeas: no such file to load --
augeasproviders/provider on node ip-10-28-37-186.ec2.internal
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

However, I run "puppet agent --test" again and it always works.

This pattern repeats anytime there was a puppet run failure for any reason
(like syntax error in one of the unrelated manifests files).

I do have "pluginsync=true" in agent's /etc/puppet/puppet.conf file.

Not sure what I need to do fix this. Any pointers appreciated.


You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/tMSl2OJh_rsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
postedDec 1, '12 at 8:47p
activeDec 1, '12 at 8:47p

1 user in discussion

Rajul Vora: 1 post



site design / logo © 2022 Grokbase